Page MenuHomePhabricator

1.17wmf1: recompile wikidiff2
Closed, ResolvedPublic

Description

r80621#c13280: Please recompile wikidiff2 on wikimedia wikis.

Thanks.


Version: unspecified
Severity: enhancement

Details

Reference
bz27720

Event Timeline

bzimport raised the priority of this task from to High.Nov 21 2014, 11:23 PM
bzimport set Reference to bz27720.

Mark B., how far did you get with this? Did you want to wait for lucid?

We likely should wait for lucid, since it will hopefully start transitioning this week or next week.

It there any action to recompile the modules soon?

Is there any action to recompile the wikidiff2 extension soon?

Is there any action to recompile the wikidiff2 extension soon?

Reedy added a comment.Sep 18 2011, 7:09 PM

Looks like this is going to be somewhat dealt with as part of the lucid deployment to the apaches

http://www.mediawiki.org/w/index.php?path=+%2Ftrunk%2Fdebs%2Fwikidiff2&title=Special%3ACode%2FMediaWiki

Will ping Peter regarding this

Reedy added a comment.Sep 18 2011, 7:11 PM

RT #588 was logged about this a while ago

py wrote:

new package has been built for lucid. will be rolled out as I continue to upgrade apaches.

TheDJ added a comment.Oct 23 2011, 9:01 AM

Have all apaches been upgraded, and thus this package rolled out now ?

py wrote:

Yes! Sorry to have not updated sooner. Many bugs closed with lucid upgrades, this one slipped through the cracks.

I have spotchecked some apaches just to make sure, and yes, it is the case that they are now using the newer version of php-wikidiff2

(In reply to comment #10)

I have spotchecked some apaches just to make sure, and yes, it is the case that
they are now using the newer version of php-wikidiff2

Closing

Reopening since the version on Lucid is still the old version of wikidiff2. The idea was to use the new version of wikidiff2 on Lucid, i.e. version 1.1.0, not to just recompile the old buggy code. This was explained on RT #588.