Page MenuHomePhabricator

Rollback of one IPv6 address to another IPv6 address's edit needs shorter edit summary
Closed, DeclinedPublic

Details

Reference
bz37356

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 12:28 AM
bzimport set Reference to bz37356.
bzimport added a subscriber: Unknown Object (MLST).
Jasper created this task.Jun 5 2012, 10:10 PM
aaron added a comment.Jun 5 2012, 10:18 PM

We really should allow larger comments in the revision table. The problem is that the display length is much shorter than the content length. The size limitation is also annoying for the same reason with multi-byte chars.

aaron added a comment.Jun 5 2012, 10:18 PM

We could also abbreviate ips when possible in the link text using '::'.

Stryn added a subscriber: Stryn.Sep 23 2015, 2:48 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2015, 2:48 PM
Tgr added a subscriber: Tgr.Oct 16 2016, 4:03 AM

This is a problem with long usernames as well, not just IPv6 anons. And especially bad for non-Latin usernames which take 3-4 bytes per character.

The good but hard solution is T6714: Epic: Increasing the length of the edit summary. A quick win would be to detect when the summary is too long and fall back to a different message. The current text is Reverted edits by [[Special:Contributions/$2|$2]] ([[User talk:$2|talk]]) to last revision by [[User:$1|$1]] (revertpage message). Something like Reverted edits by [[Special:Contributions/$2]] to last revision by [[User:$1]] would be less pretty but still contain all the information.

Tgr updated the task description. (Show Details)Oct 16 2016, 4:05 AM
Tgr set Security to None.

I think, the link from user:$1 may also be omitted if necessary. Watchers of recent changes usually want to know about the guy whose edit was reverted, sometimes about the reverter. The previous editor is uninteresting and so is worth two clicks (the first being the difflink) in the rare cases.

Abbreviation of IPv6 decreases readability more than the idea of Tgr. Do we know about automated tools (AWB, PYwikibot, Lab tools etc.), how they recognize IPv6 and have a method for expanding? IPv6 usualy appears in total length in logs so they may have not had the reason to develop it. Anyway, modifying the message may be a breaking change for some tools. Perhaps it would be a good idea to prexfix abbreviated messages for the sake of bots and tools with a special character, so that they spare the analysis of every line.

Anomie added a subscriber: Anomie.Mar 4 2018, 6:30 AM
In T39356#2719894, @Tgr wrote:

Now that that has been done, shall we decline this task?

Tgr closed this task as Declined.Mar 4 2018, 8:02 AM

Yeah. Thanks for working on that!