Page MenuHomePhabricator

flowRoot (defined only in deprecated SVG 1.2 draft) not supported by rsvg
Closed, DeclinedPublic

Details

Reference
bz41424

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 22 2014, 12:46 AM
bzimport set Reference to bz41424.
bzimport added a subscriber: Unknown Object (MLST).
TheDJ created this task.Oct 26 2012, 12:43 PM

Why you made a new bug report and converting [[Bugzilla: 5710]]? I've not found you bug and the description is not clear! Because it is not only not supported, it makes large full filled rectangles!

PRO: The description here is much much more clearer then the vague one in bug 5710. It happens that previously filed tickets cannot be find and that duplicates are created. It's not a problem at all if you don't find a bug immediately - you can file a new one and somebody at some point would mark duplicates as such.

Why you made a new bug report and converting Bugzilla:5710 ? I've not found your bug and the description/title is not clear! Because it is not only not supported, it makes large full filled rectangles! Most SVG editors don't know flowRoot.

PRO: Please avoid repetitive comments. I've already explained it in comment 3, plus nobody "converted" Bugzilla:5710. If something is unclear, feel free to send me a private email, as the Bugzilla workflow is not specific to the issue covered in this bug report. Thanks for your understanding!

Andre Klapper: I wanted to edit my post or delete what does not seem to appear.

Andre Klapper: I wanted to edit my post or delete what does not seem to appear. (editing work)

PRO: Stop commenting on this bug report.
Send me private email instead. Thanks.

*** Bug 5710 has been marked as a duplicate of this bug. ***

I propose the close this bug as WONTFIX. Because this flowRoot feature is not part of any SVG standard (it's only contained in a working draft of SVG 1.2) and its usage will almost certainly result in compatibility problems.

It is also beneficial that this flowed text appears as black rectangle (or whatever) to see this false crap code immediately.

TheDJ moved this task from Backlog to Reported Upstream on the Upstream board.Mar 4 2015, 8:59 PM
Menner added a subscriber: Menner.May 7 2015, 4:40 PM

Remark: In SVG2 there will be a attribute called extend. It defines the width of a textline and support a similar feature.
see https://svgwg.org/svg2-draft/text.html#TextLayoutContentArea

I support to mark this bug as WONTFIX.

He7d3r added a subscriber: He7d3r.Jul 9 2015, 6:55 PM

Just to comment, I also support closing this task. As Perhelion said, this element was part of the SVG 1.2 draft, but that was never finalized and was later scrapped. The current standard that was finalized is SVG 1.1 which does not have the flow elements. SVG 2 is being worked on as a potential successor of SVG 1.1, so no reason in asking for support for a element from a now defunct draft.

The required support is to make it clear that it is invalid. Alternativly this bug can be close in favor of a more general error handling task for SVG.

pseudo code:
$errors = validateSvg()
if(empty($errors)) continueUpload()
else {
echo "The SVG is corrapted. Errors: $errors";
}

Aklapper renamed this task from flowRoot not supported by rsvg to flowRoot (defined only in deprecated SVG 1.2 draft) not supported by rsvg.Aug 25 2017, 6:07 PM
Aklapper closed this task as Declined.Sep 8 2017, 8:55 AM

Declining as upstream will not support this (instead, librsvg 2.41.* will ignore unknown elements and all sub-elements).

@Aklapper Was there an recent (this week) update or something?

I can test
https://commons.wikimedia.org/wiki/File:Error-libsvgr-flow.svg
or
https://commons.wikimedia.org/wiki/File:L%C3%B6tschberg_H%C3%B6henprofil.svg
or others,
and all of them do not place a black recktangle.

Second this – noted the sudden change on https://commons.wikimedia.org/wiki/File:FlowRoot_and_flowRegion.svg . Moreover, when I purged https://upload.wikimedia.org/wikipedia/commons/thumb/3/35/Bayesian_Calculus_Summary.svg/1051px-Bayesian_Calculus_Summary.svg.png , black billets disappeared (were present in the cached version). Does this new rsvg making {{SVG 1.2}} obsolete?

@Incnis_Mrsi :
Please check the differences in Rendering between

SVG 1.2SVG 1.1

They should render the same but they do not render the same.

The most common error in https://commons.wikimedia.org/wiki/Category:SVG_files_with_multiple_W3C-errors is the attribute vector-effect=, which is not supported by librsvg. (also this is Task is about flowRoot)

The new rsvg sill does not understand any SVG1.2-code that is not in SVG 1.1.