Page MenuHomePhabricator

Category text "Pages in category "foo"" does not use DISPLAYTITLE
Closed, ResolvedPublic

Description

On category pages, below the top header and above the list of pages in the category, there is an h2 tag containing the text "Pages in category "(page's title)"". The page title used is not the text given through DISPLAYTITLE. This can be a problem on pages like [[wiktionary:Category:Burmese words suffixed with -မား]], where DISPLAYTITLE is used to apply a lang= to the Burmese text in the title, allowing WebFonts to add the correct font, but on the lower line, containing the text "Pages in category "Burmese words suffixed with -မား"", the Burmese text shows up as meaningless boxes for users without the right fonts installed, because the DISPLAYTITLE was not able to affect its content.

Details

Reference
bz44197

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 1:30 AM
bzimport added a project: MediaWiki-Categories.
bzimport set Reference to bz44197.
bzimport added a subscriber: Unknown Object (MLST).

Created attachment 11659
Opera 12.02 screenshot

Not sure if I understand the bug description correctly.
Outcome in Opera 12.02 is that "Pages in category "Burmese words suffixed with -မား"" looks correct while the "Category:" looks wrong.

Attached:

Created attachment 11660
Category page rendered by firefox (looking fine)

Hmm, I kind of have a mixed opinion about this bug.
*On one hand from a practical point of view you guys obviously just need this to work and this is the obvious thing to do to make it work
*OTOH. DISPLAYTITLE changes the title of the page, however it doesn't change the "name" of the category. To categorize something you have to use the actual name of the category. This doesn't make much of a difference on Wikimedia's set up due to display title restrictions (ignoring lang converter), but if unrestricted display title was enabled, then the displaytitle need not having anything to do with the actual category name.

(In reply to comment #1)

Created attachment 11659 [details]
Opera 12.02 screenshot
Not sure if I understand the bug description correctly.
Outcome in Opera 12.02 is that "Pages in category "Burmese words suffixed
with
-မား"" looks correct while the "Category:" looks wrong.

It depends on the fonts you have installed. For me the page title looks correct, and the subheader is a bunch of missing glyph characters. However your screen shot looks rather wrong (Are those unattached combining glyphs jammed in the middle?). But I think that's unrelated, and should maybe be filed as a separate bug for web fonts on opera. [attached is a screenshot for firefox 16.0.1]

Attached:

  • Bug 41720 has been marked as a duplicate of this bug. ***

5 years later - issue still relvant.
I may rebase https://gerrit.wikimedia.org/r/#/c/44766/ to handle other issues with categories display and @Nikerabbit may have a fix for it in https://gerrit.wikimedia.org/r/#/c/305991/

Change 305991 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/core@master] Improve page display title handling for category pages

https://gerrit.wikimedia.org/r/305991

Change 305991 merged by jenkins-bot:
[mediawiki/core@master] Improve page display title handling for category pages

https://gerrit.wikimedia.org/r/305991

matej_suchanek updated the task description. (Show Details)
matej_suchanek removed a subscriber: wikibugs-l-list.
Jdforrester-WMF closed this task as Resolved.Sep 12 2018, 4:25 PM
Jdforrester-WMF assigned this task to Nikerabbit.