Wikitext warning triggered when editing paragraph with wikitext in it, even though none was added in this edit
Closed, ResolvedPublic

Description

In my volunteer mode, I was removing content that was copied from an external site. I didn't add any content at all, but simply deleted text (and a template) and merged the resultant material into a single paragraph.

VisualEditor flagged this as my adding wikimarkup and gave me the nowiki warning. :)

See http://en.wikipedia.org/wiki/File:Wikimarkup_warning_without_case.png which is confusingly titled, because I missed the "u" in "cause."


Version: unspecified
Severity: normal

bzimport added a project: VisualEditor.Via ConduitNov 22 2014, 1:54 AM
bzimport set Reference to bz51751.
Mdennis-WMF created this task.Via LegacyJul 20 2013, 2:55 PM
Thryduulf added a comment.Via ConduitSep 6 2013, 9:07 AM
  • Bug 53661 has been marked as a duplicate of this bug. ***
Thryduulf added a comment.Via ConduitSep 6 2013, 9:08 AM

From bug 53661:
The Wikitext warning is triggered in some circumstances without the user having
entered Wikitext. The one cause I can reliably reproduce is where there is
nowikied markup on the page from a previous edit.

To reproduce:

  1. Load

https://en.wikipedia.org/w/index.php?title=User:Thryduulf/sandbox3&oldid=571089410&veaction=edit

  1. Click anywhere on the last line of Section number two (the line that

contains "[[Manhatan]]" and an ISBN, both of which are enclosed in nowiki
tags).

It seems that the warning is triggered by the existence of wikitext markup in
the VE editing surface, rather than by its addition.

Whatamidoing-WMF added a comment.Via ConduitJan 28 2014, 6:32 PM

I get this error by adding anything to the second paragraph (beginning "VisualEditor" at https://office.wikimedia.org/w/index.php?title=User:Mdennis/sandbox&oldid=105896 There are preëxistng (intentional) nowiki's in this paragraph, which may the cause.

Jdforrester-WMF added a comment.Via ConduitMar 20 2014, 11:11 PM

Fixing this would cause a serious performance penalty for minor improvement in the user experience. WONTFIXing.

gerritbot added a project: Patch-For-Review.Via ConduitNov 25 2014, 10:39 PM

Change 175336 had a related patch set uploaded (by Catrope):
Replace hacky wikitext warning listener with sequences

https://gerrit.wikimedia.org/r/175336

Patch-For-Review

Jdforrester-WMF changed the title from "VisualEditor: Wikitext warning triggered when editing paragraph with wikitext in it, even though none was added in this edit" to "Wikitext warning triggered when editing paragraph with wikitext in it, even though none was added in this edit".Via WebNov 25 2014, 10:40 PM
Jdforrester-WMF reopened this task as "Open".
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF triaged this task as "Normal" priority.
Jdforrester-WMF set Security to None.
Jdforrester-WMF moved this task to Done on the VisualEditor workboard.Via WebNov 25 2014, 10:42 PM
gerritbot added a comment.Via ConduitNov 25 2014, 10:42 PM

Change 175336 merged by jenkins-bot:
Replace hacky wikitext warning listener with sequences

https://gerrit.wikimedia.org/r/175336

Etonkovidova added a subscriber: Etonkovidova.Via WebNov 25 2014, 11:49 PM

Verified in betalabs.

Jdforrester-WMF closed this task as "Resolved".Via WebNov 26 2014, 12:34 AM

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.