VisualEditor: Right floated elements other than images and info boxes are not placed correctly
Closed, ResolvedPublic

Description

There are many templates in Wikipedia that create right floated content other than info boxes and images.

Examples are for instance Template:Stack, but there are many similar templates. These are currently not rendering as right floated.


Version: unspecified
Severity: normal

bzimport set Reference to bz57296.
TheDJ created this task.Via LegacyNov 20 2013, 10:52 AM
TheDJ added a comment.Via ConduitNov 20 2013, 11:02 AM

This is caused by the div block surrounding it, that should receive 'similar' traits in that case.

It is worsened, because in the case of stack in particular also takes fullwidth, due to the broken implementation of inline images with captions. These currently feature a figcaption that has display block, and no width constraint (shouldn't be allowed to be wider than the image frame, but it is).

TheDJ added a comment.Via WebThu, Mar 26, 8:06 PM

This seems mostly fixed to me. Is that correct team ?

Etonkovidova added a subscriber: Etonkovidova.Via WebThu, Mar 26, 8:18 PM

I checked in production some samples from https://en.wikipedia.org/wiki/Template:Stack:

{{stack |[[File:Test.png|thumb|right|Example 2a]] [[File:Test.png|thumb|right|Example 2b]]}}

Without float=left/right parameter - default is right. Is that what's been fixed?

TheDJ added a comment.Via WebThu, Mar 26, 8:36 PM

If I remember correctly, it would be that the right floating stack, was opened in VE as full width and left aligned, pushing all visual adjacent content to be positioned underneath the stack template.

Etonkovidova added a comment.Via WebThu, Mar 26, 9:05 PM

If I remember correctly, it would be that the right floating stack, was opened in VE as full width and left aligned, pushing all visual adjacent content to be positioned underneath the stack template.

Seems to be fixed to me - not happenning anymore: inserting Stack template(with/without specifying float- right) will position the template on the right.

Btw, left - puts the template on the left.

Jdforrester-WMF closed this task as "Resolved".Via WebThu, Mar 26, 9:05 PM
Jdforrester-WMF triaged this task as "Normal" priority.
Jdforrester-WMF set Security to None.

I vaguely think there was another task (since fixed) which this duplicates, but I have no idea what it was called.

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.