Page MenuHomePhabricator

catall.py replaces categories instead of adding them
Closed, ResolvedPublic

Description

Expected behavior: every entered category is added to the page.

Actual behavior: all existing categories are removed, and only the entered ones are placed.

Example: https://nl.wikipedia.org/w/index.php?title=NS_1200_(stoomlocomotief)&diff=39835503&oldid=39835472

Note: this is the case for both core and compat.


Version: core-(2.0)
Severity: major

Details

Reference
bz58549

Event Timeline

bzimport raised the priority of this task from to Unbreak Now!.Nov 22 2014, 2:26 AM
bzimport set Reference to bz58549.
bzimport added a subscriber: Unknown Object (????).

I think this is the expected behaviour.
replaceCategoryLinks() is there since the first revision: https://www.mediawiki.org/wiki/Special:Code/pywikipedia/733

CC: Rob W.W. Hooft & Andre Engels who are listed as the initial copyright holders.

If it is working as intended, the messages need to be clearer, and re-translated, but priority/severity of the bug can be reduced if it isnt a regression.

Gallaecio closed this task as Resolved.Nov 29 2014, 11:27 PM

Merged by @jayvdb.