Page MenuHomePhabricator

mediawiki.js uses console.warn.apply which IE9 does not support
Closed, ResolvedPublic

Description

A test is done to check for console.warn, but none for console.warn.apply

https://git.wikimedia.org/blob/mediawiki%2Fcore/c34f7109fca7fdb60cd528cb1207f51539d9e044/resources%2Fsrc%2Fmediawiki%2Fmediawiki.js#L541


Version: unspecified
Severity: normal

Details

Reference
bz63770

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:13 AM
bzimport set Reference to bz63770.
bzimport added a subscriber: Unknown Object (MLST).

Change 125197 had a related patch set uploaded by MarkAHershberger:
Fix IE9's lack of support for console.warn.apply

https://gerrit.wikimedia.org/r/125197

gerrit 122408 avoids the fatal

TheDJ added a comment.Apr 29 2014, 7:04 PM

When fixed, potentially back port to 1.23 ?

Change 125197 merged by jenkins-bot:
Fix IE9's lack of support for console.warn.apply

https://gerrit.wikimedia.org/r/125197

Change 130502 had a related patch set uploaded by Legoktm:
Fix IE9's lack of support for console.warn.apply

https://gerrit.wikimedia.org/r/130502

Change 130502 merged by jenkins-bot:
Fix IE9's lack of support for console.warn.apply

https://gerrit.wikimedia.org/r/130502