Page MenuHomePhabricator

R2. Bad Flow link targets in usenewrc (Enhanced RC) in watchlist and recentchanges (Portuguese)
Open, MediumPublic2 Estimate Story Points

Description

If I enable “Preferences/Recent changes/Advanced options/Group changes […]”, the watchlist has incorrect behaviour:

  • “diff” and “n changes” are links to “title=Topic:…&curid=0&diff=0&oldid=0” (normal enhanced RC uses numerical IDs here).

See also:

Details

Reference
bz70513
Related Gerrit Patches:
mediawiki/extensions/Flow : masterFix link targets in usenewrc
mediawiki/core : masterAdd hook EnhancedChangesList::getLogText

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 3:55 AM
bzimport set Reference to bz70513.
bzimport added a subscriber: Unknown Object (MLST).
Ltrlg created this task.Sep 7 2014, 9:48 AM

(In reply to Ltrlg from comment #0)

  • all Flow revisions are marked unpatrolled;

Forked into bug 71456

(In reply to Ltrlg from comment #0)

  • “diff” and “n changes” are links to “title=Topic:…&curid=0&diff=0&oldid=0”

(it should be simple text like in normal watchlist).

  • Also the timestamps, which link to “title=Topic:…&curid=0”

Note: Docs at https://meta.wikimedia.org/wiki/Help:Enhanced_recent_changes

(I'll focus this bug ticket on just this aspect. Thanks for the report :) Tracked on trello at https://trello.com/c/c9dxYaQl/

  • Bug 63711 has been marked as a duplicate of this bug. ***
Quiddity removed a subscriber: Maryana.Dec 19 2014, 1:41 AM
DannyH set Security to None.
DannyH edited a custom field.Feb 2 2015, 7:38 PM
Mattflaschen-WMF triaged this task as Medium priority.Feb 3 2015, 6:45 PM
Quiddity renamed this task from Flow: Bad link targets in usenewrc (group changes) in watchlist and recentchanges to Flow: Bad link targets in usenewrc (Enhanced RC) in watchlist and recentchanges.Feb 5 2015, 5:23 AM
Quiddity updated the task description. (Show Details)
Teles added a subscriber: Teles.Feb 5 2015, 6:43 PM
DannyH renamed this task from Flow: Bad link targets in usenewrc (Enhanced RC) in watchlist and recentchanges to Flow: Bad link targets in usenewrc (Enhanced RC) in watchlist and recentchanges (Portuguese).Feb 10 2015, 11:29 PM
Ltrlg added a comment.EditedFeb 11 2015, 1:55 PM

@DannyH: Why “Portuguese”?

markers about particular languages on Collaboration team tickets denote where we can move forward deployments with particular languages by closing the linked ticket. This helps to align the work being done with the wiki's that are moving forward with flow deployment.

DannyH edited a custom field.Feb 25 2015, 7:14 PM
DannyH renamed this task from Flow: Bad link targets in usenewrc (Enhanced RC) in watchlist and recentchanges (Portuguese) to R2. Bad Flow link targets in usenewrc (Enhanced RC) in watchlist and recentchanges (Portuguese).Feb 25 2015, 9:13 PM

Change 193094 had a related patch set uploaded (by Matthias Mullie):
Fix link targets in usenewrc

https://gerrit.wikimedia.org/r/193094

Patch is up. Depends on a couple of fixes in Flow & a core change as well.

I've made a slight change in terminology.
Currently, Enhanced RC says: "X changes" (however many there were) or "diff" (if there's only been only 1 change)
I've also made that say "1 change" instead of "diff", since we're not linking to diff pages, but to the topic with highlighted posts.

Which brings me to another point: a change can also be something that won't pop out when being linked to the topic page with highlighted posts (like a moderated post). I've ignored that for now, since we have no view to display all kind of changes (and well, there's also still al link to history...)

Change 193091 had a related patch set uploaded (by Mattflaschen):
Add hook EnhancedChangesList::getLogText

https://gerrit.wikimedia.org/r/193091

That patch addresses the main line (unexpanded view) well.

However, there are some issues with the ungrouped (expanded view) part.

In the expanded view for a topic, links just go to the topic page with a invalid curid. For example, I created a topic, then made two more posts (one a reply to the initial post). They should show up as
post links, but instead just go to the topic:

<a href="/w/index.php?title=Topic:Scte781slghgc6yq&amp;curid=0" title="Topic:Scte781slghgc6yq">03:48</a>.

It looks like this would probably require another hook

Change 193091 merged by jenkins-bot:
Add hook EnhancedChangesList::getLogText

https://gerrit.wikimedia.org/r/193091

Change 193094 merged by jenkins-bot:
Fix link targets in usenewrc

https://gerrit.wikimedia.org/r/193094

There is still some work that needs to be done in the expanded view, unless we want to make that a separate task.

This seems stalled out, what do we want to do about the expanded view?

DannyH closed this task as Resolved.Mar 19 2015, 9:48 PM

works on Beta

He7d3r updated the task description. (Show Details)Mar 29 2015, 1:19 PM
He7d3r added a subscriber: He7d3r.Apr 3 2015, 6:10 PM

Where is beta?

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 3 2015, 6:10 PM

English beta is http://en.wikipedia.beta.wmflabs.org/wiki/Talk:Flow_QA . There are also beta's in a couple other languages, try switching out the en for other language codes.

He7d3r reopened this task as Open.Apr 3 2015, 6:40 PM

This is not fixed there. I watched "Talk:Flow QA" and "Special:Watchlist" has is a link named "58 changes" which points to
http://en.wikipedia.beta.wmflabs.org/w/index.php?title=Topic:Senqsumbi4s45wtn&fromnotif=1#flow-post-sem8qx52h93lvy1k
However, that page only one comment from "Selenium user", not the "58 changes" I wanted to see.

Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 18 2018, 7:06 PM
SBisson moved this task from Inbox to Triaged but Future on the Growth-Team board.Jul 20 2018, 5:58 PM