Page MenuHomePhabricator

"Ignore" notification level setting has no effect on web notifications
Closed, ResolvedPublic

Description

0) Register, confirm email, subscribe to some tasks and whatever

  1. Visit https://phabricator.wikimedia.org/settings/panel/emailpreferences/
  2. Set some dropdown in "Maniphest Tasks" to "Ignore" (I did "A task's subscribers change." and " A task's associated projects change.")
  3. [Wait.] Visit https://phabricator.wikimedia.org/notification/

I. Expected: no notifications of the ignored kind are shown, i.e. I receive less notifications than the two "higher" levels in the dropdown, "Email" and "Notification". (Expectation confirmed upstream: https://secure.phabricator.com/differential/changeset/?ref=167553&whitespace=ignore-all )
II. Observed: I have several, e.g. https://phabricator.wikimedia.org/T74740#786993 https://phabricator.wikimedia.org/T857#786815 ; those tasks are not in projects I watch, I'm not more than a subscriber to those tasks and I don't have Herald rules enabled (because Herald is disabled for me).

Hoo confirmed he sees several "updated subscribers of" in https://phabricator.wikimedia.org/notification/query/all/ after setting the event to "ignore".

Krenair and Nemo were NOT able to reproduce the bug upstream, https://secure.phabricator.com/T5908#86041 Qgil's hypothesis is that the bug is caused by T765.


Severity: Critical

Event Timeline

Nemo_bis raised the priority of this task from to Unbreak Now!.
Nemo_bis updated the task description. (Show Details)
Nemo_bis added a project: Phabricator.
Nemo_bis changed Security from none to None.
Nemo_bis added a subscriber: Nemo_bis.
Qgil lowered the priority of this task from Unbreak Now! to Low.Nov 27 2014, 7:10 AM
Qgil added a subscriber: Qgil.

There is a possibility that web notifications don't update properly without enabling the notification server. We can have some patience with these issues until T765 is implemented, or we can pull web notifications altogether until we are ready to deploy the full feature.

Meanwhile, it would be useful to test this problem in https://secure.phabricator.com, where the notification server is enabled.

In T76098#790527, @Qgil wrote:

There is a possibility that web notifications don't update properly without enabling the notification server.

I don't think that would cause the reported symptoms here. Not having the server means we will not receive real-time notifications while sitting on a page. The reporter says they do receive notifications when going to the dedicated page (even for categories they shouldn't)

The notifications should always be accurate (even without the server) on a clean refresh of the dedicated page, and anyway the report says there are too many, not too few.

One thing to check is that the triggering event (e.g. a subscriber change) occurred after the preference change. If it occurred before, it may already be in the notification queue.

Qgil lowered the priority of this task from Low to Lowest.Dec 2 2014, 10:05 AM
Qgil edited projects, added Phabricator (Upstream); removed Phabricator.

Alright, then this is a feature missing in Phabricator. After a quick search I couldn't find any task reported upstream.

Alright, then this is a feature missing in Phabricator

A feature missing? What does "Ignore" mean then?

Qgil added a comment.Dec 2 2014, 4:36 PM

The title of that page is "Email preferences". Today "Ignore" means that these updates will not retrieve an email.

Nemo_bis raised the priority of this task from Lowest to Unbreak Now!.Dec 2 2014, 4:36 PM
Aklapper lowered the priority of this task from Unbreak Now! to Low.Dec 2 2014, 4:41 PM
Aklapper added a subscriber: Aklapper.

Now, this is not "Unbreak now" as it's not "need to be fixed immediately". Please respect https://www.mediawiki.org/wiki/Phabricator/Project_management#Priority_levels if you do not plan to work on fixing this. Thank you.

Qgil lowered the priority of this task from Low to Lowest.EditedDec 2 2014, 4:43 PM

Edited: (What Andre said)

Out of control spam is definitely something that needs to be fixed immediately. However, see the edits coming.

Nemo_bis changed the task status from Open to Stalled.Dec 2 2014, 8:21 PM
Nemo_bis raised the priority of this task from Lowest to Needs Triage.
Nemo_bis updated the task description. (Show Details)
In T76098#800171, @Mattflaschen wrote:

One thing to check is that the triggering event (e.g. a subscriber change) occurred after the preference change. If it occurred before, it may already be in the notification queue.

Did anyone check this?

Qgil added a comment.Dec 3 2014, 9:25 AM

Another hypothesis: "(someone) updated subscribers of (some task)" appears in web notifications when someone CCs you manually in a task.

In my preferences I'm ignoring changes in subscribers. However, I do have a couple of notifications of this type in the web notifications. In both, the author subscribed me manually when creating the task.

This would also explain why some popular contributors are seeing this problem here, but not upstream.

Qgil triaged this task as Medium priority.Dec 4 2014, 10:41 AM

Meh, today I see notifications about "(someone) updated subscribers of (some task)" that were not about people CCing me. My previous hypothesis seems to be false, or at least incomplete.

I have aligned my notification preferences here and upstream, and I will keep watching for differences in behavior.

Qgil added a comment.EditedDec 4 2014, 11:08 AM

OK, now I think I have found what is going on.

IF a user performs an action that you should be notified about AND also subscribes to a task at the same time,
THEN your receive an email notification that starts with "(someone) added a subscriber: (someone)." AND this is the string you also get in the web notification (instead of the action that actually triggers the notification.

If this is true, you are not getting more notifications than you deserve; it is only that the "added subscriber" action is listed first and only, when probably listing it last would let you see the real reason for the notification, and would fix the problem reported.

Please check whether this condition works for you as well.

Qgil added a comment.Dec 8 2014, 6:26 AM

Proof of recent "updated subscribers" in my web notifications that in fact are legit, just misnamed:

Etc. I'm going to edit the description of this task relfecting the current situation, pointing to the related task upstream, and prioritizing as Needs Volunteer.

Qgil changed the task status from Stalled to Open.Dec 8 2014, 6:30 AM
Qgil lowered the priority of this task from Medium to Lowest.
Qgil updated the task description. (Show Details)
Qgil moved this task from Need Discussion to Wikimedia requests on the Phabricator (Upstream) board.
Qgil renamed this task from "Ignore" notification level setting has no effect on web notifications to Web notifications for multiple actions only show "updated subscribers".Dec 8 2014, 6:32 AM

I see that this task was morphed into a duplicate of my newly-filed T78257; but this is NOT the issue I reported. Please split back this separate issue instead of hijacking mine.

In particular, comment 0 linked https://phabricator.wikimedia.org/T74740#786993 which is not a subscribers change and is an event of which 100 % subevents are ignored in my preferences.

Qgil closed this task as Resolved.Dec 11 2014, 9:18 AM
Qgil claimed this task.

In theory, this problem has been fixed upstream just a few hours ago, as part of a bigger task: https://secure.phabricator.com/T5604

Resolving now, but needs to be re-checked after T78243: Phabricator upgrade on 2015-01-14

Nemo_bis renamed this task from Web notifications for multiple actions only show "updated subscribers" to "Ignore" notification level setting has no effect on web notifications.Dec 11 2014, 9:20 AM
Nemo_bis reopened this task as Open.
Nemo_bis raised the priority of this task from Lowest to Unbreak Now!.
Nemo_bis updated the task description. (Show Details)
Qgil lowered the priority of this task from Unbreak Now! to Lowest.Dec 11 2014, 9:47 AM

I see that this task was morphed into a duplicate of my newly-filed T78257;

The other way around. Next time you can just "Open" your merged task.

but this is NOT the issue I reported.

I believe both have the same cause, and I'm proposing to wait until the next upgrade to see whether the new behavior fixes both problems.

You have moved descriptions, and to be honest now I'm quite lost. I will just set T78243 as a blocker for both. Also please use Unbreak Now! with caution. I'm sure users can live with this problem. The fact is that none of the Wikimedia Phabricator team members will work on this before the next upgrade, so Needs Volunteer is accurate.

Qgil removed Qgil as the assignee of this task.Dec 11 2014, 11:46 AM
Nemo_bis updated the task description. (Show Details)Dec 18 2014, 8:55 AM

"Personal requests"? What does that mean?

Qgil closed this task as Resolved.Jan 7 2015, 10:43 AM
Qgil claimed this task.
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMay 23 2016, 6:04 PM