Page MenuHomePhabricator

Allow translating pages from different namespaces (not only main namespace)
Closed, ResolvedPublic

Description

Content Translation (CX) does not allow to translate a pages such as http://en.wikipedia.org/wiki/Wikipedia:No_climbing_the_Reichstag_dressed_as_Spider-Man

In the example, that page represents a policy which is available in other languages, and having CX support may have been helpful. This does not seem like a high priority usecase, but if there is a simple way to overcome that limitation, we may want to consider it.

Acceptance criteria

  1. In the new translation dialog, users are able to select Wikipedia:No_climbing_the_Reichstag_dressed_as_Spider-Man
    1. Warnings about the page existing in a given language should be shown as usual
    2. If the namespace does not exist in the target wiki it should not be possible to start the translation.
  2. The user can translate the page in the translation editor.
  3. When the page is published it gets published in the corresponding namespace of the target wiki.
    1. The warnings and options if the page already exist should be applied.

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterDon't localize the namespace unnecessarily

Event Timeline

Pginer-WMF raised the priority of this task from to Low.
Pginer-WMF updated the task description. (Show Details)
Pginer-WMF added a project: ContentTranslation.
Pginer-WMF added a subscriber: Pginer-WMF.
Amire80 closed this task as Resolved.Jun 25 2015, 10:59 PM
Amire80 claimed this task.
Amire80 added a subscriber: Amire80.

This is already possible.

Mavrikant reopened this task as Open.Jun 25 2015, 11:26 PM
Mavrikant set Security to None.

Amire80, nope it is not.

Amire80 moved this task from Needs Triage to CX6 on the ContentTranslation board.Jul 3 2015, 2:56 PM

Do we have a priority of non-ns0 spaces? Wikipedia and Help pages are useful to be translated, I'm ok if you focus on those after the ns0-step, but please don't forget the "navbox" templates.

They are part of the articles.

For example on itwiki their code is very similar to enwiki ("|title =", "|groupstyle = "...), i always thought it was an "easy" option to implement. I am here if you need to test a beta in the future.

Actually, as far as I can see, it does work already, but there are some issues with it. For example, namespace names are incorrectly translated.

Content Translation's priority is content, but the existing bugs are relatively easy, so this might be properly closed some time soon. (Patches always welcome ;) )

Amire80 removed Amire80 as the assignee of this task.Jul 11 2015, 9:43 AM
Pginer-WMF moved this task from CX6 to CX7 on the ContentTranslation board.Jul 21 2015, 4:20 PM
Amire80 moved this task from CX7 to CX6 on the ContentTranslation board.Jul 29 2015, 10:39 PM

This seems to be the cause for this comment.

@Amire80, I've tried with [[ Wikipedia:WikiProject_Medicine/Translation_task_force/RTT/Simple_eating_disorder | this page ]] and while the "new translation" dialog was able to find it, once I started the translation I got an empty page with the error
"The "Viquipèdia:WikiProject Medicine/Translation task force/RTT/Simple eating disorder" page could not be found in English Wikipedia". It seems the problem is that it seems to look the source article using the namespace translated to the target language (i.e., "Viquipedia:" instead of "Wikipedia:").


If one could set the source url and the article it is replacing that would be great.

So for this article I want [[Wikipedia:WikiProject_Medicine/Translation_task_force/RTT/Simple_eating_disorder]] to substitute for "Eating disorder" with the completed translation occurring at the term eating disorder and linking to it.

If one could set the source url and the article it is replacing that would be great.
So for this article I want [[Wikipedia:WikiProject_Medicine/Translation_task_force/RTT/Simple_eating_disorder]] to substitute for "Eating disorder" with the completed translation occurring at the term eating disorder and linking to it.

It seems that T105130: Make finding articles to translate be more flexible (accepting URL and more) will also help with this usecase. I added an example based on this to the ticket.

Amire80 raised the priority of this task from Low to Medium.Sep 4 2015, 4:18 PM

Change 236047 had a related patch set uploaded (by Amire80):
Don't localize the namespace unnecessarily

https://gerrit.wikimedia.org/r/236047

Change 236047 merged by jenkins-bot:
Don't localize the namespace unnecessarily

https://gerrit.wikimedia.org/r/236047

Amire80 claimed this task.Sep 22 2015, 3:14 PM
Amire80 removed a project: Patch-For-Review.

To me it seems to be fixed in production, but because I submitted the patch I'd love somebody else to verify :)

@Pginer-WMF, @Doc_James, @Mavrikant, can you verify that it's fixed, please?

To me it seems to be fixed in production, but because I submitted the patch I'd love somebody else to verify :)
@Pginer-WMF, @Doc_James, @Mavrikant, can you verify that it's fixed, please?

I tried to start a translation for the example I mentioned in the description ( http://en.wikipedia.org/wiki/Wikipedia:No_climbing_the_Reichstag_dressed_as_Spider-Man ) and I can reach the translation editor without issues, but I have not checked what happens when publishing (which we need to check before closing this). Regarding publishing we probably need to check it works when publishing to (a) the equivalent namespace, (b) a different namespace (by changing the target title), and (c) the main namespace of the target wiki (by changing the target title)

To me it seems to be fixed in production, but because I submitted the patch I'd love somebody else to verify :)
@Pginer-WMF, @Doc_James, @Mavrikant, can you verify that it's fixed, please?

I tried to start a translation for the example I mentioned in the description ( http://en.wikipedia.org/wiki/Wikipedia:No_climbing_the_Reichstag_dressed_as_Spider-Man ) and I can reach the translation editor without issues, but I have not checked what happens when publishing (which we need to check before closing this). Regarding publishing we probably need to check it works when publishing to (a) the equivalent namespace, (b) a different namespace (by changing the target title), and (c) the main namespace of the target wiki (by changing the target title)

The equivalent namespace is set as the default namespace if the user didn't write anything else, so this should fulfill (a).

(b) and (c) are also supposed to work as you describe.

Amire80 closed this task as Resolved.Oct 8 2015, 6:43 PM

Cleaning up the ContentTranslation-Release6 board, and it works as far as I can see. Please reopen if anything is still broken.