Page MenuHomePhabricator

UploadWizard: File name is not allowed
Closed, ResolvedPublic

Description

Lots of reports about similar issues, with some variance in the exact error message, resulting in the upload failing:

Seems deterministic and reproducible for different users with the same files; the files upload fine with the old interface.

Some of it might be fallout from T86680 but seems unlikely.

Details

Related Gerrit Patches:
mediawiki/core : wmf/1.25wmf14Bring UploadWizard submodule up to date
mediawiki/core : wmf/1.25wmf15Bring UploadWizard submodule up to date
mediawiki/extensions/UploadWizard : wmf/1.25wmf14Fix formdata filename field
mediawiki/extensions/UploadWizard : wmf/1.25wmf15Fix formdata filename field
mediawiki/extensions/UploadWizard : masterFix formdata filename field

Event Timeline

Tgr created this task.Jan 16 2015, 9:19 PM
Tgr raised the priority of this task from to High.
Tgr updated the task description. (Show Details)
Tgr added a project: UploadWizard.
Tgr added a subscriber: Tgr.
Restricted Application added a project: Multimedia. · View Herald TranscriptJan 16 2015, 9:19 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Tgr added a comment.EditedJan 16 2015, 9:29 PM

According to the linked discussions, error messages are file name is not allowed, this type of file is banned, badupload_file, The stashed file was not found when attempting to upload it from the stash (this one probably unrelated, but who knows).

Tgr updated the task description. (Show Details)Jan 16 2015, 9:30 PM
Tgr set Security to None.

If someone could share an affected file without uploading it to Commons, that would be helpful.

Tgr added a comment.Jan 16 2015, 9:57 PM
In T87062#982992, @Tgr wrote:

According to the linked discussions, error messages are file name is not allowed, this type of file is banned, badupload_file, The stashed file was not found when attempting to upload it from the stash (this one probably unrelated, but who knows).

this type of file is banned is filetype-banned (or api-error-filetype-banned).
The stashed file was not found when attempting to upload it from the stash is api-error-stashedfilenotfound.

I can't find file name is not allowed` but [api-error-]illegal-filename is close enough (The filename is not allowed.).

Sorry, I translated the message without retry. The exact message is in German Der Dateiname ist nicht erlaubt. In English The filename is not allowed.

There you have a file not uploaded and failing with the same message. Name on local disk is 20150103_15-32-20_01.3.jpg.

I know that the name is not legal for the final naming, but until yesterday it was possible to rename after the upload to stash. But I tried a similar file renamed to Ernst Uray.jpg and it did not work either.

This comment was removed by Aklapper.
Tgr added a comment.Jan 17 2015, 1:48 AM

Thanks for the details!

Tgr added a comment.Jan 17 2015, 1:55 AM

Is this really a bug? Uploads failing due to title blacklist issues after one has went through the effort to fill out the description is a weird thing and seems to be responsible for a significant amount of aborted uploads (T77827; see stats here). Is there any disadvantage of these errors happening sooner? Are they happening in a more disturbing / less informative way?

Tgr added a comment.Jan 17 2015, 1:56 AM

Eh, stupid question. I still had the old upload form in mind. In UW you can't rename the file until the description step...

Rillke changed Security from None to Other confidential issue.Jan 17 2015, 1:14 PM
Restricted Application added a project: WMF-NDA. · View Herald TranscriptJan 17 2015, 1:14 PM
Restricted Application changed the visibility from "Public (No Login Required)" to "Custom Policy". · View Herald Transcript
Restricted Application changed the edit policy from "All Users" to "Custom Policy". · View Herald Transcript
Aklapper changed the visibility from "Custom Policy" to "Custom Policy".
Aklapper changed the edit policy from "Custom Policy" to "Custom Policy".
Restricted Application added a project: WMF-NDA. · View Herald TranscriptJan 18 2015, 1:52 AM
Tgr added a comment.Jan 18 2015, 5:28 AM
Content-Disposition: form-data; name="filename"
-----------------------------202708882616013225741163437014

As Lupo pointed out on-wiki, the filename is missing.

It only happens in FF, in Safari the upload via UW succeeds. So it is unlikely the internet provider.

The upload with FF and Upload Wizard works for me on one computer, does not work on another. Different providers.

I now tried Computer A (which produces upload error messages with two different Internet providers) with the third Internet provider, and upload with the Wizard failed as well with the exact same message "badupload_image". Wizard upload using Computer B with this third Internet provider works without any error messages. I can't test Computer B with the first two Internet providers because I can't really move it. I'm using the latest Firefox (with Adblock enabled, but disabling it doesn't change anything) on both computers.

Aklapper changed the visibility from "Custom Policy" to "Public (No Login Required)".
Aklapper changed the edit policy from "Custom Policy" to "All Users".
Aklapper changed Security from Other confidential issue to None.

FYI, I have removed a comment in this task that contained personal data and afterwards removed the custom access policy again.

Tgr added a comment.Jan 28 2015, 8:33 PM
This comment was removed by Tgr.
gerritbot added a subscriber: gerritbot.

Change 187317 had a related patch set uploaded (by Gilles):
Fix formdata filename field

https://gerrit.wikimedia.org/r/187317

Patch-For-Review

Gilles claimed this task.Jan 29 2015, 1:42 AM
Gilles moved this task from Untriaged to Needs code review on the Multimedia board.

Change 187317 merged by jenkins-bot:
Fix formdata filename field

https://gerrit.wikimedia.org/r/187317

I still get „badupload_file“.

@Rosenzweig locally? This hasn't been deployed to production yet. The fix is verifiable on commons beta, though.

Change 187697 had a related patch set uploaded (by Gilles):
Fix formdata filename field

https://gerrit.wikimedia.org/r/187697

Patch-For-Review

Change 187698 had a related patch set uploaded (by Gilles):
Fix formdata filename field

https://gerrit.wikimedia.org/r/187698

Patch-For-Review

Change 187699 had a related patch set uploaded (by Gilles):
Bring UploadWizard submodule up to date

https://gerrit.wikimedia.org/r/187699

Patch-For-Review

Change 187697 merged by jenkins-bot:
Fix formdata filename field

https://gerrit.wikimedia.org/r/187697

Change 187698 merged by jenkins-bot:
Fix formdata filename field

https://gerrit.wikimedia.org/r/187698

Change 187700 had a related patch set uploaded (by Gilles):
Bring UploadWizard submodule up to date

https://gerrit.wikimedia.org/r/187700

Patch-For-Review

Change 187699 merged by MarkTraceur:
Bring UploadWizard submodule up to date

https://gerrit.wikimedia.org/r/187699

Change 187700 merged by MarkTraceur:
Bring UploadWizard submodule up to date

https://gerrit.wikimedia.org/r/187700

Herzi.Pinki added a comment.EditedFeb 4 2015, 3:22 PM

Upload through UW worked for me this morning on FF, but now (after 14 UTC) no upload happens again. The behavior is different: I get the ''share from Flickr'' button. Upload through UW does not with Safari either, same behavior.

To clarify:
After selecting a file, I see the usual box for a single file with the original name and the remove button, but no spinning 'I'm uploading' icon to the right. And that's what is happening: no upload.

Below I have two buttons named (with &uselang=en)

  • Add more files
  • Share images from Flickr

No idea whether this is the same problem or something different. There was a similar problem with the Flickr-button, I remember.

Tgr added a comment.Feb 4 2015, 3:59 PM

I get the ''share from Flickr'' button.

Can you clarify what you mean by that?

Do you think it is still the same bug, or something unrelated?

Herzi.Pinki added a comment.EditedFeb 4 2015, 4:23 PM

Do you think it is still the same bug, or something unrelated?

Could be unrelated, but I don't know. Do you need more diagnostic data?

See also T88576

MarkTraceur moved this task from Needs backport to Doing on the Multimedia board.Feb 4 2015, 5:50 PM
Tgr closed this task as Resolved.Feb 4 2015, 6:24 PM

Lack of next button is T88576 which is unrelated. Closing this as fixed.

Jdforrester-WMF moved this task from Doing to Done on the Multimedia board.Oct 23 2015, 4:59 PM
Restricted Application added subscribers: Steinsplitter, Matanya. · View Herald TranscriptOct 23 2015, 4:59 PM