Page MenuHomePhabricator

Fix Flow scenarios that fail at en.wikipedia.beta.wmflabs.org or do not run them daily
Closed, ResolvedPublic

Related Objects

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

Elena will check this over.

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 22 2015, 7:08 PM
DannyH renamed this task from Fix failed Flow browsertests Jenkins jobs to A5. Fix failed Flow browsertests Jenkins jobs.Apr 22 2015, 8:04 PM
DannyH moved this task from Current workboard to Untriaged on the Collaboration-Team-Triage board.
hashar updated the task description. (Show Details)Apr 24 2015, 10:03 AM

Rephrasing the task details. The Echo and Flow jobs are listed at https://integration.wikimedia.org/ci/view/BrowserTests/view/Echo+Flow/

They are now failing with:

"timed out after 5 seconds, waiting for {:name=>"topiclist_content", :tag_name=>"textarea"} to become present (Watir::Wait::TimeoutError)"

Change 206880 had a related patch set uploaded (by Catrope):
Hover on the post action menu instead of clicking on it

https://gerrit.wikimedia.org/r/206880

Change 206880 merged by jenkins-bot:
Hover on the post action menu instead of clicking on it

https://gerrit.wikimedia.org/r/206880

Change 207527 had a related patch set uploaded (by Catrope):
Make browser tests work with or without visual editor

https://gerrit.wikimedia.org/r/207527

Change 207527 merged by jenkins-bot:
Make browser tests work with or without visual editor

https://gerrit.wikimedia.org/r/207527

Change 209000 had a related patch set uploaded (by Sbisson):
Fix browser tests

https://gerrit.wikimedia.org/r/209000

Change 209000 merged by jenkins-bot:
Fix browser tests

https://gerrit.wikimedia.org/r/209000

Change 209127 had a related patch set uploaded (by Sbisson):
Fix javascript detection on load

https://gerrit.wikimedia.org/r/209127

Change 209127 merged by jenkins-bot:
Browser tests: fix javascript detection on load

https://gerrit.wikimedia.org/r/209127

Change 209239 had a related patch set uploaded (by Sbisson):
Move tooltip to the right

https://gerrit.wikimedia.org/r/209239

Change 209239 merged by jenkins-bot:
Move tooltip to the right

https://gerrit.wikimedia.org/r/209239

DannyH closed this task as Resolved.May 6 2015, 8:31 PM
zeljkofilipin renamed this task from A5. Fix failed Flow browsertests Jenkins jobs to Fix or delete failing Flow browsertests Jenkins jobs.Sep 25 2015, 1:39 PM
zeljkofilipin reopened this task as Open.
zeljkofilipin removed SBisson as the assignee of this task.
zeljkofilipin updated the task description. (Show Details)
zeljkofilipin edited a custom field.
zeljkofilipin moved this task from Done to Waiting on the Browser-Tests-Infrastructure board.
zeljkofilipin added a subscriber: SBisson.
zeljkofilipin lowered the priority of this task from High to Normal.Sep 25 2015, 2:25 PM

The IE job can be deleted since it's never going to pass unless we recreate the IE browser factory in mediawiki_selenium.

The other jobs are passing once in a while. I pay close attention to the browser tests. I run them locally every morning and even though they are pretty much stable locally, they still fail for the most random reasons on Jenkins/Saucelabs.

I would like to keep them and see them green more often than not. Any help or advice you can provide would be appreciated.

@SBisson: I will delete IE job until T114362 is fixed.

Change 242887 had a related patch set uploaded (by Zfilipin):
Deleted failing Flow browsertests Jenkins job

https://gerrit.wikimedia.org/r/242887

All other jobs are failing because of T114368.

@SBisson: as a first step, I would recommend not running scenarios that fail in Jenkins. When the jobs are back to green, we can debug the scenarios that fail. I can create a patch if you agree.

@SBisson: as a first step, I would recommend not running scenarios that fail in Jenkins. When the jobs are back to green, we can debug the scenarios that fail. I can create a patch if you agree.

I have done a lot of work on those tests. I run them locally every morning and I haven't seen a failure in weeks. But if you can reproduce and fix some of the instability we see in jenkins, please do!

One thing I have seen quite often in jenkins is:
Exception Caught: Could not find local user data for New user 72425089784816018079612099150495189889@metawiki (internal_api_error_Exception) (MediawikiApi::ApiError)
We create new users all the time in the opt-in tests and sometimes it fails like this. I've never seen it locally.

Change 242887 merged by jenkins-bot:
Deleted failing Flow browsertests Jenkins job

https://gerrit.wikimedia.org/r/242887

SBisson closed this task as Resolved.Nov 3 2015, 5:41 PM

Flow browser tests are being monitored on a daily basis for regression and instability. Quick changes are being done right away while bigger issues are being logged and prioritized. They are still failing often (not always) but they are getting better.

zeljkofilipin reopened this task as Open.Nov 4 2015, 4:04 PM

Hm, as far as I can see, all Flow browser test jobs are still failing:

https://integration.wikimedia.org/ci/view/BrowserTests/view/Flow/

zeljkofilipin removed zeljkofilipin as the assignee of this task.Nov 5 2015, 11:44 AM
zeljkofilipin removed a project: Patch-For-Review.
zeljkofilipin moved this task from Next to Ruby on the Browser-Tests-Infrastructure board.
DannyH removed a subscriber: DannyH.Nov 6 2015, 12:49 AM

Change 271539 had a related patch set uploaded (by Zfilipin):
Deleting @login Cucumber tag

https://gerrit.wikimedia.org/r/271539

Change 272471 had a related patch set uploaded (by Zfilipin):
Disable scenarios that fail at en.wikipedia.beta.wmflabs.org from running daily

https://gerrit.wikimedia.org/r/272471

zeljkofilipin renamed this task from Fix or delete failing Flow browsertests Jenkins jobs to Disable Flow scenarios that fail at en.wikipedia.beta.wmflabs.org from running daily.Feb 22 2016, 3:39 PM

Change 272471 merged by jenkins-bot:
Disable scenarios that fail at en.wikipedia.beta.wmflabs.org from running daily

https://gerrit.wikimedia.org/r/272471

zeljkofilipin renamed this task from Disable Flow scenarios that fail at en.wikipedia.beta.wmflabs.org from running daily to Fix Flow scenarios that fail at en.wikipedia.beta.wmflabs.org or do not run them daily.Feb 25 2016, 3:15 PM

Change 274355 had a related patch set uploaded (by Zfilipin):
Disable scenarios that fail at en.wikipedia.beta.wmflabs.org from running daily

https://gerrit.wikimedia.org/r/274355

zeljkofilipin removed zeljkofilipin as the assignee of this task.Mar 10 2016, 2:11 PM

Change 274355 merged by jenkins-bot:
Disable scenarios that fail at en.wikipedia.beta.wmflabs.org from running daily

https://gerrit.wikimedia.org/r/274355

Change 277261 had a related patch set uploaded (by Zfilipin):
Followup 9eaa667: Use @skip instead so it's more obvious and greppable

https://gerrit.wikimedia.org/r/277261

zeljkofilipin removed zeljkofilipin as the assignee of this task.Mar 21 2016, 11:21 AM
zeljkofilipin closed this task as Resolved.Mar 29 2016, 9:43 AM
zeljkofilipin claimed this task.

Change 277261 abandoned by Mattflaschen:
Followup 9eaa667: Use @skip instead so it's more obvious and greppable

Reason:
Seems this approach is not the best solution for the current failures.

https://gerrit.wikimedia.org/r/277261