[Migrated] Option to increase number of articles loaded from Random pages
Closed, ResolvedPublic

Description

Is there a way to increase the number of articles loaded from Random pages from 20? For example, 500 per click, as with New pages. @Discospinster 23:12, 28 October 2014 (UTC)

Reguyla updated the task description. (Show Details)
Reguyla raised the priority of this task from to Needs Triage.
Reguyla added a project: AutoWikiBrowser.
Reguyla moved this task to Feature request (unsorted) on the AutoWikiBrowser board.
Reguyla added a subscriber: Reguyla.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 21 2015, 5:14 PM

@Magioladitis 11:09, 19 November 2014 (UTC) wrote:

Very expensive query. Already requested, discussed and declined.

@Discospinster 13:11, 19 November 2014 (UTC) wrote:
Can you give me a link to the discussion? I'm unable to find it by the search function.

Magioladitis closed this task as Declined.Jul 7 2015, 2:20 PM
Magioladitis claimed this task.

The MediaWiki API has a limit of 10 pages for users, 20 for bots
https://en.wikipedia.org/w/api.php
You would have to arrange an API change to get 100 random pages in one go.

I for one press the random articles buttons at least 100 times before running AWB. Isn't that even more expensive than just have 1000 random pages generated at once? In WPCleaner you can set the number of random articles as high as you want (at least as high as I've ever tried).

Josve05a added a subscriber: NicoV.EditedJul 7 2015, 2:23 PM

@Magioladitis refer to my comment. @NicoV seems to have figured out a way to do it, despite the api-rules. Why cant we? And if the api-rule is a problem, we can possibly upstream this tcket to have it "fixed" by a MediaWiki-API dev.

Josve05a reopened this task as Stalled.Jul 7 2015, 2:26 PM
Josve05a added a project: MediaWiki-API.

NicoV provides random pages between 0 and 50 by using multiple calls. We see no reason to allow multiple calls. Just press the Random pages twice. Same numbers of clicks.

Well, I only get 10 pages per click, and my computer is a bit slow, so it takes about 15 minutes to rack up the amount of articles I want and my finger hurts. How about a way for AWB to auto-click the button x times or something :P
Pressing a button which takes 3-4 seconds to load (on my PC) about 100 times isn't sustainable.

And now imagine the workload caused to the Wikimedia servers of this action... :)

Josve05a added a comment.EditedJul 7 2015, 2:33 PM

It still does the same workload on their servers if I only press the button once or 100 times, right? What if we have a "AWB will only get 10 pages per 2 seconds, but will automaticle fetch 1000 random articles in 8 minuts" or something? That would mean AWB would do the "clicking" instead of me.

Edited: It still does the same workload on their servers if I only press the button once for 1000 random articles or press the button 100 times for 10 articles each, right?

Anomie added a subscriber: Anomie.Jul 7 2015, 4:34 PM

I don't see any particular reason why the limit couldn't be raised. The original patch from T14816 / r30217 doesn't seem to have had any reason given for the current very-low limits.

Change 223342 had a related patch set uploaded (by Anomie):
API: Improve list=random

https://gerrit.wikimedia.org/r/223342

Anomie moved this task from Unsorted to Needs Review on the MediaWiki-API board.Jul 7 2015, 4:43 PM
Anomie added a comment.Jul 7 2015, 4:49 PM

It still does the same workload on their servers if I only press the button once or 100 times, right?

Not really. One query for 1000 pages has less overhead (e.g. connection setup if you're not using keepalive, receiving and routing the request, processing the MediaWiki startup, processing the parameters, connecting to the database, issuing database queries, formatting the result) than 100 queries for 10 pages each.

Josve05a moved this task from Backlog to Make list on the AutoWikiBrowser board.Aug 22 2015, 10:08 PM
Magioladitis triaged this task as Low priority.Aug 24 2015, 4:12 PM
Magioladitis set Security to None.

Since AWB just uses the API function. there is not action on AWB's side needed.

Change 223342 merged by jenkins-bot:
API: Improve list=random

https://gerrit.wikimedia.org/r/223342

Magioladitis lowered the priority of this task from Low to Lowest.Sep 10 2015, 12:03 PM

The API change should be deployed to WMF wikis with 1.26wmf23, see https://www.mediawiki.org/wiki/MediaWiki_1.26/Roadmap for the schedule. Not closing the bug in case there's anything AWB needs to do to take advantage of it, since this is mainly an AWB bug.

Anomie moved this task from Needs Review to Done on the MediaWiki-API board.
Reedy closed this task as Resolved.Sep 19 2015, 5:42 PM
Reedy added a subscriber: Reedy.

The API change should be deployed to WMF wikis with 1.26wmf23, see https://www.mediawiki.org/wiki/MediaWiki_1.26/Roadmap for the schedule. Not closing the bug in case there's anything AWB needs to do to take advantage of it, since this is mainly an AWB bug.

Nothing to do here, we're already passing rnlimit=max :)

Thanks Brad!

Confirmed :) Using rev 11328I'm getting 500 random articles for enwp when trying. Thanks!