Page MenuHomePhabricator

syntax highlight not done on mobile/android
Closed, ResolvedPublic

Description

syntax highlight (#mediawiki-extensions-syntaxhighlight_geshi) is not done on mobile/android

https://en.wikipedia.org/wiki/Atom_(standard)#Example_of_an_Atom_1.0_feed

compare desktop vs. mdot vs. Android

Event Timeline

jeremyb-phone raised the priority of this task from to Needs Triage.
jeremyb-phone updated the task description. (Show Details)
jeremyb-phone added a subscriber: jeremyb.
Restricted Application added a project: Readers-Web-Backlog. · View Herald TranscriptMay 27 2015, 9:01 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
phuedx added a subscriber: phuedx.

If we were to deliver GeSHi modules as part of the page, then we'll need to know their size and make a call. We might be able to include a button that enables highlighting so we need only load the modules when necessary.

MaxSem added a subscriber: MaxSem.Jun 2 2015, 9:22 PM

That's already the case - only CSS that's actually needed is loaded. Of course, if you have 10 different languages on a page you'll get 10 stylesheets, but that'll be in total harmony with growth of page HTML. A unified stylesheet might be coming with my Chechil work.

TheDJ added a subscriber: TheDJ.Jun 8 2015, 2:16 PM

With bottom loaded CSS modules, i see no reason not to add this to the mobile site. You can quickly test how it looks by opening an inspector on the above page and running:

mw.loader.load( 'https://en.m.wikipedia.org/w/load.php?modules=ext.geshi.language.xml&only=styles', 'text/css' );
mw.loader.load( 'https://en.m.wikipedia.org/w/load.php?modules=ext.geshi.language.html5&only=styles', 'text/css' );

The biggest problem is that ALL modules (including pure CSS addModuleStyles modules) are added to the list of module definitions, which will make that part explode on all mobile pages because of the 'many' languages. Some 5768 characters according to my text editor....

Perhaps we can fix those module definitions for pure CSS modules to not endlessly pollute the JS module definition table ? I think we had some discussion about this in the FEG meetings.... gilles and Krinkle might be interested in this...

Change 220115 had a related patch set uploaded (by TheDJ):
Enable syntaxhighlighting on mobile target

https://gerrit.wikimedia.org/r/220115

Change 220115 merged by jenkins-bot:
Enable syntaxhighlighting on mobile target

https://gerrit.wikimedia.org/r/220115

Florian added a subscriber: Florian.

We should announce this in Tech news and other channels covered by User-notice, i'm not sure, but for me, mobile syntaxhighlight is a big deal, but is it "enough" to have an extra line? :)

We should announce this in Tech news and other channels covered by user-notice, i'm not sure, but for me, mobile syntaxhighlight is a big deal, but is it "enough" to have an extra line? :)

I'll leave this task open until it's announced.

Jdforrester-WMF closed this task as Resolved.Jun 24 2015, 10:32 PM
Jdforrester-WMF assigned this task to TheDJ.
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Guillaume confirmed he'll see it even when closed.