Page MenuHomePhabricator

fancycaptchareload paraminfo failure on test wikis
Closed, ResolvedPublic

Description

There is a failure when loading paraminfo of all modules from test.wikidata.org

https://travis-ci.org/wikimedia/pywikibot-core/jobs/64542253#L802

I diagnosed a very similar problem on en wp beta, and it was the fancycaptchareload module causing the breakage.

http://en.wikipedia.beta.wmflabs.org/w/api.php?action=paraminfo&modules=fancycaptchareload&maxlag=5&format=json

very likely to be the same problem on the test wikis also, as we see the same 503 error for test.wikidata.org

https://test.wikidata.org/w/api.php?action=paraminfo&modules=fancycaptchareload&maxlag=5&format=json

however that module isnt deployed to test.wikipedia.org

https://test.wikipedia.org/w/api.php?action=paraminfo&modules=fancycaptchareload&maxlag=5&format=json

Adding 'MediaWiki-API' as I cant find a 'fancycaptcha' extension in Phabricator.

Details

Related Gerrit Patches:
mediawiki/extensions/ConfirmEdit : REL1_25Fix issues from recent extension registration changes
mediawiki/extensions/ConfirmEdit : masterFix issues from recent extension registration changes
mediawiki/extensions/ConfirmEdit : wmf/1.26wmf8Fix issues from recent extension registration changes
mediawiki/extensions/ConfirmEdit : masterRegistration: fix path to ApiFancyCaptchaReload.php

Event Timeline

jayvdb created this task.May 29 2015, 10:56 AM
jayvdb raised the priority of this task from to Unbreak Now!.
jayvdb updated the task description. (Show Details)
jayvdb added subscribers: jayvdb, greg.
Restricted Application added subscribers: Aklapper, Unknown Object (MLST). · View Herald TranscriptMay 29 2015, 10:56 AM
Anomie added a subscriber: Anomie.May 29 2015, 1:40 PM

The FancyCaptcha related portion of this bug appears to have been caused by Gerrit change 212566. I'll submit a patch as soon as I finish testing the fix and seeing what's up with testwiki.

Change 214609 had a related patch set uploaded (by Ricordisamoa):
Registration: fix path to ApiFancyCaptchaReload.php

https://gerrit.wikimedia.org/r/214609

@Anomie: whoops, sorry for the clash. I can abandon my change if you want.

jeremyb-phone set Security to None.May 29 2015, 1:49 PM
jeremyb-phone added a subscriber: jeremyb.

Oh. testwiki isn't actually throwing an error. Why did you drag that red herring in?

Change 214610 had a related patch set uploaded (by Anomie):
Fix issues from recent extension registration changes

https://gerrit.wikimedia.org/r/214610

@Anomie: whoops, sorry for the clash. I can abandon my change if you want.

No problem. I prefer moving ApiFancyCaptchaReload.php into the FancyCaptcha subdir instead of referencing it at its current location, though, and I fixed some errors in ReCaptcha too.

Change 214609 abandoned by Ricordisamoa:
Registration: fix path to ApiFancyCaptchaReload.php

Reason:
per Anomie

https://gerrit.wikimedia.org/r/214609

Change 214610 merged by jenkins-bot:
Fix issues from recent extension registration changes

https://gerrit.wikimedia.org/r/214610

Change 214620 had a related patch set uploaded (by Florianschmidtwelzow):
Fix issues from recent extension registration changes

https://gerrit.wikimedia.org/r/214620

Change 214620 merged by jenkins-bot:
Fix issues from recent extension registration changes

https://gerrit.wikimedia.org/r/214620

Anomie closed this task as Resolved.May 29 2015, 3:19 PM

Fixed and backported.

Change 214668 had a related patch set uploaded (by Florianschmidtwelzow):
Fix issues from recent extension registration changes

https://gerrit.wikimedia.org/r/214668

Change 214668 merged by jenkins-bot:
Fix issues from recent extension registration changes

https://gerrit.wikimedia.org/r/214668

jayvdb moved this task from Backlog to Upstream on the Pywikibot-tests board.Jul 5 2015, 10:03 PM