Page MenuHomePhabricator

MWException after account creation on wikitech
Closed, ResolvedPublic

Description

I tried to create an account ("hexmode") on wikitech and got the following:

MediaWiki internal error.

Exception caught inside exception handler.

Set $wgShowExceptionDetails = true; at the bottom of LocalSettings.php to show detailed debugging information.

(Yes, I know I already have an account on the wiki. This was an effort to test account creation when the account is in SUL.)

Event Timeline

MarkAHershberger updated the task description. (Show Details)
MarkAHershberger raised the priority of this task from to Needs Triage.
MarkAHershberger added a subscriber: MarkAHershberger.
Restricted Application added a project: Cloud-Services. · View Herald TranscriptNov 3 2015, 3:40 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Krenair added a subscriber: Krenair.Nov 3 2015, 3:44 PM
2015-11-03 15:37:22 silver labswiki exception ERROR: [ec2a5414] /w/index.php?title=Special:UserLogin&action=submitlogin&type=signup&returnto=OCG   MWException from line 220 of /srv/mediawiki/php-1.27.0-wmf.4/includes/Hooks.php: Detected bug in an extension! Hook OpenStackNovaUser::DynamicSidebarGetGroups has invalid call signature; ldap_count_entries() expects parameter 2 to be resource, boolean given {"exception_id":"ec2a5414"} 
[Exception MWException] (/srv/mediawiki/php-1.27.0-wmf.4/includes/Hooks.php:220) Detected bug in an extension! Hook OpenStackNovaUser::DynamicSidebarGetGroups has invalid call signature; ldap_count_entries() expects parameter 2 to be resource, boolean given
  #0 /srv/mediawiki/php-1.27.0-wmf.4/extensions/DynamicSidebar/DynamicSidebar.body.php(96): Hooks::run(string, array)
  #1 /srv/mediawiki/php-1.27.0-wmf.4/extensions/DynamicSidebar/DynamicSidebar.body.php(21): DynamicSidebar::doGroupSidebar()
  #2 [internal function]: DynamicSidebar::modifySidebar(SkinVector, array)
  #3 /srv/mediawiki/php-1.27.0-wmf.4/includes/Hooks.php(204): call_user_func_array(string, array)
  #4 /srv/mediawiki/php-1.27.0-wmf.4/includes/skins/Skin.php(1250): Hooks::run(string, array)
  #5 /srv/mediawiki/php-1.27.0-wmf.4/includes/skins/SkinTemplate.php(461): Skin->buildSidebar()
  #6 /srv/mediawiki/php-1.27.0-wmf.4/includes/skins/SkinTemplate.php(240): SkinTemplate->prepareQuickTemplate(OutputPage)
  #7 /srv/mediawiki/php-1.27.0-wmf.4/includes/OutputPage.php(2305): SkinTemplate->outputPage()
  #8 /srv/mediawiki/php-1.27.0-wmf.4/includes/MediaWiki.php(677): OutputPage->output()
  #9 /srv/mediawiki/php-1.27.0-wmf.4/includes/MediaWiki.php(474): MediaWiki->main()
  #10 /srv/mediawiki/php-1.27.0-wmf.4/index.php(41): MediaWiki->run()
  #11 /srv/mediawiki/w/index.php(3): require(string)
  #12 {main}

Note that the account was created, though.

jcrespo added a subscriber: jcrespo.EditedNov 3 2015, 3:51 PM

I am unable to locate the error on recent entries of our logs, could you indicate when that happened exactly, or try again an note down at which time the error occurred? Thanks!

Update: Krenair found it

The user already exists, did you manage to create it in the end or did it failed in the middle of the operation?

jcrespo removed a subscriber: jcrespo.Nov 3 2015, 3:53 PM

I'm able to log in as "hexmode" with the user I created. This makes sense since LDAP != SUL.

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 20 2015, 2:00 AM

This is caused by rMWca2840b5a573: Make hookErrorHandler() only care about serious signature errors, which checks for the string 'expects parameter' in a warning, and assumes it's an issue with the function hook signature, even though it can be an issue in the hook function itself.

Legoktm triaged this task as Unbreak Now! priority.Nov 20 2015, 2:25 AM
Legoktm set Security to None.
Beta16 added a subscriber: Beta16.Nov 23 2015, 8:48 AM

I have already an account on wikitech, but every time I try to access the site returns the error in the description of this task.
When reloading the browser page, I am regularly logged in.

Andrew added a subscriber: Andrew.Nov 30 2015, 4:18 PM

The title of this bug makes it look like account creation is failing -- but in reality it only failed when you try to create an account that already exists, correct? That is a much smaller problem!

Andrew lowered the priority of this task from Unbreak Now! to Low.Nov 30 2015, 4:18 PM
Andrew renamed this task from DB error when trying to create an account on wikitech to Weird error message when creating a wikitech account that already exists.

I doubt that's the actual bug, @Andrew.

Legoktm raised the priority of this task from Low to Unbreak Now!.Dec 3 2015, 8:57 AM

The title of this bug makes it look like account creation is failing -- but in reality it only failed when you try to create an account that already exists, correct? That is a much smaller problem!

No, that's not correct. Restoring UBN! priority.

Legoktm renamed this task from Weird error message when creating a wikitech account that already exists to MWException after account creation on wikitech.Dec 3 2015, 8:57 AM

Change 256645 had a related patch set uploaded (by Ori.livneh):
Revert "Make hookErrorHandler() only care about serious signature errors"

https://gerrit.wikimedia.org/r/256645

ori added a comment.Dec 4 2015, 8:37 AM

Since hook signature errors are an abnormal condition, it may be OK to call debug_backtrace() to determine where in the stack the exception was thrown.

Change 256645 merged by jenkins-bot:
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/256645

Change 256997 had a related patch set uploaded (by Ori.livneh):
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/256997

Change 256997 merged by jenkins-bot:
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/256997

ori closed this task as Resolved.Dec 4 2015, 9:36 PM
ori claimed this task.

Thanks @ori, I confirmed this is fixed by creating User:BugT117553 on wikitech.

Change 258986 had a related patch set uploaded (by Reedy):
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/258986

Change 258987 had a related patch set uploaded (by Reedy):
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/258987

Change 258989 had a related patch set uploaded (by Reedy):
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/258989

Change 258990 had a related patch set uploaded (by Reedy):
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/258990

Reedy added a subscriber: Reedy.Dec 14 2015, 4:04 PM

[15:50:56] <basisbit> could you just add a comment "+1 by basisbit; required for mediawiki 1.25.2 with MLEB installed as described in wiki."
[15:50:57] <basisbit> :D

Change 258986 merged by jenkins-bot:
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/258986

Change 258987 merged by jenkins-bot:
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/258987

Change 258989 merged by jenkins-bot:
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/258989

Change 258990 merged by jenkins-bot:
Don't install a custom error handler for hooks

https://gerrit.wikimedia.org/r/258990