Other amount in WMF donation form: error message unclear
Closed, ResolvedPublic

Description

Donors inadvertently entering a currency symbol in the Other amount field get message saying please select an amount, which confuses them. Ideally, we would just strip the symbol on our side before submitting, thereby letting the donor pass through without an error. If that's not possible, let's update this error message to something like please do not enter the currency symbol in the amount field that would be really helpful. We've seen 11 Zendesk tickets related to this in the past 4 days.

MBeat33 created this task.Nov 16 2015, 3:56 PM
MBeat33 updated the task description. (Show Details)
MBeat33 raised the priority of this task from to Needs Triage.
MBeat33 added a project: Fundraising-Backlog.
MBeat33 added subscribers: MBeat33, Ppena.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptNov 16 2015, 3:56 PM
Ppena added a comment.Nov 16 2015, 4:19 PM

@MBeat33 this is so weird. We never saw this before and had that field there forever. What country is this coming from? Maybe we should change something in the banner or the way we present the information instead?

@Ppena, most of them are US donors like ZD #168645, but we're also seeing it in France, as in #167497

Yes, this is odd. We've been using forms like this for a long time now (both in banners and donatewiki), and nothing has changed about them recently. I'll take a look how we can improve it though.

atgo added a subscriber: atgo.Nov 16 2015, 7:51 PM

@Pcoombe could we put a currency symbol just to the left of the text entry box? We should also be able to deal with this on our side with validation. Adding to the next sprint for the time being.

atgo updated the task description. (Show Details)Nov 16 2015, 7:52 PM
atgo set Security to None.
atgo moved this task from Analysis to Sprint +1 on the Fundraising-Backlog board.
atgo triaged this task as Normal priority.

Not sure why, but the volume of this is much higher than normal. A comment I've seen from multiple donors is "The fixed donation amounts had a $ sign in from of each of them. Therefore when I typed in my own amount, I thought that I had to put a $ sign in."

and great idea, @atgo

awight assigned this task to Pcoombe.Nov 17 2015, 6:29 PM
atgo added a comment.Nov 17 2015, 6:29 PM

@Pcoombe - tech thinks this is something on your side. Let us know if you need help :)

Pcoombe closed this task as Resolved.Nov 18 2015, 1:15 PM

Okay, solved. We never had the code to strip out currency symbols in donatewiki that we had in banners. I've added it to make them both the same. I guess the increase in volume is just because we've been sending many emails recently.

@Pcoombe that's great, many thanks.

MBeat33 reopened this task as Open.Dec 12 2015, 6:48 PM

Three major donors who've received the recent enMG15 bulk email have reported this problem occurring; the donor in the screenshot said it occurred on their iPad but not a desktop. ZD #s 188299, 188260, 187559 can we confirm that this fix has been applied to all mobile forms?

Okay, think I fixed what might have caused this (silly javascript error on my part). Have tested on crossbrowsertesting and it worked, but they don't have iOS 9. Will try on my iPad when I get home in a few hours.

Pcoombe closed this task as Resolved.Dec 12 2015, 11:35 PM

This seems to be working again now.

The donor in #189016 on 12/13 got the minimum amount error message after selecting 10 USD. They're using an Apple iPhone 6s on iOS 9.1

Pcoombe reopened this task as Open.Dec 22 2015, 8:13 PM

Re-opening because I confirmed there's an issue when adding a currency symbol on iOS in banners (it shouldn't even be possible to add currency symbol since the input type=number!)

atgo added a comment.Jan 20 2016, 10:22 PM

@Pcoombe is this an fr-tech task now?

@atgo No, it's still a banner issue

atgo added a comment.Jan 21 2016, 3:44 PM

Ok @Pcoombe I'm going to remove Fundraising-Backlog for now. If it becomes an fr-tech thing please re-add

atgo removed a subscriber: atgo.Mar 30 2016, 10:06 PM

The mobile donor in #261500 got a minimum amount error despite specifying $5.00 in the Other field:

I am following up to get their specs/vitals

@Pcoombe / @Jseddon this looks like it's in a banner - do you add that $, or did the donor type it? Would that mess with the amount logic?

Ejegg added a comment.Nov 21 2016, 8:04 PM

Oops, just saw all the comments above. Guess this is a well understood issue!

Pcoombe closed this task as Resolved.Nov 24 2016, 5:36 PM

This was due to particularly annoying Safari behaviour. When <input type="number"> is used, on mobile it will display a keyboard with symbols including $, and allow them to be typed. However once the input loses focus (e.g. when the user clicks a payment method) it will think "Hey, that isn't a number!" and blank the entire field. So our own validation then fails.

It is possible to get a keyboard with only numbers by applying a certain pattern attribute, but that makes it impossible to input decimal points.

Instead I've worked around this by adding some javascript to block input of anything that isn't a number or decimal point.