On single edit tab wikis, clicking on a section edit link gives an editor whose switching works oddly
Closed, ResolvedPublic1 Story Points

Description

When you section edit into WT, the editor's switch button just brings you back to the editor the first time (but then works the second time).

Krenair claimed this task.Dec 11 2015, 1:34 PM

Is this consistently reproducible? By 'back to the editor' you mean back into VE?

I think I misunderstood a bit, but it still works for me...

I said that, and then when I was testing something else I reproduced the exact issue.

looks like it is happening when when you try to switch from WT to VE and have the single edit tab preference of remember-last and one of the following is true:

  • You made no changes and were not on action=submit
  • You made changes but opted to discard them (likely if you were section editing)

looks like it is happening when when you try to switch from WT to VE and have the single edit tab preference of remember-last and one of the following is true:

  • You made no changes and were not on action=submit
  • You made changes but opted to discard them (likely if you were section editing)

That sounds likely to be my failure issues, yes.

Change 258643 had a related patch set uploaded (by Alex Monk):
Remember switching into VE from WT when discarding changes

https://gerrit.wikimedia.org/r/258643

Jdforrester-WMF closed this task as Resolved.Dec 12 2015, 12:26 AM

Provisionally assuming fixed.

Change 258643 merged by jenkins-bot:
Remember switching into VE from WT when discarding changes

https://gerrit.wikimedia.org/r/258643