VisualEditor: If VisualEditor is the primary editor, type=create and type=fulltext buttons should point to VE, not WT editor
Open, NormalPublic

Description

If VisualEditor is default, why after clicking on a red link there's 'action=edit' in url and the source editor runs instead of 'veaction' and VE? I've checked it out on the enwiki and plwiki, but it concerns the rest of phase 2 as well and creating a new page in general. Furthermore, it makes inputboxes ('type=create') incompatible with VE and it can be a bothering problem on some wikis.

See Also: T55441: VisualEditor: Where VisualEditor is the primary editor, redlinks in read mode should open VE (not wikitext editor)

Details

Reference
bz52162

Related Objects

StatusAssignedTask
OpenNone
Resolved AlexMonk-WMF
OpenNone
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
DeclinedWhatamidoing-WMF
ResolvedKrenair
ResolvedKrenair
InvalidKrinkle
ResolvedKrenair
ResolvedKrenair
OpenNone
bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz52162.

Could you provide a example of a 'type=create' problem affecting VE? Is it used on main or user namespace in your wiki?

In the plwiki, we have no important inputbox with 'type=create' in the main nor user namespace, but there are inputboxes in help or project pages which create a new article (for ex. [[pl:Pomoc:Tworzenie nowych haseł#Niniejsza strona]]), and after clicking the button there is 'action=edit&preload=' in url.

Second, whenever we click on a red link in an article (the main), 'action=edit&redlink=1' displays. The default tab is 'Create source', not 'Create'. It's quite surprising for me and for the newbies, I believe.

Ah, I see a process problem with type=fulltext too

inputbox goes to search results, and search results show a red link, which the user would click on to start a new page. e.g.

https://en.wikipedia.org/wiki/Special:Search/this_article_doesnt_exist

I believe that some enhancement will be needed in the InputBox extension to support creating VE or SE articles.
https://www.mediawiki.org/wiki/Extension:InputBox

You can easily point InputBox to VE with a simple hook so that VE can change 'action' to 'veaction'. But that won't make VE magically support all the additional parameters which InputBox uses (e.g. preload, editintro, summary, minor, etc.)

I don't want to make inputbox suddenly magically different. It's about ordinary users (especially the new sort 'born' after VE deployment) who want to type a new article's name, click on button and voila, start creating their article in VE. In 2 steps, after 1 click, without experience like 'why the markups? oh, I'm switching to VE'. They'd be more likely to give up in this case.

Technically, you may change the default 'action' with 'veaction' or create a new parameter or sth else, it's up to you.

Did SET work affect this...?

Did SET work affect this...?

Not yet; it will need further work.

Krinkle removed a subscriber: Krinkle.Aug 30 2016, 12:34 AM
Cirdan added a subscriber: Cirdan.