VisualEditor: [[MediaWiki:Anoneditwarning]] has an editor-specific link rather than taking you to the appropriate one
Closed, ResolvedPublic1 Story Points

Description

en.wp user Professor Hog reports:
"If you try and use beta to edit a page, but you've forgotten to log in, so you log in directly off the beta page, once you have successfully logged in it takes you back to the edit source page instead of the beta page. Minor, but thought you may want to correct it? "


Version: unspecified
Severity: minor
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=52281

Details

Reference
bz53746

Related Objects

StatusAssignedTask
OpenNone
Resolved AlexMonk-WMF
OpenNone
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
DeclinedWhatamidoing-WMF
ResolvedKrenair
ResolvedKrenair
InvalidKrinkle
ResolvedKrenair
ResolvedKrenair
ResolvedKrenair
OpenNone
OpenNone
bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz53746.

I can't reproduce this - I get back to VisualEditor (as expected) - the login link is something like https://en.wikipedia.org/w/index.php?title=Special:UserLogin&returnto=Foobar&returntoquery=veaction%3Dedit

Can "Professor Hog" give any further details? What browser were they using? Can they reproduce? What about after a hard-refresh? Do they have any odd gadgets on the account into which they were logging-in?

I'll ask for further clarification, but I've tested this in Firefox 23 on linux.

Clicking the link in the VE popup that notes you're not logged in reproduces this bug. (Note that this loads the login window in a new tab, I logged in there and was returned to the source editor in that window).

Dismissing that popup and then using the log in link at the top right of the page returned me to viewing the page not editing it in either editor.

The results are the same using my Thryduulf account which has a couple of gadgets, and my Awkward42 account which has none.

To clarify the sequence I used to reproduce this was:

  1. log out
  2. load a page in VE. I tested with [[Symphony No. 8 (Mahler)]] and [[user:Thryduulf/sandbox]]
  3. click to edit the page in VE
  4. Click the "log in" link in the notice that pops up.

This loads https://en.wikipedia.org/w/index.php?title=Special:UserLogin&returnto=User:Thryduulf/sandbox&returntoquery=action%3Dedit in a new tab.

  1. In that new tab, log in as normal

Get returned to the source editor.

The edit notice shown is that in [[MediaWiki:Anoneditwarning]] where the link is hardcoded to the source editor (pre VE this would never have been an issue).

To me this suggests that either editor-relative urls are needed or we need different edit notices for the classic editor and VE (see bug 52741 for the latter)

(In reply to comment #3)

To clarify the sequence I used to reproduce this was:

  1. log out
  2. load a page in VE. I tested with [[Symphony No. 8 (Mahler)]] and [[user:Thryduulf/sandbox]]
  3. click to edit the page in VE
  4. Click the "log in" link in the notice that pops up. This loads https://en.wikipedia.org/w/index.php?title=Special:UserLogin&returnto=User: Thryduulf/sandbox&returntoquery=action%3Dedit in a new tab.
  5. In that new tab, log in as normal Get returned to the source editor.

    The edit notice shown is that in [[MediaWiki:Anoneditwarning]] where the link is hardcoded to the source editor (pre VE this would never have been an issue).

    To me this suggests that either editor-relative urls are needed or we need different edit notices for the classic editor and VE (see bug 52741 for the latter)

Oh, I see, I was clicking on "login" in the personal links bar - sorry. Re-titling so I don't get confused again. :-)

Changing the depends on to bug 52471 (sorry, I typoed in comment 3)

Note, Steven added a custom workaround at English Wikipedia (shortly after this was filed). It removes the action=edit, so you don't go to any editor on return (otherwise, it can to the wrong one like this bug says).

That was never the desired behavior, though. The desired behavior is that it knows which editor you're using anonymously, and keeps you on the right editor when you return logged in. Both VE and wikitext have suitable URL parameters; the issue is knowing which to use.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 23 2015, 4:45 PM
Catrope removed a subscriber: Catrope.Jan 13 2016, 8:19 PM
Mattflaschen-WMF reopened this task as Open.Feb 19 2016, 8:15 PM

@Jdforrester-WMF It looks like the workaround at enwiki (and maybe others, though not that I know of) needs to be removed/altered.

See my previous comment.

AlexMonk-WMF added a subscriber: Krenair.
AlexMonk-WMF closed this task as Resolved.Feb 20 2016, 2:18 AM

I think that needs to wait until enwiki has SET.