Page MenuHomePhabricator

[betalabs] Special:Nuke - 'Pattern for the page name' filter does not work
Closed, ResolvedPublic

Description

From https://www.mediawiki.org/wiki/Extension:Nuke

You can also specify a pattern for the page title: the field accepts SQL wildcards, like %lol%.

In betalabs Special:Nuke, 'Pattern for the page name' does not work for patterns - only for a full page title.

Event Timeline

Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova updated the task description. (Show Details)
Etonkovidova added a subscriber: Etonkovidova.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptJan 13 2016, 12:36 AM

Please include what you put in the pattern field, what page you expected it to find, and whether that page was Flow.

Etonkovidova added a comment.EditedApr 20 2017, 7:36 PM

Rechecked in betalabs - the issue is still present: enteirng 'Mavetuna74%' does not return any results although there are new pages as 'Mavetuna74' and 'Mavetuna741' (no quotes were used for actual search criteria').

The issue is present for non-Flow pages.

https://www.mediawiki.org/wiki/Extension:Nuke

You can also specify a pattern for the page title. The field accepts SQL wildcards, like %lol%.

Change 349278 had a related patch set uploaded (by Mattflaschen):
[mediawiki/extensions/Nuke@master] Revert "Use $dbr->buildLike() instead of manual LIKE"

https://gerrit.wikimedia.org/r/349278

Change 349278 merged by jenkins-bot:
[mediawiki/extensions/Nuke@master] Revert "Use $dbr->buildLike() instead of manual LIKE"

https://gerrit.wikimedia.org/r/349278

Checked in betalabs - both '%' and '_' work as expected.

QA Recommendation: Resolve

Krinkle closed this task as Resolved.Apr 22 2017, 1:21 AM