www.wikipedia.org statistics needs to be updated
Closed, ResolvedPublic1 Story Points

Description

Please update the statistics on www.wikipedia.org regularly like it was done before. I see no update to the stats ever since it was moved to Gerrit.

https://meta.wikimedia.org/wiki/Www.wikipedia.org_template/auto may be of some help. This page has the up-to-date statistics though it probably is currently not in sync with the actual code.

Ideally, a script should be written for this purpose so that it can be done in a fast and reliable manner. Possible suggestions:

  • Someone can run a script locally and commit to Gerrit and deploy periodically
  • A task similar to l10n-update that will commit to Gerrit and deploy it. (Or maybe it shouldn't do everything by itself and should be only allowed after review by a person?)

See also https://meta.wikimedia.org/wiki/Talk:Www.wikipedia.org_template#Update_the_Thai_Wikipedia_to_100k-article_section

Glaisher created this task.Feb 2 2016, 3:47 PM
Glaisher updated the task description. (Show Details)
Glaisher raised the priority of this task from to Needs Triage.
Glaisher added a project: Wikimedia-Portals.
Glaisher added a subscriber: Glaisher.
Restricted Application added a project: Discovery. · View Herald TranscriptFeb 2 2016, 3:47 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript

@debt You should take a look at this and factor it in to your planning.

debt added a comment.Feb 4 2016, 3:30 PM

Thanks, we'll add it in! :)

debt triaged this task as Normal priority.Feb 4 2016, 3:31 PM
debt added a project: Discovery-Portal-Sprint.
debt set Security to None.
debt added subscribers: JGirault, Jdrewniak, Ironholds.
debt moved this task from Needs triage to UX on the Discovery board.Feb 4 2016, 5:01 PM
debt edited a custom field.Feb 4 2016, 6:10 PM
debt moved this task from To Discuss to What's Next on the Discovery-Portal-Sprint board.

Heya!

We're going to work on this ticket and update the links. Just to be transparent our next project is an A/B test to use language settings to sort and order the links - https://phabricator.wikimedia.org/T121567 . If it goes well the article-sorted counts may be deprecated (following the testing and discussion of the results)

debt moved this task from UX to On Sprint Board on the Discovery board.Feb 4 2016, 9:15 PM
2526 added a subscriber: 2526.Feb 5 2016, 6:26 PM
debt added a comment.Feb 6 2016, 12:06 AM

We'll add the update to this ticket: https://wikitech.wikimedia.org/wiki/Deployments#Tuesday.2C.C2.A0February.C2.A009 and we hope to release it into production on Monday Feb 8, 2016

Change 268846 had a related patch set uploaded (by JGirault):
Update www.wikipedia.org stats

https://gerrit.wikimedia.org/r/268846

JGirault claimed this task.Feb 6 2016, 12:54 AM
JGirault moved this task from In Progress to Needs code review on the Discovery-Portal-Sprint board.

Change 268846 merged by jenkins-bot:
Update www.wikipedia.org stats

https://gerrit.wikimedia.org/r/268846

debt added a comment.Feb 8 2016, 8:23 PM

This update is visible here: http://www.wikipedia.beta.wmflabs.org/?monday and will be released into production later on today. Closing this ticket.

debt closed this task as Resolved.Feb 8 2016, 10:05 PM
debt moved this task from Done to Completed on the Discovery-Portal-Sprint board.Feb 10 2016, 1:13 AM
Glaisher reopened this task as Open.Feb 19 2016, 5:24 PM

I initially requested the stats to be updated regularly but this task seems to be have been changed to a one-time update task and then closed after that. Considering that the script was written months ago, I expect it to be run regularly as well as this is a huge regression from the Gerrit switchover.

Hence opening this again until there is a confirmation that it will be updated regularly at least until the work being done at T121567 is implemented.

debt added a comment.Feb 19 2016, 10:31 PM

Hi @JGirault - let's go ahead and update the stats again during the week of Feb 22, 2016, thanks!

This should become a regular maintenance task. I'd suggest a regular occurrence on someone's calendar, if it is ensured that the task gets reassigned after that person leaves. Ideally this would be done automatically...

We are hoping to be able to switch away from pageview-based ordering, which is why it hasn't been.

The stats in the other portals have not been updated since the move either. They must be updated as well.

I didn't think we'd moved them? I might be wrong (I'm probably wrong)

Well, that is not what Chris Koerner said in the portal improvements page in meta and they seem to be in gerrit. Is there any way to find out for sure?

Hey, I said I was probably wrong! :D. I'll wait until the Engineers wake up; presumably they know.

Change 274304 had a related patch set uploaded (by JGirault):
Update wikipedia.org stats

https://gerrit.wikimedia.org/r/274304

Change 274304 merged by jenkins-bot:
Update wikipedia.org stats

https://gerrit.wikimedia.org/r/274304

Hi! Will this also fix the other portals? Or are they still pointing to Meta?

I updated www.wikipedia.org stats today.
As well as other portals: T128522

We are hoping to be able to switch away from pageview-based ordering, which is why it hasn't been.

See meta:Top Ten Wikipedias. Summary: "In 2008, it was decided that the Top Ten Wikipedias are defined by usage rather than article count." (Broad RfC, 221 supporters for this result.) Is there consensus for overturning this established consensus?

debt added a comment.Mar 9 2016, 12:39 AM

Hi @Yair_rand - we haven't changed the earlier decision, on how the top 10 wiki's are defined. However, we might have a different visual treatment for them in the future.

debt closed this task as Resolved.Mar 9 2016, 4:48 PM

This ticket is now closed - the stats have been updated.

debt moved this task from Done to Completed on the Discovery-Portal-Sprint board.Apr 7 2016, 3:37 PM