Page MenuHomePhabricator

Compress all versioned, static PNG files with zopflipng
Closed, ResolvedPublic

Description

Zopfli is the most efficient DEFLATE compression algorithm, trading run-time performance for file sizes that are typically 3-8% smaller than those produced by zlib with the maximum compression setting. Its output is Deflate-compatible, so no specialized decoder is needed.

We should iterate over all repositories which contain PNG-encoded user interface components, compressing each image with Zopfli and committing the result.

More on Zopfli: http://blog.codinghorror.com/zopfli-optimization-literally-free-bandwidth/

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

Change 272281 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272281

Change 272263 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272263

Change 272275 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272275

Change 272269 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272269

Change 272264 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272264

Change 272245 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272245

Change 272240 merged by jenkins-bot:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272240

Change 272204 merged by jenkins-bot:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272204

Change 272202 merged by jenkins-bot:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272202

Change 272234 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272234

Change 272256 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272256

Change 272208 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272208

Change 272254 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272254

Change 272253 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272253

Change 272250 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272250

Change 272241 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272241

Change 272207 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272207

Change 272178 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I99e959fe949a323b2b5299eed656b283e6750704

https://gerrit.wikimedia.org/r/272178

Change 272195 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272195

Change 272164 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in Idf8e2bb781f07e2ab8e0d65eddae129fbd6b220e

https://gerrit.wikimedia.org/r/272164

Change 272168 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I65af1742d5bbd5ac30a22995d58de210fe056977

https://gerrit.wikimedia.org/r/272168

Change 272166 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I152cfdf9f24b80979a20116363f34a643e12b8e9

https://gerrit.wikimedia.org/r/272166

Change 272165 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I75cbcaa0127349c75a0041c716b4282c94ca5f86

https://gerrit.wikimedia.org/r/272165

Change 272162 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I04993ea97b05cf2864fbd7db4b3bc51403c99435

https://gerrit.wikimedia.org/r/272162

Change 272183 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I248688a1720e307f5621a5c1e2be1958d41cee5c

https://gerrit.wikimedia.org/r/272183

Change 272161 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Read only mirror:
[READ ONLY] This mirror is here only for i18n updates from Translatewiki. Other contributions are welcome at https://github.com/SemanticMediaWiki/SemanticResultFormats

https://gerrit.wikimedia.org/r/272161

Change 272160 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in Ie0202aeaacc73168a13c7c4392804388990e2579

https://gerrit.wikimedia.org/r/272160

Change 272189 merged by jenkins-bot:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272189

Change 272155 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I8625d89e41b1c9b15bce844940d7ad71553562e1

https://gerrit.wikimedia.org/r/272155

Change 272158 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I3f22b89d9ba10448849a83f0c5501b9132f0e2a4

https://gerrit.wikimedia.org/r/272158

Change 272231 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272231

Change 272230 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272230

Change 272228 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272228

Change 272152 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I66362cfcff82ebb9280ed01231888c9a61e8a173

https://gerrit.wikimedia.org/r/272152

Change 272149 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I854f32f4e47b2ba68e31ae8c1c55dd62d623ebe9

https://gerrit.wikimedia.org/r/272149

Change 272141 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I5d44b87648f892cf617ab1d04f78300f05006c4b

https://gerrit.wikimedia.org/r/272141

Change 272127 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I59e7e3964c97b982cef47c206673afd8345b650c

https://gerrit.wikimedia.org/r/272127

Change 272138 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in Icb74fa79d8541625035a0fd28d23429cd686dc7b

https://gerrit.wikimedia.org/r/272138

Change 272159 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in Ia9375d59249425e1094df64f97c5188edaddf8ff

https://gerrit.wikimedia.org/r/272159

Change 272157 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I2e6fe98939167191c40109207d38de73019639b9

https://gerrit.wikimedia.org/r/272157

Change 272156 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I3ac66020e620744d79422f08aed5ea2635ecdf2d

https://gerrit.wikimedia.org/r/272156

Change 272154 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I6ace4f92f6281bf7aaac28d402f19e5ee4defa9b

https://gerrit.wikimedia.org/r/272154

Change 272135 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I564586fd0b27585d260bbb6f9cb3bb31e160c186

https://gerrit.wikimedia.org/r/272135

Change 272134 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I4aa4d986a18680838df3fc45fbc2c32e83499bc9

https://gerrit.wikimedia.org/r/272134

Change 272132 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I2984dad2e360eedccf260a1b07894647eebb199e

https://gerrit.wikimedia.org/r/272132

Change 272145 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in Idcdcba293a1784968e1281d79344ed02a5d409c2

https://gerrit.wikimedia.org/r/272145

Change 272182 merged by jenkins-bot:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272182

Change 272153 merged by jenkins-bot:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272153

Change 272177 merged by Florianschmidtwelzow:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272177

Change 272171 abandoned by Florianschmidtwelzow:
Compress PNGs with zopflipng

Reason:
Done in I9e54e90af3778479a9677fada7e18028209a4764

https://gerrit.wikimedia.org/r/272171

Change 272143 abandoned by Ori.livneh:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272143

Change 272239 abandoned by Ori.livneh:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272239

Change 272201 abandoned by Umherirrender:
Compress PNGs with zopflipng

Reason:
Same as Ia7af30948786cd291b1832a001eadc1f44ee0370

https://gerrit.wikimedia.org/r/272201

Change 272187 merged by jenkins-bot:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272187

Unexpected regression in https://gerrit.wikimedia.org/r/#/c/272093 (EducationProgram)

mediawiki/extensions/EducationProgram/resources/images/added-to-course-notification.png
has been overwritten with the content of
mediawiki/extensions/EducationProgram/resources/images/course-talk-notification.png

I brought back the old version of the icon in https://gerrit.wikimedia.org/r/272720 but didn't try to compress it.

TheDJ added a subscriber: TheDJ.Feb 24 2016, 9:13 AM

Regression in CodeEditor as well, was reverted in:
https://gerrit.wikimedia.org/r/272817

TheDJ added a comment.Feb 24 2016, 9:14 AM

Seems to me we need to check all conversions now. Three extensions with problems is a pattern...

ori added a comment.Feb 24 2016, 9:16 AM

Seems to me we need to check all conversions now. Three extensions with problems is a pattern...

Yes. Crap.

ori added a comment.Feb 24 2016, 9:22 AM

This might have happened because:

  • I used parallel
  • zopflipng re-uses the same temp file name
  • Files can get mixed up when multiple zopflipng processes are interleaved.

If that's the case, then it could have happened anywhere. It's 1:21AM here but tomorrow I will write a script to scrape the commits from Gerrit and automatically detect swapped files somehow.

Change 272983 had a related patch set uploaded (by Krinkle):
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272983

Change 272984 had a related patch set uploaded (by Krinkle):
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272984

Change 272983 merged by jenkins-bot:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272983

Change 272984 merged by jenkins-bot:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272984

Change 272196 merged by Krinkle:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272196

Perhelion added a subscriber: Perhelion.EditedFeb 27 2016, 10:48 PM

Two files on the extensions-wikihiero are overwritten with completely other files:
Reported on the w:De:WikiProjekt_Ägyptologie

https://gerrit.wikimedia.org/r/#/c/272984/1/img/hiero_W9.png,unified
https://gerrit.wikimedia.org/r/#/c/272984/1/img/hiero_Y3.png,unified

Change 272235 abandoned by Paladox:
Compress PNGs with zopflipng

Reason:
The patches are being reverted, plus these images are upstream in the OpenLayers repo.

https://gerrit.wikimedia.org/r/272235

Change 272282 abandoned by Krinkle:
Compress PNGs with zopflipng

Reason:
Redundant with I81be54b13f10f2c76f0838419fcc96f10c4d8bd2

https://gerrit.wikimedia.org/r/272282

Change 272180 abandoned by Ori.livneh:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272180

Change 272273 abandoned by Bartosz Dziewoński:
Compress PNGs with zopflipng

Reason:
Duplicate of https://gerrit.wikimedia.org/r/#/c/272175/

https://gerrit.wikimedia.org/r/272273

Change 272272 merged by jenkins-bot:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272272

Oliv0 removed a subscriber: Oliv0.Mar 30 2016, 3:41 PM

Change 280766 had a related patch set uploaded (by Awight):
Compress PNGs using zopflipng

https://gerrit.wikimedia.org/r/280766

Change 280766 merged by jenkins-bot:
Compress PNGs using zopflipng

https://gerrit.wikimedia.org/r/280766

ori closed this task as Resolved.Apr 7 2016, 6:43 PM

Change 272186 abandoned by Krinkle:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272186

Change 272284 abandoned by Krinkle:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272284

Change 272214 abandoned by Krinkle:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272214

Change 272198 abandoned by Robert Vogel:
Compress PNGs with zopflipng

Reason:
We've had troubles with the zopflipng conversion in BlueSpiceFoundation. File contents got switched. We had to revert some of it.

https://gerrit.wikimedia.org/r/272198

Change 272286 abandoned by Ori.livneh:
Compress PNGs with zopflipng

https://gerrit.wikimedia.org/r/272286