Page MenuHomePhabricator

As creator / publisher of a newsletter, I cannot edit and save its description
Closed, DuplicatePublic

Description

@Qgil just created http://newsletter-test.wmflabs.org/wiki/Special:Newsletter/16 and this problem still exists. I can see the text area, but it is not editable. I tried with "Manage", since the label suggested that there I would be able to edit the description, but that wasn't the case either.

Details

Related Gerrit Patches:
mediawiki/extensions/Newsletter : masterAllow newsletter managers to edit newsletter description

Event Timeline

Qgil created this task.Apr 1 2016, 9:10 AM
Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptApr 1 2016, 9:10 AM
Tinaj1234 claimed this task.Apr 1 2016, 9:19 AM

Change 280833 had a related patch set uploaded (by 01tonythomas):
Allow newsletter managers to edit newsletter description

https://gerrit.wikimedia.org/r/280833

Qgil renamed this task from As creator of a newsletter, I cannot edit its description to As creator / publisher of a newsletter, I cannot edit its description.Apr 1 2016, 9:50 AM

Change 280833 merged by jenkins-bot:
Allow newsletter managers to edit newsletter description

https://gerrit.wikimedia.org/r/280833

Tinaj1234 removed Tinaj1234 as the assignee of this task.Apr 1 2016, 10:01 AM

Patch merged + pulled in at newsletter-test instance. @Qgil , can you verify the problem is solved at http://newsletter-test.wmflabs.org/wiki/Special:Newsletter/12 ?

Addshore closed this task as Resolved.Apr 1 2016, 10:03 AM
Addshore assigned this task to 01tonythomas.
Qgil added a comment.Apr 1 2016, 10:16 AM

Yep, it works! Wow, that was superfast.

Glaisher reopened this task as Open.Apr 1 2016, 12:17 PM

The linked patch only changes the HTML readonly attribute to be true only for managers. It cannot be saved and submitted.

Addshore renamed this task from As creator / publisher of a newsletter, I cannot edit its description to As creator / publisher of a newsletter, I cannot edit and save its description.Apr 1 2016, 12:27 PM