Page MenuHomePhabricator

Error "Unknown widget type: id: searchText, class: mw.widgets.SearchInputWidget"
Closed, ResolvedPublic

Description

This happens when navigating back and forth around https://ka.wikiquote.org/w/index.php?search=sf&title=Special:Search&go=Go. It's hard to reproduce by direct url but going to the search bar, entering some text, submitting the search and going back consistently triggers.

Exception in load-callback in module mediawiki.widgets:

Error: Unknown widget type: id: searchText, class: mw.widgets.SearchInputWidget

Might be caused by a local modification of sorts.

Details

Related Gerrit Patches:

Event Timeline

Krinkle created this task.Apr 14 2016, 4:13 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 14 2016, 4:13 AM

Change 283464 had a related patch set uploaded (by Bartosz Dziewoński):
mediawiki.page.ready: Load 'SearchInputWidget' too

https://gerrit.wikimedia.org/r/283464

Might be caused by a local modification of sorts.

Nah, it's just a bug.

This happens if mediawiki.page.ready executes before mediawiki.special.search and, luckily, is entirely harmless.

Florian closed this task as Resolved.Apr 15 2016, 6:43 PM
Florian assigned this task to matmarex.

Change 283464 merged by jenkins-bot:
mediawiki.page.ready: Load 'SearchInputWidget' too

https://gerrit.wikimedia.org/r/283464

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 19 2016, 11:02 PM
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:11 PM