Page MenuHomePhabricator

Wikipedia app pages not updating
Closed, ResolvedPublic

Description

There seems to be a bug when trying to update pages, for example see https://en.wikipedia.org/wiki/Good_and_evil on a browser page and on the wikipedia app.
Note: I'm using Nexus 5.

Event Timeline

Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 12 2016, 6:13 PM
Lbertolotti updated the task description. (Show Details)Jun 12 2016, 6:14 PM

I just tried this on my 5X but couldn't find any problems with it.

Have you tried with other pages?

@Lbertolotti: Please describe the actual bug and what is "not updating" so anybody else could try to compare. Also see https://mediawiki.org/wiki/How_to_report_a_bug for more information. Thank you!

Well, I just tried again with the Good and evil page again, the lead has been edited but this doesn't show in the wikipedia app.

I just noticed that the "today" main page is not updating correctly as well, compare it to a browser page https://en.wikipedia.org/wiki/Main_Page

Dbrant added a subscriber: Dbrant.

possibly same as T137902

Lbertolotti added a comment.EditedJul 21 2016, 2:02 PM

These are screenshots from my Nexus 5:

First of all, is there a delay on updating pages? Look at portal pages and how they compare to the ones displayed on the wikipedia app.
Ex:
https://en.wikipedia.org/wiki/Portal:Business_and_economics
https://en.wikipedia.org/wiki/Portal:Capitalism
https://en.wikipedia.org/wiki/Portal:Communism
https://en.wikipedia.org/wiki/Portal:Socialism

Mholloway added a subscriber: Mholloway.EditedSep 8 2016, 6:48 PM

There was a delay in updating pages in general around the time this bug was filed, but that was resolved by T137902: [BUG] Old page revision shown when using Content Service. Does that resolve this issue?

If there's still an issue, it looks specific to portals. I am comparing the featured contents of the Communism portal on various devices, and they are indeed different, but the content on the mobile web is also different from both the app and the content shown in my browser on desktop.

It is possible there's an issue with propagating changes to these pages, but it looks like the portal featured content is changeable by anyone at the click of a button, there doesn't appear to be a strong expectation that the featured content for a portal will remain constant for any length of time. I am far from a portal expert so I apologize if I'm mistaken here.

Can you explain, in the clearest possible terms, what is happening vs. what is expected to happen:

EXPECTED BEHAVIOR:

What should happen

ACTUAL BEHAVIOR:

What is going wrong

There was a delay in updating pages in general around the time this bug was filed, but that was resolved by T137902: [BUG] Old page revision shown when using Content Service. Does that resolve this issue?

Yes it does, I can change the portal pages content by using "Show new selections" on the Wikipedia app.

Huon added a subscriber: Huon.Sep 8 2016, 6:57 PM

Apparently Module:Random portal component gives different results depending on whether you view the page in desktop view, mobile view or in the app (without purging the cache in between, reproducably). Not sure whether that's a bug or a feature.

Lbertolotti added a comment.EditedSep 15 2016, 3:14 PM

The problem is not with the module, the problem is with the wikipedia app.

EXPECTED BEHAVIOR:

Purge page cache-> updated version of the page appears on wikipedia app

ACTUAL BEHAVIOR:

Purge page cache -> nothing happens

I thought this problem was solved, but It's reocurring.

On the Android side, I think this might be an issue in Mobile-Content-Service. Consider the results from this test page:

https://en.wikipedia.org/api/rest_v1/page/mobile-sections-lead/User:Lbertolotti%2Ftest_page
{
  "ns": 2,
  "id": 44359273,
  "revision": "738430755",
  "lastmodified": "2016-09-08T22:32:47Z",
  "lastmodifier": {
    "name": "Lbertolotti",
    "gender": "male"
  },
  "displaytitle": "User:Lbertolotti/test page",
  "normalizedtitle": "User:Lbertolotti/test page",
  "protection": {},
  "editable": true,
  "languagecount": 0,
  "sections": [
    {
      "id": 0,
      "text": "<span></span><div style=\"float: left;\"><b><a href=\"/wiki/Portal:Business_and_economics/Selected_quote\" title=\"Portal:Business and economics/Selected quote\">...Archive</a></b></div><div style=\"float: right;\"><b><a href=\"https://en.wikiquote.org/wiki/Category:Economists\" title=\"q:Category:Economists\">More…</a></b></div><div style=\"text-align:center;\"><b><a href=\"/wiki/Portal:Business_and_economics/Selected_quote/Suggest\" title=\"Portal:Business and economics/Selected quote/Suggest\">Suggest</a></b></div>"
    }
  ]
}
https://en.wikipedia.org/api/rest_v1/page/mobile-sections-remaining/User:Lbertolotti%2Ftest_page
{
  "sections": []
}
bearND added subscribers: Pchelolo, mobrovac, bearND.

@mobrovac @Pchelolo Looks like some pages are not getting rerendered. Not sure if this is just contained to the non mainspace pages. The page reported on IRC mobile channel right now is https://en.wikipedia.org/api/rest_v1/page/mobile-sections-lead/User%3ALbertolotti%2Ftest_page. Looks like the last update of that page was about an hour ago as of this writing.

~8pm UTC some template was edited that caused content change of every single page it was transcluded in. All those pages were being rerendered up until 12am UTC today, creating tons of rerender jobs for mobile endpoints. It will get back on track eventually, but it seems like we need to think about some mechanism of job prioritisation..

We are increasing the concurrency of re-render jobs, which should help ChangeProp to go through the backlog quicker.

Created a follow-up task with an idea how to decrease visibility of such situations for the user: T145804

Pchelolo closed this task as Resolved.Sep 16 2016, 4:59 PM
Pchelolo claimed this task.

The backlog has cleared so everything should be fine right now.

Resolving this since I've create a follow-up task on how to protect in the future from situations like this.