Page MenuHomePhabricator

Flow causes fatal exception on [[Special:EditWatchlist]]
Closed, ResolvedPublic

Description

https://pt.wikibooks.org/wiki/Special:EditWatchlist

Error
An error has occurred.
Return to Wikilivros:Página principal.
[V2CJUQpAEEYAAHfxB1UAAAED] 2016-06-14 22:46:46: Fatal exception of type "Flow\Exception\InvalidDataException"

After reloading the page, I got

[V2CJigpAEK4AABhLXYkAAAAK] 2016-06-14 22:47:42: Fatal exception of type "Flow\Exception\InvalidDataException"

and then

[V2CJ0ApAADgAAfNTPiIAAAAF] 2016-06-14 22:48:50: Fatal exception of type "Flow\Exception\InvalidDataException"

Event Timeline

He7d3r created this task.Jun 14 2016, 10:49 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 14 2016, 10:49 PM

Other watchlist pages were working fine. In particular, I was able to access
https://pt.wikibooks.org/wiki/Special:EditWatchlist/raw
After I removed the 465 Topic:**************** pages, I'm able to load the page [[Special:EditWatchlist]] without error.

Quiddity added a subscriber: Legoktm.EditedJun 15 2016, 12:03 AM

This is about an InvalidDataException. We did have rare occurrences of InvalidInputException before in relation to Special:EditWatchlist: T73109: Fatal exception of type Flow\Exception\InvalidInputException when trying to view/edit watchlist. I vaguely recall that was due to an oversighted topic (or that was just a suspected cause, not sure).

I see there's also recent work on Linker by @Legoktm in T136352: Special:EditWatchlist is broken in response to a InvalidArgumentException bug, but I'm not sure if that's at all related.

Restricted Application added a project: Growth-Team. · View Herald TranscriptAug 23 2018, 2:09 PM
Quiddity removed a subscriber: Quiddity.Aug 23 2018, 8:13 PM
Krinkle changed the task status from Open to Stalled.Sep 16 2018, 7:01 PM
Krinkle added a subscriber: Krinkle.

I see no instances of message:InvalidDataException AND SpecialEditWatchlist in WMF Logstash for at least 30 days. Perhaps this issue has a different error message now. Can someone familiar with the issue try to reproduce it?

Krinkle closed this task as Resolved.Nov 7 2018, 4:19 AM
mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:11 PM