Page MenuHomePhabricator

deploy 1.28.0-wmf.19 to group1 wikis broke template RTL placement
Closed, ResolvedPublic

Description

Deploying the train broke the RTL placement, navigation boxes moved from left to right, see attached screenshot.

Hashar reverted the deploy.

Capture of https://he.wikipedia.org/wiki/%D7%A7%D7%99%D7%95%D7%91

After importing the page + templates on beta cluster at https://he.wikipedia.beta.wmflabs.org/wiki/%D7%A7%D7%99%D7%95%D7%91 the same issue is reproducible:

Event Timeline

Matanya created this task.Sep 14 2016, 7:31 PM
Restricted Application added a project: I18n. · View Herald TranscriptSep 14 2016, 7:31 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Matanya triaged this task as Unbreak Now! priority.Sep 14 2016, 7:32 PM
Restricted Application added subscribers: Jay8g, Luke081515, TerraCodes. · View Herald TranscriptSep 14 2016, 7:32 PM
hashar added a subscriber: hashar.Sep 14 2016, 7:36 PM

We will want to import page and its dependency on beta cluster and see whether the master branch is impacted.

https://he.wikipedia.beta.wmflabs.org/wiki/%D7%A7%D7%99%D7%95%D7%91

I have done an export of page קיוב with all templates and imported it on beta cluster :

Importing pages...

קיוב 1 revision
תבנית:Imdb title 1 revision
תבנית:Pv-options 1 revision
תבנית:Pv-options/internal 1 revision
תבנית:אנגלית 1 revision
תבנית:בלי סוגריים מרובעים 1 revision
תבנית:הערה 1 revision
תבנית:הערה/קוד 1 revision
תבנית:הערות שוליים 1 revision
תבנית:כ 1 revision
תבנית:ללא גלישה 1 revision
תבנית:מימין לשמאל 1 revision
תבנית:מקור 1 revision
תבנית:סרט 1 revision
תבנית:עין הדג 1 revision
תבנית:פירוש נוסף 1 revision
תבנית:פירושון 1 revision
תבנית:קטגוריה בתבנית 1 revision
תבנית:קישור אם קיים 1 revision
תבנית:קישור ויקינתונים 1 revision
תבנית:שפת קישור 1 revision
תבנית:תבנית מידע 1 revision
תבנית:תבנית מידע/שורה 1 revision
יחידה:ParamValidator 1 revision
יחידה:PropertyLink 1 revision
יחידה:סוגריים 1 revision
יחידה:פרמטרים 1 revision
יחידה:תאריך 1 revision

Hasher imported the affected template and reproduced on beta, see attached screenshot

Good news, with the import the issue is reproducible on the beta cluster as of now!!! https://he.wikipedia.beta.wmflabs.org/wiki/%D7%A7%D7%99%D7%95%D7%91 matanya confirmed that is broken and will upload a screenshot.

hashar updated the task description. (Show Details)Sep 14 2016, 7:42 PM
greg added a subscriber: greg.Sep 14 2016, 7:43 PM

The styles to move the infobox on the left are in MediaWiki:Common.css. These styles are not being applied for some reason.

Awesome @Legoktm thank you very much. I am holding the train for group 1 till that issue is figured out or patch reverted.

CCing authors of https://gerrit.wikimedia.org/r/#/c/309258/

I am holding the MW train pending resolution of this bug. Will push group1 on Thursday.

If the issue is too nasty, maybe it is "easier" to just revert https://gerrit.wikimedia.org/r/#/c/309258/ and proceed. Then figure out a proper solution later on.

Change 310671 had a related patch set uploaded (by Krinkle):
resourceloader: Add T145673 regression test

https://gerrit.wikimedia.org/r/310671

The bug fixed in https://gerrit.wikimedia.org/r/310671 caused site styles not to be loaded because of the following:

  • Preload logic didn't account for localised titles. It fetched the data, but the canonical keys and internal keys didn't match so intersecting the data from the batch query result produced an empty array.
  • This makes isKnownEmpty() return true.
  • This makes OutputPage() forgo loading of the module in favour of setting state to ready instead of making an http request for an empty response.
Krinkle claimed this task.Sep 14 2016, 9:56 PM
Krinkle edited projects, added MediaWiki-ResourceLoader; removed CSS, MediaWiki-General.
Krinkle added a project: Performance-Team.
Krinkle moved this task from Inbox to Assigned on the MediaWiki-ResourceLoader board.
Krinkle moved this task from Inbox to Doing on the Performance-Team board.

Change 310679 had a related patch set uploaded (by Krinkle):
resourceloader: Fix WikiModule preload to support localised titles

https://gerrit.wikimedia.org/r/310679

Change 310671 merged by jenkins-bot:
resourceloader: Fix WikiModule preload to support localised titles

https://gerrit.wikimedia.org/r/310671

Change 310679 merged by jenkins-bot:
resourceloader: Fix WikiModule preload to support localised titles

https://gerrit.wikimedia.org/r/310679

Mentioned in SAL (#wikimedia-operations) [2016-09-14T22:36:03Z] <krinkle@tin> Synchronized php-1.28.0-wmf.19/includes/resourceloader/ResourceLoaderWikiModule.php: T145673 (duration: 00m 47s)

Krinkle closed this task as Resolved.Sep 15 2016, 3:27 AM
Matanya renamed this task from deploy group1 wikis to 1.28.0-wmf.19 broke template RTL placement to deploy 1.28.0-wmf.19 to group1 wikis broke template RTL placement.Sep 15 2016, 5:08 AM

Awesome! Thank you for the quick and speedy fix :-}

Confirmed: Hewiki on 1.28.0-wmf.19 and it no more has the issue.