Page MenuHomePhabricator

Remove deprecated `.mw-ui-constructive` modifier class for anchors & text
Closed, ResolvedPublic

Description

Mediawiki.UI's .mw-ui-constructive modifier class for anchors & text was deprecated in MW 1.27 and 1.28 RC 0.
The usage instances were completely removed in core and any major extension in T146923: Replace usages of mw-ui-primary and mw-ui-constructive with mw-ui-progressive (1.28).

Let's remove it entirely.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 12 2017, 11:52 PM

Change 331936 had a related patch set uploaded (by VolkerE):
Remove deprecated .mw-ui-constructive class for text and anchors

https://gerrit.wikimedia.org/r/331936

Change 331936 merged by jenkins-bot:
Remove deprecated .mw-ui-constructive class for text and anchors

https://gerrit.wikimedia.org/r/331936

Volker_E closed this task as Resolved.Jan 19 2017, 12:11 AM
Volker_E edited projects, added UI-Standardization-Kanban; removed Patch-For-Review.
Restricted Application added a project: UI-Standardization. · View Herald TranscriptJan 19 2017, 12:11 AM

@Liuxinyu970226 Thanks for pointing this out!
By help of automated translation, it seems to me, that the main argument is about replacing the class needs editors work best by help of a bot. It doesn't say, that people are opposing the change generally, correct? Maybe @dchan or @chelsyx could help reassuring this?

Hi. Are there some migration rules? We have 11 instances, and I do not know what to do with them. Thank you.

@IKhitron Yes, guidelines for migration are:

  • .mw-ui-constructive should be changed over to .mw-ui-progressive as long as it's the primary action in the view. There shouldn't be more than one primary (aka progressive) button in one view.
  • If there's already an .mw-ui-progressive for the primary action existing, please consider just .mw-ui-button for the others

Exemplified at Hebrew Wikipedia:Welcome

  • .mw-ui-constructive should be removed and
  • the inline color style color:#fff; should be removed too.

When those button classes are used in wikitext to make a link look like a button, it would default to blue text on light-grey background. You could consider using color:#222 for inline style to make it resemble a normal button.

Please let me know if you've got any further questions…

Thank you very much.

Btw, 3 of them are in commons.

@Liuxinyu970226 Thanks for pointing this out!
By help of automated translation, it seems to me, that the main argument is about replacing the class needs editors work best by help of a bot. It doesn't say, that people are opposing the change generally, correct? Maybe @dchan or @chelsyx could help reassuring this?

@Volker_E Your understanding looks correct to me. :)

Dvorapa removed a subscriber: Dvorapa.
Elitre added a subscriber: Elitre.Jul 25 2017, 8:00 AM

I am not sure I understand what happened here, since this task was resolved 6 months ago?

@Elitre We've deprecated the green shaded buttons (.mw-ui-constructive) in MW 1.27 and removed all its instances from our products a while ago as it was not a successful, but more confusing UX pattern. But mediawiki.UI was intended to be a collection of user interface CSS helper classes that could be used by authors and community gadget or extension developers apart from only Wikimedia Foundation products.
Just recently we've completely removed the CSS class hoping that there are not many instances where it's still used.
While we've got developer tools to officially deprecate certain code functionality and make devs aware of this in their daily work, we don't have the possibility with CSS.
There seemingly were leftovers where the class was still in use (see above) and the appearance of mw-ui-constructive buttons suddenly changed due to its removal. I'm happy to help with technical support in cases where
Does this answer your question?