Page MenuHomePhabricator

Disallow adding Czech language tag (cs-CZ) into citation templates on cswiki
Closed, DeclinedPublic

Description

Citoid adds our national Czech (cs-CZ) language if citing Czech reference, which is according to users and cswiki rules pointless. Could you disallow this behavior?

Requested by users on Czech technical Village pump here.

The example of this issue is [1]. Look for parameter "jazyk" (language)

Event Timeline

Dvorapa created this task.Jan 28 2017, 1:28 PM
Dvorapa updated the task description. (Show Details)
Mvolz moved this task from Backlog to Zotero on the Citoid board.Jan 28 2017, 1:30 PM
Dvorapa updated the task description. (Show Details)Jan 28 2017, 1:31 PM
Mvolz added a subscriber: Mvolz.Jan 28 2017, 1:37 PM

Unfortunately there's no way to do this through template data. Previous requests for this were declined as it was decided this was something the citation template should handle: T97256

In fr wiki they handle this by ignoring the field when the language field is fr.

Mvolz closed this task as Declined.Jan 28 2017, 1:39 PM
Dvorapa added a comment.EditedJan 28 2017, 1:47 PM

Unfortunately there's no way to do this through template data. Previous requests for this were declined as it was decided this was something the citation template should handle: T97256
In fr wiki they handle this by ignoring the field when the language field is fr.

Yes, we discussed the same partial solution solution, but no, automatic adding useless code into pages is not the correct behavior of the editor according to our users. Is there any possibility to stop VE doing that (e.g. some JS gadget for VE)? After all VE acts against our cswiki community rules.

@Mvolz You closed T97256, but enwiki's community maybe haven't got rules for marking citations as english, cswiki's community does

Mvolz added a comment.Jan 28 2017, 1:51 PM

You can remove the language field from the template data in the template entirely, and then it won't add in any language. Or remove specific values after the fact with a bot.

But, there's currently no way to specify that certain information should or should not be added to the template by *value*, only by field. Possibly a CS-specific gadget could do that?

Ok, so you think we should setup a bot that will war with VisualEditor? I don't think this is good idea. Enwiki has reason for marking references/external links as written in English. Enwiki is not read by native speakers only. But cswiki is. Therefore it doesn't make sense for marking links as written in Czech. It's something like if you mark a wiki page with "editable" tag.

The TemplateData solution won't work as the language field is quite useful in other cases. CSS gadget (if the CS was a mistake) is better idea...

BTW I know there is no config value for disable adding certain codes. So could you treat the request as request for adding one? I think this won't be only cswiki problem.

Dvorapa added a comment.EditedJan 28 2017, 2:08 PM

@Mvolz I think CS-specific JS gadget would do, but I can't code this by using VE API only. VE gadget API is not cut out for purposes like this.

@Urbanecm CSS is the same solution as changing template's code not to show Czech language. It still doesn't solve our issue. I have to agree more national Wikipedias could struggle with the same issue.

@Dvorapa Much better will be if we don't need to get rid of it but better then writing a bot too.

Dvorapa added a comment.EditedJan 28 2017, 6:16 PM

@Urbanecm In addition, flooding article history by bot would have no support in cswiki's community, novice users would ask, what they did wrong bot has to fix (nothing).

Dvorapa reopened this task as Open.Jan 11 2018, 9:45 AM

Users of Czech Wikipedia complained again (details), reopening

TheDJ added a subscriber: TheDJ.Feb 8 2018, 3:49 PM

When I read: "I do not understand why developers do not want to accept the fact that each Wiki has citation templates built a little differently and according to some other standards."

then I hear: "The construction inspectors should just accept that everyone wants to build their house a little different and everyone should be allowed to have their own building code"

That's just not how ANY of this works, and people who think it does, should start their own wiki and waste their own time on issues like this.
<feeling grumpy today />

Mvolz added a comment.Feb 8 2018, 3:57 PM

As noted earlier, there are several options:

  1. You can remove the language parameter entirely from the citoid map in the templatedata field. This will stop the language code from being added from any language.
  2. Change the citation template so that it does not display the language if the language is czech. In my opinion this is the best option and it is what many other wikis do.
  3. Have bots clean it up. This is not a "war" because it only happens once; there's a VE edit followed by a bot edit. There are bots that do similar things other wikis all the time and it is not a problem.

These are all viable options but they're something the *community* needs to decide on which one and implement. It would be great if someone could present these options to the community and decide there.

Dvorapa added a comment.EditedFeb 8 2018, 9:36 PM

Well, the community of Czech Wikipedia users has chosen the option two, but please try to understand, that nobody from our community doesn't fully understand, why we should fix by ourselves some bug made by developers. There are tendencies in our community not to trust WM developers, because there were issues with language list folding, OOUI pages, mobile view and many others in the past and developers didn't want to fix many of them.

There is also another similar issue, T115326. Our templates are strictly using ISO 639-1 standard two-letter codes and now Citoid ignores this policy and adds four-letter codes. And we blamed innocent users for that. There was an issue with TemplateData and templates without paramOrder were still sorted by VE. And we also blamed innocent users for that. Problems like these just make users upset to admins and admins upset to developers.

Last month I got an email from multiple Czech Wikipedia admins, that block page on mobile phone is broken and they can not block vandalisms using a mobile phone. I asked them why don't they create a task on Phabricator and report the issue to developers. And I got an answer, that the developers would do nothing, or even reject this, because this is the issue with OOUI and developers would not change OOUI to make block page work. So they asked me to create a gadget to turn off OOUI on Special:Block page on mobile phone to make Special:Block work on mobile phone again.

Well, you should understand at least partially the distrust to WM devs from cswiki community. And this issue is only another brick to the wall between users and developers. Nobody gets why Citoid should continue adding our language to the template. We have got a really old policy that our language should not be added to citation templates or next to the external links by users. But now Citoid does this and we used to blame innocent users for that, when we didn't know this is an issue in Citoid. This is just an unnecessary piece of page source adding unnecessary bytes to Wikimedia database/server storage creating unnecessary conflicts between users.

I personally don't care about the result of this task, I'm only a spokesperson. But you must understand I'm sick of explaining to users that developers aren't as mean as it looks like, and opposite, sick of explaining to developers that Czech Wikipedia users are not dumb. Also note that I'm sick of recurring complaints about this particular issue, like every month on technical village pump, that's why I'm making efforts to solve issues like this one.

Mvolz closed this task as Declined.Feb 9 2018, 9:31 AM
Mvolz added a comment.EditedFeb 9 2018, 9:45 AM

Well, the community of Czech Wikipedia users has chosen the option two, but please try to understand, that nobody from our community doesn't fully understand, why we should fix by ourselves some bug made by developers. There are tendencies in our community not to trust WM developers, because there were issues with language list folding, OOUI pages, mobile view and many others in the past and developers didn't want to fix many of them.
There is also another similar issue, T115326. Our templates are strictly using ISO 639-1 standard two-letter codes and now Citoid ignores this policy and adds four-letter codes. And we blamed innocent users for that. There was an issue with TemplateData and templates without paramOrder were still sorted by VE. And we also blamed innocent users for that. Problems like these just make users upset to admins and admins upset to developers.
Last month I got an email from multiple Czech Wikipedia admins, that block page on mobile phone is broken and they can not block vandalisms using a mobile phone. I asked them why don't they create a task on Phabricator and report the issue to developers. And I got an answer, that the developers would do nothing, or even reject this, because this is the issue with OOUI and developers would not change OOUI to make block page work. So they asked me to create a gadget to turn off OOUI on Special:Block page on mobile phone to make Special:Block work on mobile phone again.
Well, you should understand at least partially the distrust to WM devs from cswiki community. And this issue is only another brick to the wall between users and developers. Nobody gets why Citoid should continue adding our language to the template. We have got a really old policy that our language should not be added to citation templates or next to the external links by users. But now Citoid does this and we used to blame innocent users for that, when we didn't know this is an issue in Citoid. This is just an unnecessary piece of page source adding unnecessary bytes to Wikimedia database/server storage creating unnecessary conflicts between users.
I personally don't care about the result of this task, I'm only a spokesperson. But you must understand I'm sick of explaining to users that developers aren't as mean as it looks like, and opposite, sick of explaining to developers that Czech Wikipedia users are not dumb. Also note that I'm sick of recurring complaints about this particular issue, like every month on technical village pump, that's why I'm making efforts to solve issues like this one.

Thanks for being the go-between @Dvorapa. I think at issue here is that everyone has different opinions and every wiki is different, but we're making software that's supposed to be flexible enough for every use case and that's not always simple. That's why wikis have the ability to configure things differently on every single wiki. Unfortunately that can sometimes be interpreted as "making the community do the work" but in reality that's a feature, not a bug :). We could have probably avoided this on cz wiki entirely by simple removing the lang parameter in the citoid maps for citations there, and just making users add it manually as they used to. Probably no one would have even noticed that the data is missing (especially as there's often even more critical data missing in plenty of citations!)

But, I didn't want to overstep there by doing the edits myself, once it became controversial. It's unfortunate this became a contentious issue as it probably didn't need to be.

Dvorapa added a comment.EditedFeb 9 2018, 10:56 AM

@Mvolz Overall this is a really useful feature, not buggy in other ways (like detecting wrong language), so we adapted our templates for both issues and not more blame users as we know a majority of them dodn't do that manually and the others are now undetectable.

I understand you are trying to make it as flexible as possible. I just thought of some form of per-project config for Citoid would be awesome. In the old wikitext editor there is a gadget called RefToolbar, which adds similar functionality for old wikitext editor. This gadget has got also per-project config file. I haven't looked into Citoid's code, but I thought there was maybe some config for local citation templates parameters. And if there is a config file, there can simply be added options like language_format for T115326 and not_insert_languages for this issue.