Page MenuHomePhabricator

Incorrect display of Special:ListProperties (regression)
Closed, ResolvedPublic

Description

In https://www.wikidata.org/w/index.php?title=Special:ListProperties&uselang=zh,

  1. All property labels are in English even I have change the interface language to Chinese
  2. The properties are displayed in a order of P10, P1000, P1001, ..., P103, ... which make no sense, the previous and more proper order is P6, P10, P14, ...

Event Timeline

Restricted Application added a project: Wikidata. · View Herald TranscriptFeb 14 2017, 8:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Bugreporter updated the task description. (Show Details)Feb 14 2017, 8:01 PM
thiemowmde triaged this task as High priority.Mar 26 2017, 2:26 PM
thiemowmde added a subscriber: Ladsgroup.

I believe this regression happened in https://gerrit.wikimedia.org/r/332011, where the language was accidentally changed from the users to the wikis content language.

Ordering can not be "fixed" so easily, because there is no numeric ID any more we can use to order numerically. It might be possible to apply a workaround, but I'm not sure if this is worth it.

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptMar 26 2017, 2:33 PM

Change 344822 had a related patch set uploaded (by Thiemo Mättig (WMDE)):
[mediawiki/extensions/Wikibase@master] Fix Special:ListProperties not using the users language

https://gerrit.wikimedia.org/r/344822

thiemowmde claimed this task.
thiemowmde moved this task from incoming to in progress on the Wikidata board.

Change 344822 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Fix Special:ListProperties not using the users language

https://gerrit.wikimedia.org/r/344822

Aleksey_WMDE lowered the priority of this task from High to Normal.
matej_suchanek added a subscriber: matej_suchanek.EditedMar 27 2017, 2:45 PM

Ordering can not be "fixed" so easily, because there is no numeric ID any more we can use to order numerically. It might be possible to apply a workaround, but I'm not sure if this is worth it.

Order by page_id?

page_id is the internal number MediaWiki uses, and very different from Wikibase's entity ID. It might be that the order is the same, because both numbers increase every time a new entity is created. So this might indeed be a possible workaround, but not a clean solution.

Moving back to proposed for the team to pick up.

@Bugreporter @matej_suchanek: can you quickly say what you use the page for? That'd help me in figuring out the desired behaviour.

I do not rely on that page much, maybe I sometimes look for how many properties we have for rare datatypes. Anyway, now I'm trying to work out either how the ordering by id, which is just internal stuff, could be useful.

I would appreciate having it ordered by the date the property was created, newest first, or by usage (which I'm afraid isn't possible).

Also, some kind of sorting has already been asked for in T107880.

Gerritbot doesn't make comment when I make a patch: https://gerrit.wikimedia.org/r/347985

This patch fixes the ordering issue and orders by numeric id. I spend some time to figure what's the best way to do it and this is the cleanest way I came up with but still it's hacky and ugly IMO. Feel free to say "just throw it away"

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptApr 12 2017, 9:32 PM
Ladsgroup moved this task from Proposed to Review on the Wikidata-Former-Sprint-Board board.
matej_suchanek moved this task from Backlog to Doing on the good first bug board.

Change 347985 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Order properties in SpecialListProperties based on numeric id

https://gerrit.wikimedia.org/r/347985

Ladsgroup closed this task as Resolved.
matej_suchanek moved this task from Doing to Done on the good first bug board.Apr 18 2017, 2:42 PM
matej_suchanek removed a project: Patch-For-Review.
matej_suchanek removed a subscriber: matej_suchanek.