Page MenuHomePhabricator

Dropdown options of Upload Wizard are broken (copy metadata, add location and more, non-own-work license options)
Closed, ResolvedPublic

Description

Dropdown options for copying fields to other images, and for further information including location do not work today. They worked yesterday.

Reported on Commons:

Event Timeline

Restricted Application added a project: Multimedia. · View Herald TranscriptMay 25 2017, 10:33 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Framawiki renamed this task from Upload WIzard to Dropdown options of Upload Wizard are broken.May 25 2017, 11:06 AM
Framawiki updated the task description. (Show Details)
Framawiki added a subscriber: Framawiki.

I can reliably reproduce this. No obvious errors in console.

Wednesday => probably MediaWiki train. The only recent change in UW's code is 3740018, so cc @matthiasmullie.

zhuyifei1999 removed Rodhullandemu as the assignee of this task.May 25 2017, 12:36 PM
Aklapper triaged this task as High priority.May 25 2017, 1:46 PM
Aklapper added a project: Regression.
Aklapper added a subscriber: matmarex.
matmarex renamed this task from Dropdown options of Upload Wizard are broken to Dropdown options of Upload Wizard are broken (copy metadata doesn't work).May 25 2017, 3:47 PM

I believe the issue is not in UW (works on my local machine) but in core (stopped working on my machine when I updated that)
I'll keep looking into this.

matmarex renamed this task from Dropdown options of Upload Wizard are broken (copy metadata doesn't work) to Dropdown options of Upload Wizard are broken (copy metadata, add location and more, non-own-work license options).May 25 2017, 7:05 PM
matmarex claimed this task.
matmarex raised the priority of this task from High to Unbreak Now!.
Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptMay 25 2017, 7:05 PM

Change 355642 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/UploadWizard@master] Unbreak usages of $.fn.makeCollapsible with custom <a> toggle

https://gerrit.wikimedia.org/r/355642

matmarex added a comment.EditedMay 25 2017, 7:15 PM

Thanks for the pointer Matthias, I remembered a change related to makeCollapsible() that was merged recently (2d95d36a8ed296813e686e9b756c2bb7c306950f) and I was able to easily confirm it was the problem. The workaround above fixes the problem for us.

Change 355642 abandoned by Bartosz Dziewoński:
Unbreak usages of $.fn.makeCollapsible with custom <a> toggle

Reason:
Alternative patch: https://gerrit.wikimedia.org/r/355715

https://gerrit.wikimedia.org/r/355642

Change 355715 had a related patch set uploaded (by Bartosz Dziewoński; owner: Krinkle):
[mediawiki/core@master] jquery.makeCollapsible: Restore considering empty <a> as part of toggle

https://gerrit.wikimedia.org/r/355715

Change 355715 merged by jenkins-bot:
[mediawiki/core@master] jquery.makeCollapsible: Restore considering empty <a> as part of toggle

https://gerrit.wikimedia.org/r/355715

Change 355721 had a related patch set uploaded (by Bartosz Dziewoński; owner: Krinkle):
[mediawiki/core@wmf/1.30.0-wmf.2] jquery.makeCollapsible: Restore considering empty <a> as part of toggle

https://gerrit.wikimedia.org/r/355721

kaldari closed this task as Resolved.May 25 2017, 9:45 PM
kaldari added a subscriber: kaldari.

Tested locally and seems to be fixed.

@matmarex: This also needs to be backported to wmf/1.30.0-wmf.2.

matmarex updated the task description. (Show Details)

Change 355721 merged by jenkins-bot:
[mediawiki/core@wmf/1.30.0-wmf.2] jquery.makeCollapsible: Restore considering empty <a> as part of toggle

https://gerrit.wikimedia.org/r/355721

Mentioned in SAL (#wikimedia-operations) [2017-05-25T23:44:46Z] <thcipriani@tin> Synchronized php-1.30.0-wmf.2/resources/src/jquery/jquery.makeCollapsible.js: SWAT: [[gerrit:355721|jquery.makeCollapsible: Restore considering empty <a> as part of toggle]] T166298 (duration: 00m 42s)