MW-1.30.0-wmf.2 deployment blockers
Closed, ResolvedPublic

Related Objects

StatusAssignedTask
Resolvedthcipriani
ResolvedAnomie
ResolvedMhurd
ResolvedMhurd
ResolvedMholloway
ResolvedABorbaWMF
Resolvedssastry
Resolvedssastry
Resolveddchan
ResolvedJdforrester-WMF
ResolvedJdforrester-WMF
ResolvedCatrope
ResolvedCatrope
ResolvedAnomie
Resolvedmatmarex
ResolvedGilles
OpenTheDJ
greg created this task.Apr 20 2017, 10:20 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 20 2017, 10:20 PM

Will there be a wmf.24 as well?

greg added a comment.Apr 24 2017, 7:24 PM

Actually, I went too far. Chad will be branching 1.30 this week. I'll rename these after his announce email.

greg renamed this task from MW-1.29.0-wmf.23 deployment blockers to MW-1.30.0-wmf.2 deployment blockers.Apr 25 2017, 9:07 PM
greg updated the task description. (Show Details)
greg added a comment.May 16 2017, 3:21 AM

Added some blocking tasks that should be resolved before we branch/roll out wmf.2 (which caused production breakage last week).

hashar added a subscriber: hashar.May 22 2017, 10:13 AM
Elitre added a subscriber: Elitre.

(If I understood Greg's directions correctly, T37247 belongs here.)

He7d3r added a subscriber: He7d3r.May 22 2017, 11:20 PM

Mentioned in SAL (#wikimedia-operations) [2017-05-23T17:09:04Z] <thcipriani> starting branch cut for 1.30.0-wmf.2 T163512

dr0ptp4kt moved this task from Backlog to Next Up on the Reading-Admin board.
greg added a comment.May 25 2017, 9:31 PM

From the newly created blocking sub-task:

setting as UBN! since we're stuck on wmf.1 until we can figure this out.

Just to be clear: as of this moment wmf.2 is on group0 (testwikis) and group1 (non-wikipedias, like commons, wikisource, etc). group2 ('pedias) is the only one on wmf.1. There is no clear indication that reverting group0 and group1 is needed at this moment. Please shout if that is incorrect/changes!

@greg cawiki and hewiki are on wmf.2, if needed they also need to revert.

@greg cawiki and hewiki are on wmf.2, if needed they also need to revert.

Rollback is due to performance issues related to enwiki ( T166345 ), most probably due to load. cawiki / hewiki can stay on wmf.2 for now unless there is a reason to roll them back.

greg added a comment.May 26 2017, 5:37 PM

Cross-posting from the blocking task:

Status update from RelEng:

We don't have any plans to roll out wmf.2 any further today (Friday the 26th). We still don't have a root cause and we're going into a 3 day weekend.

We have confirmation from the Performance Team that they (Krinkle) will begin investigating this from their side in a couple of hours time (around 19:30 UTC).

Ping us (probably thcipriani on IRC) if you want any other production app/debug servers to have wmf.2 put on them for testing. We'll/he'll be around and available for that.

Johan, adding it here as Tech News is likely wrong now.

Johan added a subscriber: Johan.May 26 2017, 11:31 PM

Keeping track of it. Tentatively adding contradictory information to Tech News; will remove whatever's not relevant come Monday.

thcipriani closed this task as Resolved.Mon, Jun 5, 4:38 PM

wrong workboard :)

Krinkle updated the task description. (Show Details)Mon, Jun 5, 5:29 PM