[regression] Broken link in a user rights change notification email from Echo
Closed, ResolvedPublic

Description

I've just received an user rights change notification email from Echo, and the main link in it points to a relative URL /wiki/%D8%AE%D8%A7%D8%B5:%D9%88%D8%B5%D9%84%D8%A9_%D8%AF%D8%A7%D8%A6%D9%85%D8%A9/23718221 rather than an absolute one. The email is in Arabic (from ar.wikipedia.org).


The message on Special:Notifications and in the flyout also seems to have a broken link, in English as well as Arabic:

matmarex created this task.Aug 6 2017, 11:51 AM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptAug 6 2017, 11:51 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Could it be the case of custom email formatting ? In betalabs there is no additional link such as in the message text:

<a href=3D"/wiki/%D8%AE%D8%A7%D8%B5:%D9%88%D8%B5%D9%84%D8%A9_%D8%AF=
%D8%A7%D8%A6%D9%85%D8%A9/23718221" title=3D"=D8=AE=D8=A7=D8=B5:=D9=88=D8=B5=
=D9=84=D8=A9 =D8=AF=D8=A7=D8=A6=D9=85=D8=A9/23718221">=D8=AE=D8=A7=D8=B5:=
=D8=B1=D8=A7=D8=A8=D8=B7 =D8=AF=D8=A7=D8=A6=D9=85/23718221</a>

I attached the sample of the user rights change email from beta hewiki :

Mattflaschen-WMF renamed this task from Broken link in a user rights change notification email from Echo to [regression] Broken link in a user rights change notification email from Echo.Aug 29 2017, 5:43 PM
Mattflaschen-WMF triaged this task as High priority.

This is a link provided by the user via wikitext (the wikitext is a reason for the group change). See dupe I'm about to merge in.

We could (it would be better if we do parse it):

  • Ask the parser to parse with full URLs (if this is possible). I believe it is being parsed by the message system.
  • Or if that isn't available, just expand all links after parsing the body message.
  • Consistently not parse the link.

When overhauling the notification system in 2015 we decided that links in notification text were not going to be supported. I think we should not parse them consistently in emails as well as in the web UI.

Change 403150 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/extensions/Echo@master] Format user-rights reason as plain text

https://gerrit.wikimedia.org/r/403150

Change 403150 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Format user-rights reason as plain text

https://gerrit.wikimedia.org/r/403150

Checked in betalabs - the Reason on Special:UserRights is not displayed as a link anymore - not in email and not in Alerts:

From the email source:

Your user rights were changed. You have been added to: =E2=80=AAPatrollers=
=E2=80=AC.

checking email and Notifications format when user rights are changed

Learn more:  <https://en.wikipedia.beta.wmflabs.org/wiki/Special:ListGroupR=
ights?markasread=3D768746#patroller>

=E2=80=AAEtonkovidova=E2=80=AC:  <https://en.wikipedia.beta.wmflabs.org/wik=
i/User:Etonkovidova>

Public log:  <https://en.wikipedia.beta.wmflabs.org/w/index.php?title=3DSpe=
cial:Log&type=3Drights&page=3DUser%3AET70&user=3DEtonkovidova>
Etonkovidova closed this task as Resolved.Jan 10 2018, 7:43 PM