Fatal: Wikimedia\Rdbms\DBQueryError on Special:AbuseFilter/examine: "Error: 1054 Unknown column 'rev_id' in 'field list' (10.64.16.191)"
Closed, ResolvedPublic

Description

Trying to examine past edits from a user on mediawiki.org gives an exception:

[WbJgwgpAEKkAACsqsGoAAAAI] 2017-09-08 09:20:02: Fatal exception of type "Wikimedia\Rdbms\DBQueryError"

https://www.mediawiki.org/wiki/Special:AbuseFilter/examine?wpSearchUser=Babaji33&wpSearchPeriodStart=&wpSearchPeriodEnd=&submit=1

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFri, Sep 8, 9:20 AM
WbJgwgpAEKkAACsqsGoAAAAI
Function: IndexPager::buildQueryInfo (AbuseFilterExaminePager)
Error: 1054 Unknown column 'rev_id' in 'field list' (10.64.16.191)
#0 /srv/mediawiki/php-1.30.0-wmf.17/includes/libs/rdbms/database/Database.php(979): Wikimedia\Rdbms\Database->reportQueryError(string, integer, string, string, boolean)
#1 /srv/mediawiki/php-1.30.0-wmf.17/includes/libs/rdbms/database/Database.php(1343): Wikimedia\Rdbms\Database->query(string, string)
#2 /srv/mediawiki/php-1.30.0-wmf.17/includes/pager/IndexPager.php(368): Wikimedia\Rdbms\Database->select(string, array, array, string, array, array)
#3 /srv/mediawiki/php-1.30.0-wmf.17/includes/pager/IndexPager.php(225): IndexPager->reallyDoQuery(string, integer, boolean)
#4 /srv/mediawiki/php-1.30.0-wmf.17/includes/pager/IndexPager.php(608): IndexPager->doQuery()
#5 /srv/mediawiki/php-1.30.0-wmf.17/includes/pager/ReverseChronologicalPager.php(35): IndexPager->isNavigationBarShown()
#6 /srv/mediawiki/php-1.30.0-wmf.17/extensions/AbuseFilter/includes/Views/AbuseFilterViewExamine.php(68): ReverseChronologicalPager->getNavigationBar()
#7 /srv/mediawiki/php-1.30.0-wmf.17/extensions/AbuseFilter/includes/Views/AbuseFilterViewExamine.php(57): AbuseFilterViewExamine->showResults()
#8 /srv/mediawiki/php-1.30.0-wmf.17/extensions/AbuseFilter/includes/Views/AbuseFilterViewExamine.php(26): AbuseFilterViewExamine->showSearch()
#9 /srv/mediawiki/php-1.30.0-wmf.17/extensions/AbuseFilter/includes/special/SpecialAbuseFilter.php(115): AbuseFilterViewExamine->show()
#10 /srv/mediawiki/php-1.30.0-wmf.17/includes/specialpage/SpecialPage.php(522): SpecialAbuseFilter->execute(string)
#11 /srv/mediawiki/php-1.30.0-wmf.17/includes/specialpage/SpecialPageFactory.php(578): SpecialPage->run(string)
#12 /srv/mediawiki/php-1.30.0-wmf.17/includes/MediaWiki.php(287): SpecialPageFactory::executePath(Title, RequestContext)
#13 /srv/mediawiki/php-1.30.0-wmf.17/includes/MediaWiki.php(848): MediaWiki->performRequest()
#14 /srv/mediawiki/php-1.30.0-wmf.17/includes/MediaWiki.php(523): MediaWiki->main()
#15 /srv/mediawiki/php-1.30.0-wmf.17/index.php(43): MediaWiki->run()
#16 /srv/mediawiki/w/index.php(3): include(string)
#17 {main}
Aklapper renamed this task from Fatal: Wikimedia\Rdbms\DBQueryError on Special:AbuseFilter/examine to Fatal: Wikimedia\Rdbms\DBQueryError on Special:AbuseFilter/examine: "Error: 1054 Unknown column 'rev_id' in 'field list' (10.64.16.191)".Fri, Sep 8, 9:41 AM
Aklapper triaged this task as High priority.

Change 376709 had a related patch set uploaded (by Hashar; owner: Hashar):
[mediawiki/extensions/AbuseFilter@master] Select proper db fields in AbuseFilterExaminePager

https://gerrit.wikimedia.org/r/376709

The problem seems to be a side effect of this.

Suhadakashter closed this task as a duplicate of T175367: Page wikipedia.
Reedy reopened this task as Open.Fri, Sep 8, 2:11 PM
Anomie added a comment.Fri, Sep 8, 2:14 PM

I think that got fixed by @demon via 3f4ba191f68bd16e45ee9643a584a8f2ab3fb9d0

The opposite, actually.

Change 376709 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@master] Select proper db fields in AbuseFilterExaminePager

https://gerrit.wikimedia.org/r/376709

Change 376742 had a related patch set uploaded (by Chad; owner: Hashar):
[mediawiki/extensions/AbuseFilter@wmf/1.30.0-wmf.17] Select proper db fields in AbuseFilterExaminePager

https://gerrit.wikimedia.org/r/376742

Change 376742 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@wmf/1.30.0-wmf.17] Select proper db fields in AbuseFilterExaminePager

https://gerrit.wikimedia.org/r/376742

Mentioned in SAL (#wikimedia-operations) [2017-09-08T16:04:37Z] <demon@tin> Synchronized php-1.30.0-wmf.17/extensions/AbuseFilter/includes/Views/AbuseFilterViewExamine.php: T175338, followup (duration: 00m 46s)

demon closed this task as Resolved.Fri, Sep 8, 4:05 PM
demon claimed this task.