Other review tools button and saved filters are misaligned in Recent Changes
Closed, ResolvedPublic

Description

The Recent Changes page provides two controls "Other review tools" and "Saved filters", as a user reported, these controls are not aligned. A screenshot below shows the issue:

Aligning them will not only help to perceive the UI as more clean but also save some vertical space by moving the rest of the page up as illustrated below:

When we fix this, we need to make sure we don't have a regression re. the functionality that makes the Other Review Tools box span the page in its open state. Meaning it is effectively on the same line as the Saved Filters in its closed state, but ABOVE saved filters in its open state. This stops the Review Tools HTML from being mashed up.

jmatazzoni updated the task description. (Show Details)

If this turns out to be not a Snack Box--i.e., if it is more complicated than it looks—then please raise the issue and we'll decide if it ranks attention or not.

Change 393754 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/core@master] Align other review tools and saved filters buttons

https://gerrit.wikimedia.org/r/393754

This is how it looks in FF with the submitted patch:

Change 393754 merged by jenkins-bot:
[mediawiki/core@master] Align other review tools and saved filters buttons

https://gerrit.wikimedia.org/r/393754

Etonkovidova added a comment.EditedNov 29 2017, 8:05 PM

Checked the fix in betalabs (FF, Chrome, Safari and for the monobook skin too) - the alignment looks as per the screenshot in @Petar.petkovic comment above.

Before the fix After the fix

QA Recommendation: Resolve

That looks so much better. Thanks @Petar.petkovic!

That looks so much better. Thanks @Petar.petkovic!

You are welcome!

jmatazzoni closed this task as Resolved.Nov 30 2017, 9:39 PM