Page MenuHomePhabricator

Multi-part templates are rendered backwards and have a slug inside them
Closed, ResolvedPublic1 Story Points

Description

None of these things should happen. Marking UBN because multi-part templates are pretty common.

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : wmf/1.31.0-wmf.15Update VE core submodule to master (8c5e78c7f)
mediawiki/extensions/VisualEditor : masterUpdate VE core submodule to master (8c5e78c7f)
VisualEditor/VisualEditor : masterFollow-up c7ef30a30f6: append multi-element nodes in the right order

Event Timeline

Catrope created this task.Dec 22 2017, 7:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 22 2017, 7:28 PM
Catrope triaged this task as Unbreak Now! priority.Dec 22 2017, 7:28 PM
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptDec 22 2017, 7:28 PM

The incorrect order appears to be broken in production too, but I can't reproduce the slug issue in production.

I believe T182704 may be related to, or a duplicate of, this.

Change 399888 had a related patch set uploaded (by Catrope; owner: Catrope):
[VisualEditor/VisualEditor@master] Follow-up c7ef30a30f6: append multi-element nodes in the right order

https://gerrit.wikimedia.org/r/399888

I believe T182704 may be related to, or a duplicate of, this.

Yes, pretty sure that's the same issue.

Change 399888 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Follow-up c7ef30a30f6: append multi-element nodes in the right order

https://gerrit.wikimedia.org/r/399888

greg added a subscriber: greg.Jan 2 2018, 5:52 PM

Change 399888 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Follow-up c7ef30a30f6: append multi-element nodes in the right order
https://gerrit.wikimedia.org/r/399888

Given this merge, this should go out with the train this week, but also given this is an UBN!, should this be swatted to all wikis? @Catrope / @Deskana

Deskana lowered the priority of this task from Unbreak Now! to High.Jan 2 2018, 6:52 PM

Given this merge, this should go out with the train this week, but also given this is an UBN!, should this be swatted to all wikis? @Catrope / @Deskana

I don't think this needs a SWAT. The kinds of templates that cause this problem appear to be rarely used. In fact, I think this may have been broken for a while without anyone noticing.

Change 401599 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (90a2a3834)

https://gerrit.wikimedia.org/r/401599

Change 401599 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (8c5e78c7f)

https://gerrit.wikimedia.org/r/401599

Given this merge, this should go out with the train this week, but also given this is an UBN!, should this be swatted to all wikis? @Catrope / @Deskana

I don't think this needs a SWAT. The kinds of templates that cause this problem appear to be rarely used. In fact, I think this may have been broken for a while without anyone noticing.

This patch was in the VisualEditor/VisualEditor repo, which is not branched regularly – only mediawiki/extensions/VisualEditor is, and the submodule update commit (https://gerrit.wikimedia.org/r/401599) was not merged in time for wmf.15 (we had CI issues). I will be swatting this, especially since it resolves one more annoying issue too (T182907).

Change 401771 had a related patch set uploaded (by Bartosz Dziewoński; owner: Jforrester):
[mediawiki/extensions/VisualEditor@wmf/1.31.0-wmf.15] Update VE core submodule to master (8c5e78c7f)

https://gerrit.wikimedia.org/r/401771

Change 401771 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@wmf/1.31.0-wmf.15] Update VE core submodule to master (8c5e78c7f)

https://gerrit.wikimedia.org/r/401771

Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2018-01-03T20:16:06Z] <thcipriani@tin> Synchronized php-1.31.0-wmf.15/extensions/VisualEditor/lib/ve: SWAT: [[gerrit:401771|Update VE core submodule to master]] T182907 T183590 (duration: 01m 06s)

matmarex closed this task as Resolved.Jan 3 2018, 8:33 PM
matmarex assigned this task to Catrope.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJan 3 2018, 8:33 PM
Deskana set the point value for this task to 1.Jan 4 2018, 11:05 AM
Deskana moved this task from To Triage to TR0: Interrupt on the VisualEditor board.

Thank you!