Page MenuHomePhabricator

Invisible text in new wikitext editor after large paste
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

Most of the text will be invisible. It can be selected, and reappears as soon as the text is changed.

Seen in Chrome 63.0.3239.132, Ubuntu 16.04.

Details

Related Gerrit Patches:
mediawiki/extensions/CodeMirror : masterVE: Use different approach for transparent text issue
mediawiki/extensions/CodeMirror : masterDefer update of CM surface to avoid invisible text

Event Timeline

Tgr created this task.Jan 18 2018, 8:14 AM
Restricted Application added a project: VisualEditor. · View Herald TranscriptJan 18 2018, 8:14 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I can't reproduce this. Do you have syntax highlighting enabled? Any exceptions in the console?

Tgr added a comment.Jan 18 2018, 8:50 PM

Yeah, sorry, I forgot to mention I have syntax highlight on (and it doesn't happen without that). I tried to reproduce this with another account with the same beta features enabled but couldn't - so maybe some gadget? I don't have anything obviously edit area related, though.

No exceptions. The whole thing feels more like a browser error than a VE error: the text is present (the DOM nodes are there in developer toolbar) but invisible, there is no obvious reason for it to be invisible (the visible and invisible rows have the same structure and attributes), and the behavior is very erratic (for example if I have the developer toolbar open in split-window mode it does not happen).

NWE+SyntaxHighlight deliberately uses invisible text so that work is done in the VE surface, but displayed in the syntax highlighted surface. If you have invisible text that suggests the syntax highlighted surface isn't getting updated.

jeblad added a subscriber: jeblad.EditedJan 19 2018, 1:06 PM

I've seen the same thing, but could not reproduce. Same setup, but I was probably using Firefox as that is my usual browser unless I must check something in an alternate browser.

I had so much problem with SyntaxHighlight I turned it off. Also SH does not work with spell checkers and LanguageTools, which makes it very awkward.

This sounds a lot like T171616 to me! There it has nothing to do with syntax highlighting, though. In any case I can still reproduce my problems, although I fortunately did not have another crash.

Esanders renamed this task from Invisible text in new wikitext editor to Invisible text in new wikitext editor after large paste.Feb 25 2018, 5:54 PM
Esanders claimed this task.Feb 25 2018, 6:05 PM
Esanders edited projects, added VisualEditor (Current work); removed VisualEditor.

Change 414512 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/CodeMirror@master] Defer update of CM surface to avoid invisible text

https://gerrit.wikimedia.org/r/414512

Change 414512 merged by jenkins-bot:
[mediawiki/extensions/CodeMirror@master] Defer update of CM surface to avoid invisible text

https://gerrit.wikimedia.org/r/414512

Deskana closed this task as Resolved.Feb 26 2018, 4:09 PM
Deskana triaged this task as Normal priority.
Deskana set the point value for this task to 1.

Change 415273 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/CodeMirror@master] VE: Use different approach for transparent text issue

https://gerrit.wikimedia.org/r/415273

Change 415273 merged by jenkins-bot:
[mediawiki/extensions/CodeMirror@master] VE: Use different approach for transparent text issue

https://gerrit.wikimedia.org/r/415273