Page MenuHomePhabricator

[regression] Wikis using template-generated references no longer seeing ref list contents while editing
Closed, ResolvedPublic1 Story Points

Description

This is a side effect of T52769 which fixed the template-generated ref list being completely static in all cases.

Example: https://he.wikipedia.org/wiki/%D7%90%D7%93%D7%99_%D7%A7%D7%91%D7%98%D7%A0%D7%A8?veaction=edit&uselang=en

Details

Related Gerrit Patches:

Event Timeline

Esanders created this task.Feb 15 2018, 8:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 15 2018, 8:28 PM

And of course the reason for the template-generated references is T30980.

Working on the assumption that the root cause isn't going to be fixed anytime soon, I will first attempt to have reference list nodes use their Parsoid-provided references until the ref list has changed. This should result in a performance boost for other users too, as they won't need to re-render the ref list on load.

If this doesn't work I'll create a feature flag to disable T52769 so he.wiki can disable it.

Change 411101 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/Cite@master] Render reference list from originalDomElements until modified

https://gerrit.wikimedia.org/r/411101

In local tests, [[Barrack Obama]] spends about 1200ms rendering the root node (the whole doc) of which 700ms is spent on the ref list. After this patch the ref list takes 150ms.

By the way, I saw such generated references in other wikis too. Ruwiki, and even enwiki, something with CS1.

Deskana triaged this task as Medium priority.Feb 16 2018, 11:46 AM
Deskana set the point value for this task to 1.
Deskana added a project: Performance Issue.
Deskana added a subscriber: Deskana.

Nice. Excellent progress toward our quarterly goal of improving performance.

IKhitron renamed this task from Wikis using template-generated references (hewiki) no longer seeing ref list contents while editing to Wikis using template-generated references no longer seeing ref list contents while editing.Feb 16 2018, 7:39 PM
Elitre added a subscriber: Elitre.Feb 16 2018, 8:56 PM

I don't think the line that was added to Tech News about this change is accurate?

I don't think the line that was added to Tech News about this change is accurate?

I added it, because I found the problem in the first place. What's wrong?

This bug means that when you read https://en.wikipedia.org/wiki/Breast_cancer_awareness#Notes you see 93 entries, but when you edit that page, you see only one in that list, because 92 of them are generated by {{sfn}}, which the visual editor has never supported.

Previously, when you edited that page, you saw all 93 of them, but the list never changed, even if you blanked most of the article or added dozens of new refs.

Neither of these are particularly desirable situations, but other than "don't use {{sfn}}", I don't think we have very many viable options right now.

Neither of these are particularly desirable situations, but other than "don't use {{sfn}}", I don't think we have very many viable options right now.

Oh Boy. Hewiki uses only such references, because of direction problem. Can't fix just the part of previous edits, and drop the ability to see the new ones, created by such templates?

I don't think the line that was added to Tech News about this change is accurate?

I added it, because I found the problem in the first place. What's wrong?

This team is good and consistent in flagging items for Tech News consideration.
Next time, please add the relevant tag to the task, or suggest that is added, so that they are also aware and can help with wording, in case. TY!

I don't think the line that was added to Tech News about this change is accurate?

I added it, because I found the problem in the first place. What's wrong?

This team is good and consistent in flagging items for Tech News consideration.
Next time, please add the relevant tag to the task, or suggest that is added, so that they are also aware and can help with wording, in case. TY!

Of course, no problem. I did this just because Johan somehow believes I'm a part of Tech News team, with three more people. So, what was wrong?

I don't think the line that was added to Tech News about this change is accurate?

I added it, because I found the problem in the first place. What's wrong?

This team is good and consistent in flagging items for Tech News consideration.
Next time, please add the relevant tag to the task, or suggest that is added, so that they are also aware and can help with wording, in case. TY!

Of course, no problem. I did this just because Johan somehow believes I'm a part of Tech News team, with three more people. So, what was wrong?

If there's really something unclear in my message (your comment doesn't really relate much to what I wrote), you can move this conversation to my Meta talk page or wherever you see fit.

If there's really something unclear in my message (your comment doesn't really relate much to what I wrote), you can move this conversation to my Meta talk page or wherever you see fit.

Sure, done, thank you.

Change 411101 merged by jenkins-bot:
[mediawiki/extensions/Cite@master] Render reference list from originalDomElements until modified

https://gerrit.wikimedia.org/r/411101

Deskana closed this task as Resolved.Mar 8 2018, 10:32 AM

Hi, @Deskana, are you sure it's resolved? It's better than before, but still does not work well.

Maybe @Esanders? Thank you.

IKhitron reopened this task as Open.Mar 14 2018, 4:33 PM

Well, after a lot of time without any answer, I'll reopen the task. It still does not work, including in this week deployment. Hope will be fixed soon. Thank you.
@Deskana, @Esanders

Elitre renamed this task from Wikis using template-generated references no longer seeing ref list contents while editing to [regression] Wikis using template-generated references no longer seeing ref list contents while editing.May 4 2018, 1:54 PM
Deskana closed this task as Invalid.Jun 14 2018, 3:14 PM

I can't reproduce your problem. When editing the San Francisco Chronicle article on the Hebrew Wikipedia (https://he.wikipedia.org/wiki/סן_פרנסיסקו_כרוניקל) the references, which are generated by a template, are still visible; see the bottom right of the screenshot below.

Please do not reopen tasks simply saying that things "still do not work" without screenshots and reproduction steps.

IKhitron added a comment.EditedJun 14 2018, 3:22 PM

I can't reproduce your problem. When editing the San Francisco Chronicle article on the Hebrew Wikipedia (https://he.wikipedia.org/wiki/סן_פרנסיסקו_כרוניקל) the references, which are generated by a template, are still visible; see the bottom right of the screenshot below.
Please do not reopen tasks simply saying that things "still do not work" without screenshots and reproduction steps.

Hi, @Deskana. I am very surprised that you could not reproduce the problem - the feature simply does not work. The steps are just the usage of these refs. But very well, here you are again:

  1. Open some page, for example this one.
  2. Start VE editing.
  3. Add a ref, using, for example, cite-manual-basic form.
  4. Check the references section.

Could you reopen the task, please? Thank you.

Hi, @Deskana. The steps are just the usage of these refs. But very well, here you are again:

  1. Open some page, for example this one.
  2. Start VE editing.
  3. Add a ref, using, for example, cite-manual-basic form.
  4. Check the references section.

"Check the references section" for what exactly? What do you expect to see, and what do you actually see? Please provide screenshots.

Could you reopen the task, please? Thank you.

Provide clear reproduction steps, and then we'll see what the best course of action is.

"Check the references section" for what exactly? What do you expect to see, and what do you actually see? Please provide screenshots.

I expect to see refs, but I do not see them. I'll bring you the screenshots, @Deskana, in five minutes.

IKhitron added a comment.EditedJun 14 2018, 3:40 PM

Here you are, @Deskana:
View mode:


VE:

Hope you can see the difference now.

I think that Step 3, in which you click the Cite button, is the key point. While you're doing non-ref-related editing, or even editing existing ref-mimicking templates, everything's fine. The refs don't disappear until you try to insert a new one.

You are absolutely right.

Hello, everyone. Now, when I proved ten times that the problem still exist, and at least @Whatamidoing-WMF saw this, can somebody reopen the task? Please!!!

Elitre reopened this task as Stalled.Jun 20 2018, 4:21 PM

@Deskana , is the new information useful to move on? Thanks for your attention.

Thank you, Elitre. Hopefully it will be opened and not stalled soon enough.

Yeah, this is going to be investigated, probably in another task. Stay tuned.

Deskana closed this task as Resolved.Jun 29 2018, 1:37 PM

@IKhitron For the record, there were a few things you could've done here to have helped things move along. Saying "It's better than before, but still does not work well." is not a helpful bug report: you need to provide a specific description of the problem you're having, with detailed reproduction steps. When I asked for steps, you provided more detail, but you still didn't actually describe what the problem was, ending your steps with "Check the references section." with no screenshots. After I asked again, you finally provided the necessary information and screenshots. In the future, please provide specific details of what you did, what you expect to see, and what you actually see, preferably with screenshots; if you'd done this (like I just did in T198477), we could've skipped all this back-and-forth.

Anyway, I've put all the steps and such in T198477; the work will happen in that task, as it's better practice to track work in smaller actionable tasks rather than huge tasks that are repeatedly opened and closed.