Page MenuHomePhabricator

Regression: Wikidata descriptions are not showing on various wikis
Closed, ResolvedPublic

Description

Wikidata: most of these items have descriptions but they are no longer displayed in Special:Nearby.

Not seeing them in French (under article title) or in Watchlist.

Details

Related Gerrit Patches:
operations/mediawiki-config : masterRe-enable Wikidata descriptions
operations/mediawiki-config : masterRe-enable Wikidata descriptions

Event Timeline

aude created this task.Feb 24 2018, 6:10 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 24 2018, 6:10 PM
thiemowmde triaged this task as Low priority.Mar 2 2018, 4:31 PM
thiemowmde moved this task from incoming to needs discussion or investigation on the Wikidata board.

The API query that runs at the moment looks like this: https://www.wikidata.org/w/api.php?action=query&format=json&prop=coordinates|pageprops|pageterms|pageimages&colimit=max&generator=geosearch&ggsradius=10000&ggsnamespace=0&ggslimit=50&formatversion=2&ggscoord=50|13&ppprop=displaytitle&wbptterms=label&piprop=thumbnail&pithumbsize=150&pilimit=50&codistancefrompoint=50|13

Notice the parameter wbptterms=label does miss the …|description. The global configuration wgMFDisplayWikibaseDescriptions is supposed to enable this. See MobileFrontend/resources/mobile.search.util/extendSearchParams.js for the code responsible for this. As far as I can tell from what I see in the mediawiki-config repository it is currently enabled, but mw.config.get( 'wgMFDisplayWikibaseDescriptions' ) on wikidata.org shows it is not. Further investigation is needed to find this configuration bug.

Jdlrobson added a subscriber: Jdlrobson.

Note $wgMFEnableWikidataDescriptions will need to be enabled too for this to work.

Looks like said MFEnableWikidataDescriptions flag was introduced via https://gerrit.wikimedia.org/r/402126 (T182362) and https://gerrit.wikimedia.org/r/408357 (T182217) some weeks ago. But since this is disabled by default and the configuration not updated, the feature was effectively disabled. Was this intentional? Why is one feature hidden behind two almost identical configuration flags now?

Change 416741 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[operations/mediawiki-config@master] Re-enable Wikidata descriptions

https://gerrit.wikimedia.org/r/416741

Ack. Yes looks like this got broken :/

The purpose of MFEnableWikidataDescriptions was supposed to be a kill switch for the entire feature.
wgMFDisplayWikibaseDescriptions is supposed to allow further configuration.

It doesn't seem to be working correctly. I'm surprised it hasn't turned them off everywhere! MFSearchAPIParams is probably interfering with the behaviour...

Jdlrobson claimed this task.Mar 6 2018, 6:39 PM
Jdlrobson raised the priority of this task from Low to High.
Restricted Application added a project: Readers-Web-Backlog. · View Herald TranscriptMar 6 2018, 6:39 PM
Jdlrobson renamed this task from Special:Nearby no longer shows descriptions on Wikidata to Regression: Wikidata descriptions are not showing on various wikis.Mar 6 2018, 6:39 PM
Jdlrobson updated the task description. (Show Details)

Change 416741 merged by jenkins-bot:
[operations/mediawiki-config@master] Re-enable Wikidata descriptions

https://gerrit.wikimedia.org/r/416741

Change 416872 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[operations/mediawiki-config@master] Re-enable Wikidata descriptions

https://gerrit.wikimedia.org/r/416872

Change 416872 merged by jenkins-bot:
[operations/mediawiki-config@master] Re-enable Wikidata descriptions

https://gerrit.wikimedia.org/r/416872

Mentioned in SAL (#wikimedia-operations) [2018-03-07T00:32:46Z] <ladsgroup@tin> Synchronized wmf-config/InitialiseSettings.php: Re-enable Wikidata descriptions (T188182) (duration: 01m 16s)

This is fixed now, and I discovered a bug while working on this (T189066)

@ovasileva one of the side effects of this fix, is now that wikidata descriptions under the title cannot be enabled in the beta mode on English Wikipedia for example. I'm not sure if that matters, but if it does I'd suggest we cleanup the existing configuration options to support that (please raise a ticket and I can fill out the details).

@Jdlrobson - I think it's okay to disable them on english (even from beta). Would this also be the case with Russian (the only other wiki that doesn't have them enabled)? Also, to confirm, they will also not display on the list of beta features as well, right?

Jdlrobson reassigned this task from Jdlrobson to ovasileva.Mar 7 2018, 6:06 PM

Yup. Wikidata descriptions show up in search results, nearby and watchlist on Russian and English but not under the title. You cannot enable this via beta. On all other projects they show up in all places. Does this sound like the correct behaviour?

ovasileva closed this task as Resolved.Mar 7 2018, 6:46 PM

That's perfect. Thanks @Jdlrobson!