Page MenuHomePhabricator

Watchlist should not show wikidata descriptions, it should show last modified timestamp
Closed, ResolvedPublic3 Story Points

Description

Make sure you have over 50 items on your watchlist and visit https://en.m.wikipedia.org/wiki/Special:EditWatchlist

Scroll down the page so that the infinite scroller is loaded.

Expected:

  • Last modified show up on all items loaded via JavaScript
  • No wikidata descriptions show

Actual:

  • Only wikidata descriptions for articles loaded via JavaScript show up (Paloma onwards in screenshot)

Testing criteria

Abhay and Rani Bang2
Abhay and Rani Bang3
Abhay and Rani Bang4
Abhay and Rani Bang5
Agra
Agra existing
Albert Einstein
Albert Einstein2
Albert Einstein3
Albert Einstein4
Albert Einstein5
Asas2
Asas3
Asas4
Asas5
Baby chicks
Barack Obama
Bernie Sanders
Cats in ancient Egypt
Cite columns
Corey references
Deletion page
Dinosaurs
Display title test
Display title test2
Egyptian weasel 10
Egyptian weasel 2
Egyptian weasel 3
Egyptian weasel 4
Egyptian weasel 5
Egyptian weasel 6
Egyptian weasel 7
Egyptian weasel 8
Egyptian weasel 9
Example ref cite reference link
Flag images
Flow QA2
Flow QA3
Flow QA4
Flow QA5
Foo
Foo bar2
Foo bar3
Foo bar4
Foo bar5
Foooooo2
Foooooo3
Foooooo4
Foooooo5
Francisco Goya
Gallery2
Gallery3
Gallery4
Gallery5
Gallery media view test
Ginger monkeys
Headings2
Headings3
Headings4
Headings5
Headings in paragraphs
Hello Piotr I've been expecting you
Hello Piotr I've not been expecting you
Henry
Hovertest
IPod
I don't exist
Infobox inception
Irish Drinking Songs for Cat Lovers2
Irish Drinking Songs for Cat Lovers3
Irish Drinking Songs for Cat Lovers4
Irish Drinking Songs for Cat Lovers5
Japanese Text
Jon's nasty VE test page2
Jon's nasty VE test page3
Jon's nasty VE test page4
Jon's nasty VE test page5
Jon example
Leonardo da Vinci
Link to T188164
List of dog fighting breeds
MMV lowercase extension
Main Page2
Main Page3
Main Page4
Main Page5
Marie Curie
Meaning/test
Menopause
Michael Jackson
Mobile view headings test2
Mobile view headings test3
Mobile view headings test4
Mobile view headings test5
Nested references
New York2
New York3
New York4
New York5
No print test
Noam Chomsky2
Noam Chomsky3
Noam Chomsky4
Noam Chomsky5
Nonexistent page abc2
Nonexistent page abc3
Nonexistent page abc4
Nonexistent page abc5
Nonexistent page ijewrcmhvg347733
Nonexistent page ijewrcmhvg447744
Nonexistent page ijewrcmhvg547752
Nonexistent page ijewrcmhvg547755
North American Martyrs2
North American Martyrs3
North American Martyrs4
North American Martyrs5
Page preview of using the translate tag
Panorama
Redirect
Redirect test
Related test
San Franciszo2
San Franciszo3
San Franciszo4
San Franciszo5
Segunda Guerra Mundial
Selenium Watchlist
Selenium language test page without languages
Selenium mobile watch test
Selenium mobile watch test2
Selenium mobile watch test3
Selenium mobile watch test4
Selenium mobile watch test5
Selenium page issues test page/Test
Sighthound
Sled dog
Small image link
Small image link fun
Small image link fun time
Star Trek test
Star Wars test
Star Wars vs Star Trek
T146394
T188164
TestRef
Test EasyImage Template T157162
Test anxiety
Test br tags in extracts
Test graph hover
Test images2
Test images3
Test images4
Test images5
Test ios scrolling
Test lead paragraph
Test lists
Test popups EasyImage Template T157162
Test previews
Test previews no lead
Testlangas
Text
The Montgomery (San Francisco)
The West Wing
Timeline of the presidency of Barack Obama (2010)
Timeline test
Trending article
Unused styles test page
Using the translate tag
Very long lines
VisualEditor stress test2
VisualEditor stress test3
VisualEditor stress test4
VisualEditor stress test5
WikidataPageBanner example 1
WikidataPageBanner example 2
WikidataPageBanner example 3
WikidataPageBanner example 4
Wikidata example 1
アル=マグタス
User:Jdlrobson/Books/Bigbook
User:Jdlrobson/Books/Book without subtitle
User:Jdlrobson/Books/The big book
User:Jdlrobson/Books/The enormous book
User:Jdlrobson/GatherCollections.json
User:Jdlrobson/GatherCollections/1.json
User:Jdlrobson/GatherCollections/2.json
User:Jdlrobson/GatherCollections/3.json
User:Jdlrobson/GatherCollections/4.json
User:Jdlrobson/mainpagetest
User:Jdlrobson/minerva.css
User:Jdlrobson/minerva.js
User:Jdlrobson/pi
User:Jdlrobson/pi2
User:Jdlrobson/sandbox
User:Jdlrobson/sandbox2
User:Jdlrobson/tmp1
File:CITES 40th annverisary logo.jpg
File:Michael Jackson - Thriller.png
File:Star Trek movie logo 2009.jpg
MediaWiki:Analytics-Survey-Question
MediaWiki:Gather-lists-hide-protocol
MediaWiki:Mobile-frontend-edit-login-action
MediaWiki:Mobile-frontend-generic-login-new
MediaWiki:Mobile-frontend-watchlist-purpose
Template:EasyImage
Template:LoginWarningMessage
Template:Nomobile
Template:Refbegin/TemplateData
Module:Foo
Topic:Tik9w8ms5ld5x3bj

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 7 2018, 12:37 AM

(Is this about MediaWiki-Watchlist and Wikidata project tags?)

ovasileva triaged this task as Normal priority.Mar 7 2018, 5:28 PM

Jon says the Vagrant set up for this requires a little doing.

Jdlrobson set the point value for this task to 3.Mar 13 2018, 4:08 PM

Jan, Stephen, Piotr and I estimated this. There's a little uncertainty in what's happening here and testing Wikidata descriptions locally is difficulty but it used to happen, so it should be a simple case of finding how it used to happen and restoring that code.

pmiazga claimed this task.Mar 20 2018, 4:59 PM
pmiazga moved this task from To Do to Needs Code Review on the Readers-Web-Kanbanana-Board-Old board.
pmiazga moved this task from Needs Code Review to Doing on the Readers-Web-Kanbanana-Board-Old board.

@Nirzar Special:Watchlist is a little broken.
The first 50 pages are rendered with a timestamp and as you scroll other pages are loaded with "wikidata description" and no timestamp. What is the expected behaviour here? Might be easy to chat in person. Am in office today if you need to do that.

@Jdlrobson should show the metadata and not the wikidata description. looks like a bug to me. the intended behaviour is to show the timestamp and user

Jdlrobson renamed this task from Fix wikidata descriptions in Watchlist to Watchlist should not show wikidata descriptions, it should show last modified timestamp.Mar 21 2018, 9:42 PM
Jdlrobson updated the task description. (Show Details)

even better! that makes my life much easier. thanks @Nirzar. Tomorrow I'll push fix for JS to show timestamps instead of wikidata descriptions

Change 422344 had a related patch set uploaded (by Pmiazga; owner: Pmiazga):
[mediawiki/extensions/MobileFrontend@master] Watchlist items should show last modified time

https://gerrit.wikimedia.org/r/422344

Change 422344 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Watchlist items should show last modified time

https://gerrit.wikimedia.org/r/422344

Change 422440 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Watchlist should show thumbnail placeholders when not present

https://gerrit.wikimedia.org/r/422440

Jdlrobson updated the task description. (Show Details)
Jdlrobson added a subscriber: pmiazga.

Over to you. I've updated testing criteria to help you test this. Test on beta cluster and wait about 30 minutes from now to be sure the latest patch has been merged.

Change 422440 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Watchlist should show thumbnail placeholders when not present

https://gerrit.wikimedia.org/r/422440

Seems to be working as expected. I figure it's worth an additional QA pass, passing it over to you @ABorbaWMF

alexhollender added a subscriber: alexhollender.
Jdlrobson added a comment.EditedApr 4 2018, 7:05 PM

@ABorbaWMF pointed out 2 (unrelated to this task) bugs - T191456 and T191454

Infinite scroll is working for across a few browsers.

ovasileva closed this task as Resolved.Apr 6 2018, 9:24 AM
ovasileva added a subscriber: ovasileva.

Looks good. Last edited is appearing