Page MenuHomePhabricator

Reduce vertical space between Watchlist filtering tools and first line of results
Closed, ResolvedPublic

Description

On the Watchlist the new filters introduce a larger separation between the filters and results (highlighted below) compared to the separation in Recent Changes.

This issue seems analogous to previous issues on the Recent Changes page such as T172140.

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMay 29 2018, 6:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
jmatazzoni renamed this task from Reduce vertical space for new filters on the watchlist to Reduce vertical space between Watchlist filtering tools and first line of results.May 29 2018, 8:13 PM
jmatazzoni added a subscriber: jmatazzoni.

Yes, when I look at en.wiki, RC page leaves 82px between the bottom of the Live Update button and the bottom of the first line of results. On Watchlist, it is 97 px—15 px more. See the screenshot below, which shows my pixel gauge on RC page and demonstrates the difference.

We should clean this up if we can. Moving to This Quarter

Change 440024 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] RCFilters: Reduce min-height for Watchlist

https://gerrit.wikimedia.org/r/440024

Change 440024 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Reduce min-height for Watchlist

https://gerrit.wikimedia.org/r/440024

Change 440482 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@wmf/1.32.0-wmf.8] RCFilters: Reduce min-height for Watchlist

https://gerrit.wikimedia.org/r/440482

Change 440482 merged by jenkins-bot:
[mediawiki/core@wmf/1.32.0-wmf.8] RCFilters: Reduce min-height for Watchlist

https://gerrit.wikimedia.org/r/440482

Mentioned in SAL (#wikimedia-operations) [2018-06-14T23:24:29Z] <jforrester@deploy1001> Synchronized php-1.32.0-wmf.8/resources/src/mediawiki.rcfilters/styles/mw.rcfilters.less: T195903 SWAT for Roan (duration: 00m 59s)

Checked after deployment onwmf.8 mediawiki (and enwiki). There is a difference now between positioning of elements on Watchlist and RC page:

@Pginer-WMF - please take a look if it's alright.

@Pginer-WMF - please take a look if it's alright.

The separation between the filter area and the elements below was intended to be 24px. I marked the intended distance on top of your previous screenshots.

Recent ChangesWatchlist

The distance is a good-enough approximation, but it would be even better if it could be reduced 8px for Recent Changes.

Vvjjkkii renamed this task from Reduce vertical space between Watchlist filtering tools and first line of results to k1baaaaaaa.Jul 1 2018, 1:07 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Catrope as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from k1baaaaaaa to Reduce vertical space between Watchlist filtering tools and first line of results.Jul 2 2018, 3:20 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Catrope.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.