Page MenuHomePhabricator

Changes shifted down on Special:RecentChanges and Special:Watchlist
Closed, ResolvedPublic

Description

When viewing recent changes or the watchlist on Wikipedia, all the changes appear shifted below the bullets instead of to the right in the same row. This bug has been reported at https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)#crazy_watchlist.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 29 2018, 12:21 AM

Couldn't replicate this on enwiki under any skin with Firefox or Chrome

JJMC89 added a subscriber: JJMC89.Jun 29 2018, 3:07 AM

I noticed this on Wikitech earlier today when my watchlist updated (live updates on). Refreshing the page fixed the issue. I haven't encountered it anywhere else yet.

I think this is because the highlight container divs (added by T198139: Move construction of highlight containers to server) have no CSS rules hiding them in the old UI (non-RCFilters mode). In Chrome, the div containing these divs doesn't break the line even though it's display: block, and I don't understand why. I could easily understand Edge behaving differently (and all the reports on VPT are in Edge).

Also note they're set to display: inline-block by the RCFilters CSS, but that doesn't load with RCFilters disabled of course.

Change 443019 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] RCFilters: Hide highlight containers when RCFilters is disabled

https://gerrit.wikimedia.org/r/443019

Change 443019 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] RCFilters: Hide highlight containers when RCFilters is disabled
https://gerrit.wikimedia.org/r/443019

This patch is speculative because I couldn't test it in Edge myself, but I did test that it's harmless in Firefox and Chrome.

I think this is because the highlight container divs (added by T198139: Move construction of highlight containers to server) have no CSS rules hiding them in the old UI (non-RCFilters mode). In Chrome, the div containing these divs doesn't break the line even though it's display: block, and I don't understand why. I could easily understand Edge behaving differently (and all the reports on VPT are in Edge).

I noticed this on Wikitech earlier today when my watchlist updated (live updates on). Refreshing the page fixed the issue. I haven't encountered it anywhere else yet.

I was using Chrome (67.0.3396.87) with improved RecentChanges enabled.

Please, folks, always include a screenshot. I couldn't reproduce this at first because I had enhanced RC enabled ("Group changes by page in recent changes and watchlist") and apparently the issues does not affect that mode. It would be obvious that I have to disable that if there was a screenshot.

So, here's a screenshot, for future reference:

Change 443019 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Hide highlight containers when RCFilters is disabled

https://gerrit.wikimedia.org/r/443019

Checked in betalabs Edge17/Windows10 (checked IE11 too) - the fix seems to be fine:

matmarex closed this task as Resolved.Jul 2 2018, 4:16 PM
matmarex assigned this task to Catrope.
matmarex removed a project: Patch-For-Review.

Change 443461 had a related patch set uploaded (by Bartosz Dziewoński; owner: Catrope):
[mediawiki/core@wmf/1.32.0-wmf.10] RCFilters: Hide highlight containers when RCFilters is disabled

https://gerrit.wikimedia.org/r/443461

Change 443461 merged by jenkins-bot:
[mediawiki/core@wmf/1.32.0-wmf.10] RCFilters: Hide highlight containers when RCFilters is disabled

https://gerrit.wikimedia.org/r/443461

Mentioned in SAL (#wikimedia-operations) [2018-07-02T18:47:34Z] <niharika29@deploy1001> Synchronized php-1.32.0-wmf.10/resources/src/: RCFilters: Hide highlight containers when RCFilters is disabled T198440 (duration: 00m 51s)

The fix is now deployed to Wikimedia wikis.