Page MenuHomePhabricator

Markers not appearing
Closed, ResolvedPublic

Description

  1. Go to https://en.wikipedia.org/
  2. Make sure you are logged in.
  3. Click on "Preferences" in the top right.
  4. Click on the "Beta features" tab, the second from the right.
  5. Enable "New filters for edit review"
  6. Click "Save" at the bottom of the page.
  7. Go to your Watchlist by clicking it on the top right, near "Preferences", or by going to https://en.wikipedia.org/wiki/Special:Watchlist
  8. Change the Active filters so there are only "Page edits", "Page creations", and "Logged actions" left.
  9. Click the bookmark icon on the right side to save the Active filters.
  10. Reload the page, and then select the name you gave those Saved filters from the drop-down menu on the right side.
  11. The blue markers to the left of each diff entry in my Watchlist (which are solid if the change has not yet been viewed and empty if it has) aren't appearing. When the page is loading, they do appear, but only for about half a second, and then once the page has fully loaded, they disappear.

Without New filters:

With New filters beta feature enabled:

Event Timeline

Daybeers created this task.Jun 29 2018, 2:46 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 29 2018, 2:46 AM
Daybeers updated the task description. (Show Details)Jun 29 2018, 4:03 AM
Aklapper changed the task status from Open to Stalled.Jun 29 2018, 8:36 AM

Hi @Daybeers, thanks for taking the time to report this and welcome to Phabricator!
Unfortunately this report lacks some information. Please follow https://www.mediawiki.org/wiki/How_to_report_a_bug and add a more complete description to this report: Either the URL of the website where this problem happens, or the MediaWiki version of your installation.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster.

Please also follow https://www.mediawiki.org/wiki/Help:Locating_broken_scripts to see if you get output in the developer tools after disabling gadgets etc.

What I get on https://en.wikipedia.org/wiki/Special:Watchlist in Chromium 67 looks like this (and not blue but green):

Daybeers updated the task description. (Show Details)Jun 29 2018, 12:53 PM
Daybeers updated the task description. (Show Details)Jun 29 2018, 12:59 PM

@Aklapper that's because I'm using the improved Watchlist interface, which you can get to by following the steps above.

Daybeers updated the task description. (Show Details)Jun 29 2018, 1:08 PM

@Daybeers thank you for filing this report and for the detailed steps to reproduce. This is likely a side effect from the work we we deployed for T197168. I'll look into this today.

kostajh claimed this task.Jun 29 2018, 1:22 PM
kostajh reassigned this task from kostajh to Mooeypoo.Jun 29 2018, 3:54 PM
kostajh added a subscriber: Mooeypoo.

@Mooeypoo assigning the task to you as you're working on the patch.

matmarex changed the task status from Stalled to Open.Jun 29 2018, 3:59 PM
matmarex updated the task description. (Show Details)
matmarex added subscribers: Etonkovidova, Catrope.

@Mooeypoo assigning the task to you as you're working on the patch.

Yup, I'm working on it now. Found the culprit, cleaning it up and testing, will have the patch up soon.

Change 443110 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/core@master] RCFilters: Fix highlight container selector in Watchlist override

https://gerrit.wikimedia.org/r/443110

Change 443110 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Fix highlight container selector in Watchlist overrides

https://gerrit.wikimedia.org/r/443110

Change 443411 had a related patch set uploaded (by Sbisson; owner: Mooeypoo):
[mediawiki/core@wmf/1.32.0-wmf.10] RCFilters: Fix highlight container selector in Watchlist overrides

https://gerrit.wikimedia.org/r/443411

Change 443411 merged by jenkins-bot:
[mediawiki/core@wmf/1.32.0-wmf.10] RCFilters: Fix highlight container selector in Watchlist overrides

https://gerrit.wikimedia.org/r/443411

Mentioned in SAL (#wikimedia-operations) [2018-07-02T13:29:41Z] <hashar@deploy1001> Synchronized php-1.32.0-wmf.10/resources/src/mediawiki.rcfilters/styles/: RCFilters: Fix highlight container selector in Watchlist overrides - T198445 (duration: 00m 51s)

SBisson added a subscriber: SBisson.Jul 2 2018, 2:38 PM

The fix was deployed to production this morning.

Etonkovidova added a comment.EditedJul 2 2018, 4:58 PM

Checked in wmf.10 along with two more fixes - T198513: Watchlist bullets missing colors and T198440: Changes shifted down on Special:RecentChanges and Special:Watchlist - the markers are displayed on Watchlist and they are solid (or highlighted) according to the selected options and of seen/unseen status.

Etonkovidova closed this task as Resolved.Jul 2 2018, 4:58 PM