Page MenuHomePhabricator

Creations by autopatrolled users not marked as autopatrolled in Special:NewPagesFeed
Closed, ResolvedPublic

Description

In Special:NewPagesFeed, creations by autopatrolled users are not marked as autopatrolled. For example, the article Casper Motor Company-Natrona Motor Company on Wikipedia says that it is unreviewed despite being created by an autopatrolled user. The creations still appear without an exclamation point in recent changes, and without yellow highlighting in Special:NewPages.

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJun 29 2018, 3:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I'll have a look later. This sounds rather strange. May be a caching/timing issue.

daniel claimed this task.Jun 29 2018, 5:49 PM

Change 443127 had a related patch set uploaded (by MusikAnimal; owner: MusikAnimal):
[mediawiki/extensions/PageTriage@master] Fix setting of reviewed state based on autopatrol permission

https://gerrit.wikimedia.org/r/443127

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJun 29 2018, 6:37 PM

We realized that this problem was accidentally caused by Community Tech's work on this project to expand and improve the New Pages Feed. I'm sorry about this -- it's definitely frustrating that extra work is being caused for New Page Reviewers.

The team is working on the fix now, tests to go along with the fix, and doing code review. Because of the time it will take to do this right, we'll likely deploy a fix on Monday morning.

I'll give another update in a few hours.

Change 443127 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Fix setting of reviewed state based on autopatrol permission

https://gerrit.wikimedia.org/r/443127

The fix has been written, as well as additional tests. It has been code reviewed, and now needs to be tested in a testing wiki. We expect to deploy on Monday morning.

The reviewing community brought up the question of whether the fix will mark the pages that should have been autopatrolled as such, and remove them from the feed. @MusikAnimal wrote that he's thinking about a script to do this.

Change 443446 had a related patch set uploaded (by Niharika29; owner: MusikAnimal):
[mediawiki/extensions/PageTriage@wmf/1.32.0-wmf.10] Fix setting of reviewed state based on autopatrol permission

https://gerrit.wikimedia.org/r/443446

Scheduled for SWAT today at 1100 PST.

Change 443446 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@wmf/1.32.0-wmf.10] Fix setting of reviewed state based on autopatrol permission

https://gerrit.wikimedia.org/r/443446

Mentioned in SAL (#wikimedia-operations) [2018-07-02T18:16:04Z] <niharika29@deploy1001> Synchronized php-1.32.0-wmf.10/extensions/PageTriage/: Fix setting of reviewed state based on autopatrol permission T198497 (duration: 00m 52s)

MusikAnimal closed this task as Resolved.Jul 2 2018, 6:54 PM
MusikAnimal moved this task from In Development to Q1 2018-19 on the Community-Tech-Sprint board.

Deployed! Existing pages created by autopatrolled users are also now all marked as reviewed https://en.wikipedia.org/w/index.php?title=Special%3ALog&type=pagetriage-curation&user=MusikAnimal&offset=20180702184000

Thanks @MusikAnimal. For anyone following along, we now consider this bug fixed and all pages to have the correct review status. Please let us know if you see any problems.

Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 11 2018, 2:17 PM