Rollback from autopatrolled user was marked as not patrolled
Closed, ResolvedPublic

Description

Hello,

I have rollbacked an edit that was made by anonymous contributor on cs.wikipedia (I have autopatrol rights there, in fact I have sysop bit there) and the rollbacking edit was marked as non-patrolled and had to be patrolled manually.

The rollbacking edit: https://cs.wikipedia.org/w/index.php?title=Borsk%C3%BD_Mikul%C3%A1%C5%A1&diff=16205272&oldid=16205271
Edit that was rollbacked: https://cs.wikipedia.org/w/index.php?title=Borsk%C3%BD_Mikul%C3%A1%C5%A1&diff=16205271&oldid=16202566

Patrolling protocol: https://cs.wikipedia.org/w/index.php?title=Speci%C3%A1ln%C3%AD:Protokolovac%C3%AD_z%C3%A1znamy&page=Borsk%C3%BD+Mikul%C3%A1%C5%A1&hide_patrol_log=0

There seems to be a regression bug in the patrolling system.

Best,

Martin Urbanec

There are a very large number of changes, so older changes are hidden. Show Older Changes

Change 443031 had a related patch set uploaded (by Matěj Suchánek; owner: Matěj Suchánek):
[mediawiki/core@master] Mark rollbacking revision as patrolled

https://gerrit.wikimedia.org/r/443031

Change 443063 had a related patch set uploaded (by Daniel Kinzler; owner: Daniel Kinzler):
[mediawiki/core@master] Regression test for autopatrolling rollbacks

https://gerrit.wikimedia.org/r/443063

Assigning to Matěj as he has created the fixing patch. Thank you Matěj!

Urbanecm moved this task from Backlog to Watching on the User-Urbanecm board.Fri, Jun 29, 10:21 AM

Change 443031 merged by jenkins-bot:
[mediawiki/core@master] Mark rollbacking revision as patrolled

https://gerrit.wikimedia.org/r/443031

Change 443063 merged by jenkins-bot:
[mediawiki/core@master] Regression test for autopatrolling rollbacks

https://gerrit.wikimedia.org/r/443063

Lofhi reopened this task as Open.
Lofhi added subscribers: Huji, Saeidpourbabak.
Lofhi added a subscriber: Lofhi.

Mea culpa.

matmarex added a subscriber: greg.Fri, Jun 29, 8:17 PM

The bug has been fixed, but the fix still needs to be deployed to Wikimedia wikis. Usually deployments are not done on Fridays (so that we will not have to call up people on the weekend if anything new breaks). Judging by the number of reports, it definitely seems like a noticeable problem, is this causing major issues for users/administrators, or could you folks live with it until Monday? @greg It might be worth making an exception.

PlyrStar93 added a comment.EditedFri, Jun 29, 8:22 PM

The bug has been fixed, but the fix still needs to be deployed to Wikimedia wikis. Usually deployments are not done on Fridays (so that we will not have to call up people on the weekend if anything new breaks). Judging by the number of reports, it definitely seems like a noticeable problem, is this causing major issues for users/administrators, or could you folks live with it until Monday? @greg It might be worth making an exception.

I'm totally fine waiting for the deployment. Just curious if the double tag (both the Rollback + Undo tags applied to a rollback) issue is also fixed with this one.

Just curious if the double tag (both the Rollback + Undo tags applied to a rollback) issue is also fixed with this one.

That is a separate issue, see T190374: Rollback gets both "mw-rollback" and "mw-undo" tags. It seems there isn't a fix for it yet, but folks figured out the cause, so the fix should be easy to do.

Change 443195 had a related patch set uploaded (by Thcipriani; owner: Matěj Suchánek):
[mediawiki/core@wmf/1.32.0-wmf.10] Mark rollbacking revision as patrolled

https://gerrit.wikimedia.org/r/443195

The bug has been fixed, but the fix still needs to be deployed to Wikimedia wikis. Usually deployments are not done on Fridays (so that we will not have to call up people on the weekend if anything new breaks). Judging by the number of reports, it definitely seems like a noticeable problem, is this causing major issues for users/administrators, or could you folks live with it until Monday? @greg It might be worth making an exception.

I have created a quick bot marking all rollbacks as patrolled, so they will disappear automatically after some time from recentchanges. But having this fixed today and before Monday will be VERY GOOD!

Change 443195 merged by jenkins-bot:
[mediawiki/core@wmf/1.32.0-wmf.10] Mark rollbacking revision as patrolled

https://gerrit.wikimedia.org/r/443195

Made an attempt to deploy the fix that was merged in master today; however, when testing the change on mwdebug1002, @matmarex hit an exception. I pasted the stacktrace for the exception into P7318.

Given that I didn't know how to proceed, I decided to revert for the time being. This exception is very possibly unrelated, but I didn't feel comfortable rolling forward with so few people around should this breakage be related to the patch.

(For reference, I was making this change when testing: https://test.wikipedia.org/w/index.php?title=T198449&diff=prev&oldid=357685. The rollback actually went through, and it was correctly autopatrolled, but I got an exception instead of a success page.)

Ltrlg added a subscriber: Ltrlg.Sat, Jun 30, 10:07 AM

Maybe this should be in the tech news.

matej_suchanek removed matej_suchanek as the assignee of this task.Sat, Jun 30, 12:25 PM

Unassigning myself, I'm not sure what should be done next, looks like a deadlock to me.

He7d3r added a subscriber: He7d3r.Sat, Jun 30, 5:02 PM
revi added a subscriber: revi.Sun, Jul 1, 3:11 PM
jeblad added a subscriber: jeblad.Sun, Jul 1, 6:11 PM

Reported at nowiki too, I'll post a note that the bug is tracked.

Nsaa added a subscriber: Nsaa.Sun, Jul 1, 7:49 PM
Jeff_G added a subscriber: Jeff_G.Sun, Jul 1, 11:41 PM

This has been happening on Commons, too. This edit by Bsadowski 1, who has Local user-groups Image reviewers, File movers, Rollbackers and Autoconfirmed users and Global user-group Stewards, appears unpatrolled in my watchlist. As a member of Image reviewers, that user should inherit the Autopatrolled group rights. https://commons.wikimedia.org/wiki/Special:ListGroupRights confirms that five groups have the right "Have one's own edits automatically marked as patrolled (autopatrol)": Image reviewers, Autopatrollers; Bots; Patrollers; and Administrators. See also https://commons.wikimedia.org/wiki/COM:VP#Unpatrolled rollbacks.

Asav added a subscriber: Asav.Mon, Jul 2, 12:58 AM

Fiox is mon master, will go out with the regular train deployment.

The exception that @thcipriani saw seems unrelated. At least I can't think of a way for @matej_suchanek to cause this issue.

srwiki have this problem same

Please avoid adding further "my wiki too!" comments. Thank you everybody!

Change 443471 had a related patch set uploaded (by Bartosz Dziewoński; owner: Matěj Suchánek):
[mediawiki/core@wmf/1.32.0-wmf.10] Mark rollbacking revision as patrolled

https://gerrit.wikimedia.org/r/443471

Change 443471 merged by jenkins-bot:
[mediawiki/core@wmf/1.32.0-wmf.10] Mark rollbacking revision as patrolled

https://gerrit.wikimedia.org/r/443471

Mentioned in SAL (#wikimedia-operations) [2018-07-02T19:00:36Z] <niharika29@deploy1001> Synchronized php-1.32.0-wmf.10/includes/page/WikiPage.php: Mark rollbacking revision as patrolled T198449; WikiPage: Do not set undid revision ID for rollbacks T190374 (duration: 00m 50s)

matmarex closed this task as Resolved.Mon, Jul 2, 7:37 PM
matmarex assigned this task to matej_suchanek.
matmarex removed a project: Patch-For-Review.

The fix is now deployed to Wikimedia wikis.

Liuxinyu970226 awarded a token.