Page MenuHomePhabricator

Editing welcome dialog pops up on Wikibase entity undo page on the very first edit a user tries to make
Closed, ResolvedPublic

Description

The VisualEditor welcome screen pops up on Wikibase entity undo pages, where there is no VisualEditor. This is potentially confusing for users, and also recently lead to some failing browser tests for extensions that integrate both with Wikibase and VisualEditor (see T201901).

Screenshot taken on wikidata.org:

FWIW this also happens when manually appending action=edit to any entity page, although that is less problematic.

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterWelcomeDialog: Check at least one editor is available

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 14 2018, 2:16 PM
Deskana triaged this task as Medium priority.Aug 14 2018, 6:41 PM
Deskana moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Deskana added a subscriber: Deskana.

I can't reproduce this issue whilst logged in to my staff account, but I can when I'm logged out or logged in to a new account.

The good news is that it doesn't otherwise interfere with anything, it's just that it's shown at an inappropriate time.

If T201901 is an UBN for the team working on ContentTranslation and this ticket is the correct fix for the issue then this should probably also be UBN? or at least high?

Greta_Doci_WMDE raised the priority of this task from Medium to High.Aug 16 2018, 1:36 PM
Jakob_WMDE lowered the priority of this task from High to Medium.Aug 16 2018, 1:52 PM
Deskana moved this task from TR0: Interrupt to Up next on the VisualEditor board.Aug 16 2018, 2:46 PM
Deskana moved this task from Up next to Current work on the VisualEditor board.Aug 22 2018, 5:26 PM
Deskana edited projects, added VisualEditor (Current work); removed VisualEditor.

This is the "Welcome to editing" dialog - it's not a VE welcome dialog. It was a product decision to show this in both VE and wikitext editors. It may be possible to disable it on a per site basis. @Jdforrester-WMF may remember more?

Jdforrester-WMF renamed this task from VisualEditor welcome dialog pops up on Wikibase entity undo page to Editing welcome dialog pops up on Wikibase entity undo page on the very first edit a user tries to make.Aug 22 2018, 7:06 PM

Ed is correct, this is a general editing dialog. I've retitled the task to make it clearer what the "bug" here is. I'd suggest that this task is Invalid; it's working as designed. Dan's the product manager now, and it's his call.

I can see why this happens—it's an undo action which would ordinarily have a text box in it, it's just that no text box is shown on Wikidata since the data is structured. It's a little strange to show this to someone when the first thing they're "editing" doesn't even have a text box in it. It would be better to wait until the user is actually making an edit in the traditional sense, i.e. the page actually has a text box on it. What's the relative difficulty of implementing that? If it's nontrivial, it's probably not worth the effort.

I think that might be fairly simple: we could add a check to make sure the page at least has #wpTextbox1 textarea on it, assuming it isn't just hidden with CSS?

Esanders added a comment.EditedAug 23 2018, 1:14 PM

Just had a poke around - it's not completely trivial, but not impossible.

Esanders claimed this task.Aug 23 2018, 1:18 PM

Change 454816 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] WelcomeDialog: Check at least one editor is available

https://gerrit.wikimedia.org/r/454816

It's a little strange to show this to someone when the first thing they're "editing" doesn't even have a text box in it.

Is it? They're still causing content to change. They'll still get a "thank you for making your first edit" notification. They'll still get an edit-triggered welcome bot post on their talk page. Etc.

Change 454816 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] WelcomeDialog: Check at least one editor is available

https://gerrit.wikimedia.org/r/454816

It's a little strange to show this to someone when the first thing they're "editing" doesn't even have a text box in it.

Is it? They're still causing content to change. They'll still get a "thank you for making your first edit" notification. They'll still get an edit-triggered welcome bot post on their talk page. Etc.

Presently, most users aren't being shown this dialogue upon making their first edit anyway, because most ways of changing structured data on Wikidata don't trigger the dialogue at all; using "Undo" on an edit is one of the few ways that does. So, the status quo is "show the welcome dialogue the first time the user uses the VisualEditor, a wikitext editor, or "Undo" to revert someone's change to structured data items", which is quite strange. This way, it'll be "show the welcome dialogue the first time the user edits with the VisualEditor, a wikitext editor" which is at least a bit less strange, though not really not strange at all. ;-)

JTannerWMF moved this task from Inbox to High Priority on the Editing QA board.Nov 8 2018, 6:48 PM
Ryasmeen edited projects, added Verified; removed Editing QA.Nov 9 2018, 6:42 PM
marcella closed this task as Resolved.Nov 19 2018, 7:38 PM