Page MenuHomePhabricator

Enable the {{SHORTDESC}} magic word on the Malayalam Wikipedia
Closed, InvalidPublic

Description

Enable the {{SHORTDESC}} magic word on the Malayalam Wikipedia like was done for T184000: Magic word on English WP to override display of Wikidata short description

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 12 2018, 5:13 PM

Please explain what the {{SHORTDESC}} magic word is (links), and please provide community consensus.
See https://meta.wikimedia.org/wiki/Requesting_wiki_configuration_changes - thanks!

https://phabricator.wikimedia.org/T184000 Please do visit that link. I am needing that specific feature to be enabled in Malayalam wikipedia also.

Aklapper changed the task status from Open to Stalled.Sep 12 2018, 6:16 PM
Adithyak1997 added a comment.EditedSep 12 2018, 6:23 PM

The actual problem is: almost 70 to 80% of the templates of english are converted into malayalam as it is because only one or two are actually knowing how to create a template. When the template SHORTDESC was imported in the same way, it showed an error to create a template named SHORTDESC: which was not found in english wikipedia. When I consulted in English wikipedia, the result was: https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)#Template_doubt this.

JJMC89 renamed this task from Enable {{SHORTDESC}} Magic Word to Enable the {{SHORTDESC}} magic word on the Malayalam Wikipedia.Sep 13 2018, 1:20 AM
JJMC89 updated the task description. (Show Details)

I would like this magic word to not spread even more. It's bad enough on enwp for Wikidata already. Please!

DannyH added a subscriber: DannyH.Sep 14 2018, 5:46 PM

We're not going to enable this magic word on any other wikis right now. People should update the short descriptions on Wikidata.

Adithyak1997 added a comment.EditedSep 14 2018, 6:00 PM

@DannyH and @Lydia_Pintscher . I would like to ask two questions to you both since you both have commented against the use of the magic word on malayalam wikipedia. My first question is: if English wikipedia can use a feature , then why can't it be used in other wikipedias? According to what I think, all the wikipedias are equal and needs to be developed equally. It is the duty of each and every wikipedian to make their wikipedia move forward and attain its objectives (or targets). In such a case, why do you block our wikipedia from enhancing to upper levels? My second question is: Malayalam wikipedia, as understood by me is that there are very less members i think a maximum of 2 or 3 who actually knows to edit and correct template errors(the same in the case of template creation also). There are thousands of templates required in malayalam wikipedia which, only through the help of english wikipedia can be created or worked correctly. In such a scenario, how do you think can our wikipedia become better without the help of these helpful features? I would just like to mention a statistic. Out of the 1422 templates needed as per Wanted templates in malayalam wikipedia(from special pages), 1199 are only due to this magic word problem.

@Adithyak1997, it's possible that there's a misunderstanding about what this template does. What are you hoping to do with this template?

Adithyak1997 added a comment.EditedSep 15 2018, 3:00 AM

What I need is, I would like to remove the sentence ഫലകം:SHORTDESC: from https://ml.wikipedia.org/wiki/%E0%B4%AB%E0%B4%B2%E0%B4%95%E0%B4%82:SHORTDESC template which can be seen on top of the page below the heading of the article ie. below ഫലകം:SHORTDESC

@Adithyak1997: What stops you from editing https://ml.wikipedia.org/wiki/%E0%B4%AB%E0%B4%B2%E0%B4%95%E0%B4%82:SHORTDESC and removing the sentence ഫലകം:SHORTDESC ? It is still unclear what are you hoping to do with this template and which underlying problem you try to solve.

Adithyak1997 added a comment.EditedSep 15 2018, 10:29 AM

I have got a problem related to the template template:shortdesc which I have stated in the page https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)#Template_doubt. I need a solution to that.

The question is which underlying problem you would like to solve by creating, setting up, using https://ml.wikipedia.org/wiki/ഫലകം:SHORTDESC on ml.wp.

Adithyak1997 added a comment.EditedSep 15 2018, 5:35 PM

@JJMC89, Thanks for solving the problem just by adding 7 bytes of data. To all the users who have currently subscribed to this task, the problem is currently resolved by JJMC89.

the problem is currently resolved

How? Link very welcome. :)

This was the change made.

@JJMC89, these templates seem to have been imported to several wikis. There's a list at https://www.wikidata.org/wiki/Q52154408 I don't think any of these are in use, however. I wonder whether any other templates have the same complications?

Tgr added a comment.Sep 18 2018, 4:31 PM

@JJMC89, these templates seem to have been imported to several wikis.

People using Special:Export to import enwiki templates with all dependencies, I guess?

We could make {{SHORTDESC}} be a noop instead of not recognized at all, on wikis where it is not supported. Not sure if it's worth the effort though. In general you should not expect complex templates blindly copied from enwiki to work. (Ideally, we'd have a central template repository at some point - that's T121470.)

Adithyak1997 added a comment.EditedSep 18 2018, 4:53 PM

First of all, I have already mentioned in the beginning of the post that in our malayalam wikipedia, there are not many users who know to create and edit templates. In such a case, we can rely only on wikipedias in which the modules are created and have knowledge about it. I am one such user who work on templates. In my case, I can handle small errors that have occurred. In this case, I was not able to find out the real problem. Also, I haven't ,till date used the Special:Export feature. How I create templates is through clicking the Wanted templates pages and also those present on random pages. @Whatamidoing-WMF, if I see any problems like this, I will first discuss it in Technical Help Desk of English wikipedia and if it is not resolved, I will be posting it here as done like this one.

Aklapper closed this task as Invalid.Sep 18 2018, 5:56 PM

In general you should not expect complex templates blindly copied from enwiki to work.

I am closing this task as invalid, in my understanding, as this task is about some on-wiki content.
On-wiki content is out of scope for Phabricator and not handled here in tasks.

@JJMC89, these templates seem to have been imported to several wikis. There's a list at https://www.wikidata.org/wiki/Q52154408 I don't think any of these are in use, however. I wonder whether any other templates have the same complications?

Yea. I disabled the templates at Q52154408 and Q52083446.

People using Special:Export to import enwiki templates with all dependencies, I guess?

Many are just copy/pasted from enwiki.