Page MenuHomePhabricator

CX2: Possible template adaptation issue preventing paragraph to be added to the translation
Closed, ResolvedPublic

Description

Trying to translate the 2nd paragraph of Curiosity (rover) from English into Spanish, the tool shows a machine translation error, even though the other paragraphs around it work fine.

One particularity of this paragraph is the presence of the Curiosity Mission Timer template which is a template with no parameters only available in English. This is not the most relevant template (only appearing in few articles), but may be a worth investigating the origin of the issue to identify potential problems in the way we process content that can affect other more common templates too.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 20 2018, 11:54 AM

In the master version of cxserver, this error is not happening. I am able to translate. But the issue related to communicating the unadapted template remains( T192271 )

In the master version of cxserver, this error is not happening. I am able to translate. But the issue related to communicating the unadapted template remains( T192271 )

I checked this in production and it works for me when using Apertium, but it fails when using Yandex:

With Yandex, I have achieved following results:

  • In production: TypeError: model.getSectionNumber is not a function error on client side. Server responds to the request with code 500 and no data in response. Reason for JS error is that 462886 is not yet deployed in production. Whether that causes failure on cxserver, I haven't investigated. @Pginer-WMF suggested we wait for the patch to get deployed.
  • Localhost, with cxserver on master: Everything goes without errors and the result is as follows:

The patch seems to be deployed to wmf.24 but the issue is still there. The article en: Curiosity (rover) has 37 Template:'s and there are two paragraphs that have the template but one can be translated and another is not and 'Machine translation failed' message persistently appears.

testing in enwiki (wmf.24) en->es
cannot be translated with Yandex In December 2012, ''Curiosity''{{'s}}...
can be translated with Yandex ''Curiosity''{{'s}} design will serve as the basis for the planned [[Mars 2020]] rover.

Apertium is able to handle '{{'s}} template:

In cxserver master, Yandex also able to translate this. It seems cxserver for production did not catch up the fixes. @KartikMistry please note,

Etonkovidova added a comment.EditedOct 10 2018, 11:34 PM

There are still Yandex-related errors (and 'Automation translation failed' warning is displayed') for attempting to translate the infobox and a paragraphs with {{Curiosity Mission Timer}}:

testwiki (wmf.24):

status	500
type	internal_error
title	Error
detail	Source text too long: en-es
method	POST
uri	/v2/translate/en/es/Yandex
Response payload	

1 {"status":500,"type":"internal_error","title":"Error","detail":"Source text too long: en-es","method":"POST","uri":"/v2/translate/en/es/Yandex"}

cx2-testing displays 403 error since Yandex is not enabled there:

Authorization header is not valid: JsonWebTokenError: secret or public key must be provided

However, Apertium handles translation successfully; the translation option is switched to Apertium when Yandex is failed.

@KartikMistry - any work is still needed here?

Re-checked in enwiki (wmf.26) - the issue with Yandex translation option is still there. Another example of not properly working Yandex option for translation is "Horton River (Canada)" (translating from en to es) - only references from a paragraph got translated:

On "Curiosity (rover)" article, Yandex fails with

TypeError: this.getRange(...) is null

ve.dm.LinearSelection.prototype.isCollapsed
ve.ce.ContentBranchNode.prototype.getRenderedContents
ve.ce.ContentBranchNode.prototype.renderContents
ve.ce.Surface.prototype.handleObservedChanges
ve.ce.SurfaceObserver.prototype.pollOnceInternal
ve.ce.SurfaceObserver.prototype.pollOnce
ve.ce.Surface.prototype.afterDocumentMouseDown

Etonkovidova moved this task from QA to Blocked on the Language-Team (Language-2018-October-December) board.

@Etonkovidova can you indicate which ticket this one is blocked on? is it T205420: CXServer fails with HTTP 500: "MT processing error: undefined" as mentioned in early comments?

Etonkovidova moved this task from QA to Blocked on the Language-Team (Language-2018-October-December) board.

@Etonkovidova can you indicate which ticket this one is blocked on? is it T205420: CXServer fails with HTTP 500: "MT processing error: undefined" as mentioned in early comments?

According to @Etonkovidova's last comment, this is blocked on T207445. Notice that the behavior is the same as in T207449, which is merged as duplicate into T207445.

Pginer-WMF closed this task as Resolved.Nov 1 2018, 8:07 AM
Pginer-WMF claimed this task.

Notice that the behavior is the same as in T207449, which is merged as duplicate into T207445.

I tested this and the issue is no longer happening, probably resolved as part of other improvements in the area.